Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 627288 - dev-lang/rust-1.19.0: Please use sane targets
Summary: dev-lang/rust-1.19.0: Please use sane targets
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Rust Project
URL:
Whiteboard:
Keywords:
: 638584 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-08-08 02:11 UTC by Jan Vesely
Modified: 2018-05-14 16:14 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Vesely 2017-08-08 02:11:51 UTC
dev-lang/rust includes bundled llvm-4.0.1 (presumably with patches).

I understand that support for system-llvm was dropped,
but the bundled version is configured using:
"-DLLVM_TARGETS_TO_BUILD=X86;ARM;AArch64;Mips;PowerPC;SystemZ;JSBackend;MSP430;Sparc;NVPTX;Hexagon"
I don't know how those targets were selected, but I'm pretty sure that it won't need most of those targets on my machine.
Comment 1 Perfect Gentleman 2017-11-27 09:58:43 UTC
(In reply to Jan Vesely from comment #0)
done in pg_overlay
Comment 2 Doug Goldstein (RETIRED) gentoo-dev 2018-03-11 23:06:58 UTC
*** Bug 638584 has been marked as a duplicate of this bug. ***
Comment 3 Dirkjan Ochtman gentoo-dev 2018-05-14 14:39:35 UTC
Fixed in dev-lang/rust-1.26.0. The ebuild now uses LLVM_TARGETS to decide what targets to build.
Comment 4 Larry the Git Cow gentoo-dev 2018-05-14 14:41:07 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=71eba02631d5129e1e4c2729f4234727d7bac498

commit 71eba02631d5129e1e4c2729f4234727d7bac498
Author:     Dirkjan Ochtman <djc@gentoo.org>
AuthorDate: 2018-05-14 13:37:00 +0000
Commit:     Dirkjan Ochtman <djc@gentoo.org>
CommitDate: 2018-05-14 14:38:35 +0000

    dev-lang/rust: version bump to 1.26.0
    
    Use LLVM_TARGETS to decide which targets to build for bundled LLVM. Use
    xz-compressed tarballs where possible to limit bandwidth/storage.
    
    Fixes: https://bugs.gentoo.org/627288
    Fixes: https://bugs.gentoo.org/655600
    Package-Manager: Portage-2.3.24, Repoman-2.3.6

 dev-lang/rust/Manifest           |   4 +
 dev-lang/rust/rust-1.26.0.ebuild | 181 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 185 insertions(+)