Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 626762 - www-client/firefox-54.0.1 fails to build against gcc-7.1: Error while running startup cache precompilation
Summary: www-client/firefox-54.0.1 fails to build against gcc-7.1: Error while running...
Status: RESOLVED DUPLICATE of bug 617882
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-7
  Show dependency tree
 
Reported: 2017-08-01 09:47 UTC by Chí-Thanh Christopher Nguyễn
Modified: 2017-08-01 12:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.xz (build.log.xz,181.91 KB, application/x-xz)
2017-08-01 09:47 UTC, Chí-Thanh Christopher Nguyễn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chí-Thanh Christopher Nguyễn gentoo-dev 2017-08-01 09:47:50 UTC
Created attachment 487522 [details]
build.log.xz

Building www-client/firefox-54.0.1 with gcc-7.1 fails during src_install

Executing /var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/ff/dist/bin/xpcshell -g /var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/ff/dist/bin/ -a /var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/ff/dist/bin/ -f /var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/toolkit/mozapps/installer/precompile_cache.js -e precompile_startupcache("resource://gre/");
Traceback (most recent call last):
  File "/var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/toolkit/mozapps/installer/packager.py", line 397, in <module>
    main()
  File "/var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/toolkit/mozapps/installer/packager.py", line 391, in main
    args.source, gre_path, base)
  File "/var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/toolkit/mozapps/installer/packager.py", line 165, in precompile_cache
    errors.fatal('Error while running startup cache precompilation')
  File "/var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/python/mozbuild/mozpack/errors.py", line 103, in fatal
    self._handle(self.FATAL, msg)
  File "/var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/python/mozbuild/mozpack/errors.py", line 98, in _handle
/bin/xpcshell -g /var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/
ff/dist/bin/ -a /var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/f
f/dist/bin/ -f /var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/to
olkit/mozapps/installer/precompile_cache.js -e precompile_startupcache("resource
://gre/");
Traceback (most recent call last):
  File "/var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/toolkit/m
ozapps/installer/packager.py", line 397, in <module>
    main()
  File "/var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/toolkit/m
ozapps/installer/packager.py", line 391, in main
    args.source, gre_path, base)
  File "/var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/toolkit/m
ozapps/installer/packager.py", line 165, in precompile_cache
    errors.fatal('Error while running startup cache precompilation')
  File "/var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/python/mo
zbuild/mozpack/errors.py", line 103, in fatal
    self._handle(self.FATAL, msg)
  File "/var/tmp/portage/www-client/firefox-54.0.1/work/firefox-54.0.1/python/mo
zbuild/mozpack/errors.py", line 98, in _handle
    raise ErrorMessage(msg)
mozpack.errors.ErrorMessage: Error: Error while running startup cache precompilation

A Google search suggests that the following two bug reports might be related, although xpcshell runs only for a couple of minutes before the build fails.

https://bugzilla.mozilla.org/show_bug.cgi?id=1362771
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80706
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2017-08-01 09:48:53 UTC
# emerge --info www-client/firefox
Portage 2.3.6 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop, gcc-7.1.0, glibc-2.23-r4, 4.12.3-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.12.3-gentoo-x86_64-AMD_A12-9800_RADEON_R7,_12_COMPUTE_CORES_4C+8G-with-gentoo-2.3
KiB Mem:    15915960 total,  15237268 free
KiB Swap:   16072700 total,  13543936 free
Timestamp of repository gentoo: Mon, 31 Jul 2017 13:15:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28 p1.2) 2.28
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26.3::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.28-r2::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 7.1.0-r1::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage/
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -pipe -march=bdver4"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O3 -pipe -march=bdver4"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="https://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 java jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt5 readline sdl seccomp session spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vaapi vorbis webp wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 fma4 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" L10N="de en fa vi" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="amdgpu radeon radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 Jory A. Pratt gentoo-dev 2017-08-01 12:24:35 UTC

*** This bug has been marked as a duplicate of bug 617882 ***