Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 626342 - <dev-db/mongodb-3.4.4: src/mongo/shell/bench.cpp:677:9: error: 'string' was not declared in this scope
Summary: <dev-db/mongodb-3.4.4: src/mongo/shell/bench.cpp:677:9: error: 'string' was n...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ultrabug
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-27 10:11 UTC by Jura
Modified: 2017-09-22 04:30 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,77.33 KB, text/x-log)
2017-07-27 10:11 UTC, Jura
Details
Modified ebuild for patch (mongodb-3.0.14.ebuild,4.34 KB, text/plain)
2017-09-20 18:01 UTC, Jenkler
Details
Patch for 3.0.14 (mongodb-3.0.14-fix-std-string.patch,2.29 KB, patch)
2017-09-20 18:03 UTC, Jenkler
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jura 2017-07-27 10:11:55 UTC
Created attachment 486962 [details]
build.log

Portage 2.3.6 (python 3.6.1-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-6.3.0, glibc-2.24-r3, 4.12.3-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.12.3-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700K_CPU_@_4.00GHz-with-gentoo-2.4.1
KiB Mem:    32909776 total,  12281072 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Thu, 27 Jul 2017 09:24:48 +0000
sh bash 4.4_p12
ld GNU ld (Gentoo 2.28 p1.2) 2.28
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.2::gentoo
dev-lang/python:          2.7.13::gentoo, 3.6.1-r1::gentoo
dev-util/cmake:           3.9.0::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1::gentoo
sys-apps/openrc:          0.28::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r3::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.15.1::gentoo
sys-devel/binutils:       2.28-r2::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo, 6.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.10::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo.git
    priority: -1000
    sync-git-clone-extra-opts: --branch master

masterlay
    location: /var/lib/layman/masterlay
    masters: gentoo masterlay
    priority: 50

my-gnome
    location: /var/lib/layman/my-gnome
    masters: gentoo
    priority: 50

ring-overlay
    location: /var/lib/layman/ring-overlay
    masters: gentoo
    priority: 50

steam-overlay
    location: /var/lib/layman/steam-overlay
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -finline-functions -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/chromium/policies/managed/chrome-gnome-shell.json /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/opt/chrome/policies/managed/chrome-gnome-shell.json /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native -finline-functions -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 amr apng auto-hinter avahi avx avx2 berkdb branding bzip2 cairo cdda cdr cli colord cracklib crypt cuda cue cups cxx dbus dri dts dvd dvdr eds egl emboss encode evo exif extras faac faad fam ffmpeg firefox flac foomaticdb fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm graphite gstreamer gtk gtk3 iconv id3tag introspection ipv6 jack joystick jpeg lame lcms libnotify libsecret mad mmx mng modules mp3 mp4 mpeg mtp multilib nautilus ncurses networkmanager nls nm-applet nptl ogg openal opengl openmp pam pango pcre pdf png policykit ppds pulseaudio python qt3support readline s3tc sdl seccomp session spell sse sse2 sse4_1 sse4_2 ssl ssse3 startup-notification svg systemd tcpd theora threads tiff tracker truetype udev udisks unicode upower usb vaapi vdpau video vim vim-syntax vorbis vpx wayland wxwidgets x264 x265 xattr xcb xinerama xml xv xvid zlib zsh-completion" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3 avx2 avx" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev keyboard mouse joystick" KERNEL="linux" L10N="ru" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru ru_RU" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_conn limit_req map memcached proxy referer rewrite scgi split_clients ssi upstream_ip_hash userid uwsgi spdy gunzip gzip_static echo random_index" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24" SANE_BACKENDS="pixma" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

dev-db/mongodb-3.4.4::gentoo was built with the following:
USE="ssl tools -debug -kerberos -libressl -mms-agent -test" ABI_X86="(64)"
CFLAGS="-pipe -finline-functions -fomit-frame-pointer"
CXXFLAGS="-pipe -finline-functions -fomit-frame-pointer"
Comment 1 Andrés Becerra Sandoval 2017-07-31 16:48:27 UTC
I am having the same problem with dev-db/mongodb-3.4.6
Comment 2 Ultrabug gentoo-dev 2017-07-31 16:53:59 UTC
Just in case cause I've been having a similar error: could you try to rebuild boost (emerge -1 boost) and retry afterwards ?
Comment 3 Andrés Becerra Sandoval 2017-08-02 15:58:42 UTC
Junra, Ultrabug:

Now it builds. Syncing portage brought the patch mongodb-3.4.4-Replace-string-with-explicit-std-string.patch!
Comment 4 Stanislav Zapolsky 2017-08-30 11:18:03 UTC
I see the same error with versions 3.2.12, 3.2.13, 3.2.15, and 3.0.14. I can reproduce it on 2 different gentoo systems. Recompiling boost didn't help, but I was able to modify the patch mentioned above to compile 3.2.12 version.
Comment 5 Tony Vroon gentoo-dev 2017-09-01 14:08:10 UTC
Any chance of the 3.4.4 fix being backported to the current stable?
Comment 6 Tomáš Mózes 2017-09-08 04:12:16 UTC
I think this should handle it:
https://github.com/gentoo/gentoo/pull/5527
Comment 7 darin hensley 2017-09-12 03:49:09 UTC
I need this patch also. Can the PR request be approved and merged, please?
Comment 8 Jenkler 2017-09-19 18:46:49 UTC
It must be higher prio to fix stable packages right? If 3.0.14 should be marked as stable as it is.

Is it possible to backport this patch to latest stable (3.0.14) ?
Comment 9 Jenkler 2017-09-20 18:01:25 UTC
Created attachment 495632 [details]
Modified ebuild for patch

Here is the new ebuild file!
Comment 10 Jenkler 2017-09-20 18:03:37 UTC
Created attachment 495634 [details, diff]
Patch for 3.0.14

Here is a working patch for 3.0.14. please confirm and add it to portage!
Comment 11 Jenkler 2017-09-20 18:44:15 UTC
(In reply to Tony Vroon from comment #5)
> Any chance of the 3.4.4 fix being backported to the current stable?

I have fixed a patch for 3.0.14 (Current stable) now. Compile works!

@Ultrabug Can you add this patch to gentoo.git?
Comment 12 Patrice Clement gentoo-dev 2017-09-21 19:54:08 UTC
commit 4fb6b5123a834fbb1d1726aaeebee2ec3ad79fa4 (HEAD -> master, origin/master, origin/HEAD)
Author:     Tomas Mozes <hydrapolic@gmail.com>
AuthorDate: Tue Sep 5 18:09:31 2017 +0200
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: Thu Sep 21 21:50:01 2017 +0200

dev-db/mongodb: fix building with newer libpcre/glibc.

Gentoo-Bug: https://bugs.gentoo.org/580768
Gentoo-Bug: https://bugs.gentoo.org/625148
Gentoo-Bug: https://bugs.gentoo.org/626342

Package-Manager: Portage-2.3.8, Repoman-2.3.2

...6-Replace-string-with-explicit-std-string.patch | 283 +++++++++++++++++++++
dev-db/mongodb/mongodb-3.2.16.ebuild               |  23 +-
2 files changed, 294 insertions(+), 12 deletions(-)
create mode 100644 dev-db/mongodb/files/mongodb-3.2.16-Replace-string-with-explicit-std-string.patch