Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 625986 - dev-util/patdiff-0.9.0 : (.text+<snip>): undefined reference to makedev
Summary: dev-util/patdiff-0.9.0 : (.text+<snip>): undefined reference to makedev
Status: RESOLVED DUPLICATE of bug 627946
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Team for the ML programming language family
URL:
Whiteboard: ~arch only
Keywords:
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2017-07-23 11:17 UTC by Toralf Förster
Modified: 2018-04-27 23:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.75 KB, text/plain)
2017-07-23 11:17 UTC, Toralf Förster
Details
dev-util:patdiff-0.9.0:20170723-043118.log (dev-util:patdiff-0.9.0:20170723-043118.log,7.19 KB, text/plain)
2017-07-23 11:17 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,292.07 KB, text/plain)
2017-07-23 11:17 UTC, Toralf Förster
Details
environment (environment,17.07 KB, text/plain)
2017-07-23 11:17 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,54.98 KB, application/x-bzip)
2017-07-23 11:17 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,7.61 KB, application/x-bzip)
2017-07-23 11:17 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-07-23 11:17:33 UTC
/usr/lib64/ocaml/core/libcore_stubs.a(unix_stubs.o): In function `unix_mknod_stub':
(.text+0x10e1): undefined reference to `makedev'
collect2: error: ld returned 1 exit status
File "caml_startup", line 1:
Error: Error during linking

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0_libressl_20170716-133001

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python3.5 (fallback)
  [4]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
Comment 1 Toralf Förster gentoo-dev 2017-07-23 11:17:36 UTC
Created attachment 486538 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-07-23 11:17:39 UTC
Created attachment 486540 [details]
dev-util:patdiff-0.9.0:20170723-043118.log
Comment 3 Toralf Förster gentoo-dev 2017-07-23 11:17:42 UTC
Created attachment 486542 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-07-23 11:17:45 UTC
Created attachment 486544 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-07-23 11:17:48 UTC
Created attachment 486546 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-07-23 11:17:51 UTC
Created attachment 486548 [details]
temp.tbz2
Comment 7 Andreas K. Hüttel gentoo-dev 2017-10-20 20:29:58 UTC
Ping - this is now blocking glibc-2.25 stabilization.
Comment 8 Alexis Ballier gentoo-dev 2017-10-23 12:04:50 UTC

*** This bug has been marked as a duplicate of bug 627946 ***