Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 625730 - net-libs/nDPI-2.0 : FAIL: do.sh
Summary: net-libs/nDPI-2.0 : FAIL: do.sh
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2017-07-20 16:08 UTC by Toralf Förster
Modified: 2019-12-28 01:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.35 KB, text/plain)
2017-07-20 16:08 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,214.73 KB, text/plain)
2017-07-20 16:08 UTC, Toralf Förster
Details
environment (environment,67.40 KB, text/plain)
2017-07-20 16:08 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,23.28 KB, application/x-bzip)
2017-07-20 16:08 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,18.30 KB, application/x-bzip)
2017-07-20 16:08 UTC, Toralf Förster
Details
net-libs:nDPI-2.0:20170720-131028.log (net-libs:nDPI-2.0:20170720-131028.log,150.18 KB, text/plain)
2017-07-20 16:08 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,25.99 KB, application/x-bzip)
2017-07-20 16:08 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-07-20 16:08:03 UTC
make[2]: Entering directory '/var/tmp/portage/net-libs/nDPI-2.0/work/nDPI-2.0/tests'
make[3]: Entering directory '/var/tmp/portage/net-libs/nDPI-2.0/work/nDPI-2.0/tests'
FAIL: do.sh
============================================================================
Testsuite summary for libndpi 2.0.0
============================================================================

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 13.0_20170716-131855

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python3.5 (fallback)
  [4]   python2.7 (fallback)
  [5]   pypy3 (fallback)
  [6]   pypy (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
  [2]   ruby22 (with Rubygems)
Comment 1 Toralf Förster gentoo-dev 2017-07-20 16:08:06 UTC
Created attachment 486022 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-07-20 16:08:09 UTC
Created attachment 486024 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-07-20 16:08:12 UTC
Created attachment 486026 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-07-20 16:08:15 UTC
Created attachment 486028 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-07-20 16:08:18 UTC
Created attachment 486030 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-07-20 16:08:21 UTC
Created attachment 486032 [details]
net-libs:nDPI-2.0:20170720-131028.log
Comment 7 Toralf Förster gentoo-dev 2017-07-20 16:08:25 UTC
Created attachment 486034 [details]
temp.tbz2
Comment 8 Carlo 2018-01-22 22:58:23 UTC
The issue is 

ERROR: could not open pcap file pcap/nintendo.pcap: invalid file capture length 524288, bigger than maximum of 262144


which boils down to a libpcap issue, see https://bugzilla.redhat.com/show_bug.cgi?id=1486022

It's probably about time to grab a snapshot form master, instead of adding patch after patch to libpcap-1.8.1. This relates to bug 637592 as well.