Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 625240 - dev-python/matplotlib-2.0.2 File "work/matplotlib-2.0.2-python2_7/setupext.py", line 1328, in check if not is_min_version(six.__version__, self.min_version): AttributeError: 'module' object has no attribute '__version
Summary: dev-python/matplotlib-2.0.2 File "work/matplotlib-2.0.2-python2_7/setupext.py...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-15 19:55 UTC by Dominique Michel
Modified: 2017-10-19 08:25 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info '=dev-python/matplotlib-2.0.2::gentoo' (emerge.info,18.23 KB, text/plain)
2017-07-15 19:57 UTC, Dominique Michel
Details
build log (build.log,4.92 KB, text/x-log)
2017-07-15 20:02 UTC, Dominique Michel
Details
environment file (environment,169.17 KB, text/plain)
2017-07-15 20:09 UTC, Dominique Michel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Michel 2017-07-15 19:55:25 UTC
>>> Compiling source in /var/tmp/portage/dev-python/matplotlib-2.0.2/work/matplotlib-2.0.2 ...
 * python2_7: running distutils-r1_run_phase python_compile
/usr/bin/python2.7 setup.py build build --build-lib=/var/tmp/portage/dev-python/matplotlib-2.0.2/work/matplotlib-2.0.2-python2_7/build/build/lib
============================================================================
Edit setup.cfg to change the build options

BUILDING MATPLOTLIB
            matplotlib: yes [2.0.2]
                python: yes [2.7.13 (default, Apr 28 2017, 20:40:18)  [GCC
                        5.4.0]]
              platform: yes [linux2]

REQUIRED DEPENDENCIES AND EXTENSIONS
                 numpy: yes [version 1.13.0]
Traceback (most recent call last):
  File "setup.py", line 184, in <module>
    result = package.check()
  File "/var/tmp/portage/dev-python/matplotlib-2.0.2/work/matplotlib-2.0.2-python2_7/setupext.py", line 1328, in check
    if not is_min_version(six.__version__, self.min_version):
AttributeError: 'module' object has no attribute '__version__'
 * ERROR: dev-python/matplotlib-2.0.2::gentoo failed (compile phase):
 *   (no error message)
Comment 1 Dominique Michel 2017-07-15 19:55:53 UTC
# emerge -a matplotlib

These are the packages that would be merged, in order:

[ebuild     U  ] dev-python/matplotlib-2.0.2::gentoo [1.5.3-r1::gentoo] USE="cairo examples qt4 wxwidgets -doc -excel -gtk2 -gtk3 -latex -pyside -qt5 {-test} -tk (-fltk%)" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6" 0 KiB
Comment 2 Dominique Michel 2017-07-15 19:57:59 UTC
Created attachment 484914 [details]
emerge --info '=dev-python/matplotlib-2.0.2::gentoo'
Comment 3 Dominique Michel 2017-07-15 20:02:23 UTC
Created attachment 484916 [details]
build log
Comment 4 Dominique Michel 2017-07-15 20:07:32 UTC
# emerge -pqv '=dev-python/matplotlib-2.0.2::gentoo'
[ebuild     U ] dev-python/matplotlib-2.0.2 [1.5.3-r1] USE="cairo examples qt4 wxwidgets -doc -excel -gtk2 -gtk3 -latex -pyside -qt5 {-test} -tk (-fltk%)" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
Comment 5 Dominique Michel 2017-07-15 20:09:17 UTC
Created attachment 484918 [details]
environment file
Comment 6 François Bissey 2017-10-18 22:10:26 UTC
Version of setuptools used? I think I have seen that before when setuptools was a lower version than needed.
Comment 7 Jonas Stein gentoo-dev 2017-10-19 08:23:20 UTC
which version is needed?
Comment 8 François Bissey 2017-10-19 08:25:24 UTC
(In reply to Jonas Stein from comment #7)
> which version is needed?

35.x I think, but I am on 36.x now.