Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 624712 (CVE-2017-9988, CVE-2017-9989) - <media-libs/ming-0.20181112: Multiple vulnerabilities
Summary: <media-libs/ming-0.20181112: Multiple vulnerabilities
Status: RESOLVED FIXED
Alias: CVE-2017-9988, CVE-2017-9989
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard: B3 [glsa+ cve]
Keywords:
Depends on: CVE-2018-5251, CVE-2018-5294, CVE-2018-6315, CVE-2018-6358, CVE-2018-6359
Blocks:
  Show dependency tree
 
Reported: 2017-07-12 15:28 UTC by Agostino Sarubbo
Modified: 2019-04-24 23:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2017-07-12 15:28:57 UTC
From ${URL} :

CVE-2017-9988

The readEncUInt30 function in util/read.c in libming 0.4.8 mishandles memory allocation. A crafted input will lead to a remote denial of service (NULL pointer dereference) attack against parser.c.

https://github.com/libming/libming/issues/85

CVE-2017-9989

util/outputtxt.c in libming 0.4.8 mishandles memory allocation. A crafted input will lead to a remote denial of service (NULL pointer dereference) attack.

https://github.com/libming/libming/issues/86


@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2019-04-05 01:01:35 UTC
Both are fixed in master and a snapshot release has been added for the last commit (20181112) upstream.
Comment 2 Yury German Gentoo Infrastructure gentoo-dev Security 2019-04-19 01:44:26 UTC
GLSA Vote: Yes
Comment 3 GLSAMaker/CVETool Bot gentoo-dev 2019-04-24 23:58:20 UTC
This issue was resolved and addressed in
 GLSA 201904-24 at https://security.gentoo.org/glsa/201904-24
by GLSA coordinator Aaron Bauman (b-man).