Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 62317 - Emerging games-arcade/jumpnbump fails.
Summary: Emerging games-arcade/jumpnbump fails.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Games
Keywords: Bug
Depends on:
Reported: 2004-08-30 17:28 UTC by Johannes Athmer
Modified: 2004-08-31 12:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Athmer 2004-08-30 17:28:02 UTC
Well the summary says everything.
Emerging jumpnbump installs the following ebuilds:
[ebuild  N    ] media-libs/smpeg-0.4.4-r4  +X -debug +gtk +opengl  0 kB
[ebuild  N    ] media-libs/sdl-mixer-1.2.5-r1  +mikmod +mpeg +oggvorbis  914 kB
[ebuild  N    ] games-arcade/jumpnbump-1.50  +X -dedicated -fbcon +svga  387 kB

smpeg and sdl-mixer compile correctly, while compiling jumpnbump gives the following error:
main.c:994: Warnung: unused variable `c4'
gcc -o jumpnbump fireworks.o main.o menu.o filter.o -lm `sdl-config --libs` -lSDL_mixer -lSDL_net sdl.a
/usr/lib/ undefined reference to `_Unwind_GetIP'
/usr/lib/ undefined reference to `_Unwind_Resume_or_Rethrow'
/usr/lib/ undefined reference to `_Unwind_GetRegionStart'
/usr/lib/ undefined reference to `_Unwind_Resume'
/usr/lib/ undefined reference to `_Unwind_DeleteException'
/usr/lib/ undefined reference to `_Unwind_RaiseException'
/usr/lib/ undefined reference to `_Unwind_SetIP'
/usr/lib/ undefined reference to `_Unwind_GetTextRelBase'
/usr/lib/ undefined reference to `_Unwind_GetLanguageSpecificData'
/usr/lib/ undefined reference to `_Unwind_SetGR'
/usr/lib/ undefined reference to `_Unwind_GetDataRelBase'
collect2: ld returned 1 exit status
make: *** [jumpnbump] Fehler 1

!!! ERROR: games-arcade/jumpnbump-1.50 failed.
!!! Function src_compile, Line 59, Exitcode 2
!!! emake failed

My emerge --info:
Portage 2.0.50-r10 (default-x86-1.4, gcc-3.3.4, glibc-, 2.4.26-gentoo-r9)
System uname: 2.4.26-gentoo-r9 i686 Pentium III (Coppermine)
Gentoo Base System version 1.4.16
distcc 2.13 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
CFLAGS="-O3 -march=pentium3 -fprefetch-loop-arrays -funroll-loops -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium3 -fprefetch-loop-arrays -funroll-loops -pipe"
FEATURES="autoaddcvs ccache sandbox"
USE="X alsa apache2 apm avi berkdb cdr crypt cups divx4linux encode foomaticdb gdbm gif gpm gtk gtk2 imlib jpeg libg++ libwww lufsusermount mad mikmod mmx motif mpeg mysql ncurses nls oggvorbis opengl oss pam pdflib perl png python quicktime readline sdl slang spell sse ssl svga tcpd theora truetype x86 xface xml2 xmms xv xvid zlib"
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2004-08-31 02:13:19 UTC
Bah.  more broken makefiles.  wait 30m; resync and try it again.  Should be worked around for now.
Comment 2 Johannes Athmer 2004-08-31 07:14:46 UTC
It's still the same.
I don't see any change. No other version of the packages, no new entry in the ChangeLogs - nothing?
Comment 3 Mr. Bones. (RETIRED) gentoo-dev 2004-08-31 10:29:36 UTC
Make sure you get version 1.4 of the ebuild.
Comment 4 Mr. Bones. (RETIRED) gentoo-dev 2004-08-31 10:51:55 UTC
Hmmm, actually, the new makefile's not going to help you.  You seem to have some messed up libraries there.

look at the output of emerge -vep jumpnbump

Start at the bottom of the list and remerge things until the jumpnbump build succeeds.
Comment 5 Mr. Bones. (RETIRED) gentoo-dev 2004-08-31 11:00:24 UTC
Might try a revdep-rebuild too
Comment 6 Johannes Athmer 2004-08-31 11:53:14 UTC
Thanks alot! After 'emerge intltool XML-Parser libsdl' everything works. I suppose there was an error in libsdl.
Comment 7 Mr. Bones. (RETIRED) gentoo-dev 2004-08-31 12:30:42 UTC
Ok, glad it's working for you.