Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 623014 - net-wireless/wpa_supplicant-2.6-r1 wired mode stopped working when no wireless in linux kernel
Summary: net-wireless/wpa_supplicant-2.6-r1 wired mode stopped working when no wireles...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Rick Farina (Zero_Chaos)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-29 09:11 UTC by Pavel Semerad
Modified: 2018-03-13 12:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Semerad 2017-06-29 09:11:55 UTC
Helo,

I am using wpa_supplicant at wired network and linux kernel has no wireless compiled in.
From version 2.6-r1 wpa_supplicant stopped working. It enabled config option CONFIG_MATCH_IFACE. This is output of running:

# /usr/sbin/wpa_supplicant -i eth0 -D wired -c /etc/wpa_supplicant/config.conf -P /run/wpa_supplicant.pid
Successfully initialized wpa_supplicant
nl80211: 'nl80211' generic netlink not found
Failed to initialize driver 'nl80211'

There is problem in function "wpa_supplicant_init_match" which wants to use driver nl80211 (first one) to handle interfaces (only when that CONFIG_MATCH_INTERFACE).
But this driver is not working as there is no wireless compiled in kernel and wpa_supplicant stops.
Config for drivers nl80211, wext and wired are set at ebuild and nl8011 is first used in code so there is no possibility to make that wired driver first one to make it to work (except to modify ebuild or code).

emerge --info is nonsense here so not attaching it for now.

Pavel Semerad
Comment 1 charles17 2017-07-28 13:54:04 UTC
Sounds like for your use case another USE flag were needed?

See https://forums.gentoo.org/viewtopic-t-1036958-start-13.html
Comment 2 Pavel Semerad 2017-07-29 09:09:47 UTC
Yes, if CONFIG_MATCH_IFACE will be dependent on USE flag, then it will work as before for my use case.
Or another USE flags which will disable nl80211 and maybe wext to have wired driver as the first one.
Comment 3 charles17 2017-08-04 06:59:15 UTC
(In reply to Pavel Semerad from comment #0)
> [...]
> There is problem in function "wpa_supplicant_init_match" which wants to use
> driver nl80211 (first one) to handle interfaces (only when that
> CONFIG_MATCH_INTERFACE).
> But this driver is not working as there is no wireless compiled in kernel
> and wpa_supplicant stops.
> Config for drivers nl80211, wext and wired are set at ebuild and nl8011 is
> first used in code so there is no possibility to make that wired driver
> first one to make it to work (except to modify ebuild or code).
> [...]

Sounds like a source code bug.  Adding another USE flag to workaround it isn't a proper solution.  Please report upstream (http://lists.infradead.org/pipermail/hostap/) so they can fix it for next version.  Don't forget to link your upstream item here.
Comment 4 Pavel Semerad 2017-08-04 10:52:53 UTC
  I can try it report upstream, but it can be considered not as bug but a feature for such combination of CONFIG directives used in ebuild (it can be made working
with another CONFIG settings).
  Someone in gentoo decided that setting CONFIG_MATCH_INTERFACE doesn't broke things (https://forums.gentoo.org/viewtopic-p-7974604.html#8005096) and this isn't true in my use case.
Comment 5 charles17 2017-08-04 12:21:17 UTC
(In reply to Pavel Semerad from comment #4)
>   I can try it report upstream, but it can be considered not as bug [...]

Just try and we'll see their reply.