Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 62170 - Porting: fortune-mod-all
Summary: Porting: fortune-mod-all
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: Gentoo non-Linux Team
URL: http://forums.gentoo.org/viewtopic.ph...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-29 19:01 UTC by Ben Powers
Modified: 2008-10-21 20:49 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Powers 2004-08-29 19:01:33 UTC
fortune-mod-all does not emerge, 

if [ 0 = 1 ] ; then \
    cd off && make OCOOKIEDIR=/usr/share/fortune/off ; fi
if [ 0 = 1 ] ; then \
    cd html && make WCOOKIEDIR=/usr/share/fortune/html; fi
gcc -s -o fortune fortune.o 
ld: Undefined symbols:
_re_comp
_re_exec
make[1]: *** [fortune] Error 1
make: *** [fortune-bin] Error 2

Reproducible: Always
Steps to Reproduce:
1.emerge fortune-mod-all
2.emerge sync
3.USE=offensive fortune-mod-all
Actual Results:  
it gave the above error

Expected Results:  
should have emerged successfuly

!!! Using `which gcc` to gcc locate version, this may break
!!! DISTCC, installing gcc-config and setting your current gcc
!!! profile will fix this
Portage 20040726 (default-macos-10.3, gcc-3.3, unavailable, 7.5.0 Power Macintosh powerpc)
===============================================================
==
System uname: 7.5.0 Power Macintosh powerpc
macos-20040726
distcc 2.0.1-zeroconf powerpc-apple-darwin7.0 (protocol 1) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.57,sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.6.3,sys-devel/automake-1.8.3
Binutils: 
ACCEPT_KEYWORDS="macos ppc"
AUTOCLEAN="yes"
CFLAGS="-mcpu=7450 -O2 -pipe -maltivec -mabi=altivec -mpowerpc-gfxopt"
CHOST="powerpc-apple-darwin"
COMPILER=""
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/
qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-mcpu=7450 -O2 -pipe -maltivec -mabi=altivec -mpowerpc-gfxopt"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect cvs keepwork"
GENTOO_MIRRORS="http://gentoo.osuosl.org/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="macos berkdb cdr ldap mysql perl python ruby"
Comment 1 dario 2004-08-31 10:32:54 UTC
I get many errors of this kind, all due to bad Makefile missing a library flag (such as "-liconv" or "-lresolv").

Look at all the Makefile* in the src tree, isn't hard to find the bug.
Comment 2 Hasan Khalil (RETIRED) gentoo-dev 2005-01-20 21:47:36 UTC
Any status update on this?
Comment 3 gareth 2005-05-26 09:37:54 UTC
I get the similar kind of errors and the recode shared library is not installing 
in /usr/lib

gcc -s -o fortune fortune.o -lrecode
ld: Undefined symbols:
_error
make[1]: *** [fortune] Error 1
make: *** [fortune-bin] Error 2

!!! ERROR: games-misc/fortune-mod-1.99.1-r1 failed.
!!! Function src_install, Line 63, Exitcode 2


Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-10-21 20:49:26 UTC
Super old bug, forgotten about.

osx project is dead, use Gentoo Prefix instead.

http://forums.gentoo.org/viewtopic-t-697908.html