Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 618922 - Upgrading to Qt 4.8.7 prevents KMail2 maildir service from starting
Summary: Upgrading to Qt 4.8.7 prevents KMail2 maildir service from starting
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-19 10:57 UTC by peter@prh.myzen.co.uk
Modified: 2017-06-13 08:28 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter@prh.myzen.co.uk 2017-05-19 10:57:27 UTC
Today portage offered me upgrades of 15 dev-qt packages from 4.8.6 to 4.8.7. After the upgrade KMail could not start its local mail service and KMail stayed off-line. It was not usable at all: the folder list showed the number of messages in each folder, including the one unread message, but the message list and message panel were blank.

Masking the 4.8.7 versions and restoring the 4.8.6 enabled KMail to operate normally.

I don't know which particular qt package was responsible, but it must be one of these 15:
dev-qt/qtcore-4.8.7
dev-qt/qttranslations-4.8.7
dev-qt/qtscript-4.8.7
dev-qt/qtgui-4.8.7
dev-qt/qtsql-4.8.7
dev-qt/qt3support-4.8.7
dev-qt/qtdbus-4.8.7
dev-qt/qtsvg-4.8.7
dev-qt/qttest-4.8.7
dev-qt/qtopengl-4.8.7
dev-qt/qtmultimedia-4.8.7
dev-qt/qtxmlpatterns-4.8.7
dev-qt/qtdeclarative-4.8.7
dev-qt/qtwebkit-4.8.7
dev-qt/designer-4.8.7


Reproducible: Always




$ emerge --info
Portage 2.3.5 (python 2.7.12-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-5.4.0, glibc-2.23-r3, 4.9.16-gentoo x86_64)
=================================================================
System uname: Linux-4.9.16-gentoo-x86_64-Intel-R-_Core-TM-_i7-5820K_CPU_@_3.30GHz-with-gentoo-2.3
KiB Mem:    32842116 total,  18134724 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of repository gentoo: Fri, 19 May 2017 08:24:05 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.27 p1.0) 2.27
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r1::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.26.2::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            4.9.4::gentoo, 5.4.0-r3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo.git
    masters: gentoo
    priority: -1000

prh-local
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* !PUEL"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=haswell -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/applications/boincmgr.desktop /usr/share/config /usr/share/gkrellm2/themes/invisible /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/init.d /etc/pam.d /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=haswell -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--backtrack=100 --autounmask=n --with-bdeps y --keep-going --nospinner"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.mirrorservice.org/sites/distfiles.gentoo.org/         ftp://mirror.bytemark.co.uk/gentoo/         http://mirror.bytemark.co.uk/gentoo/    http://mirror.qubenet.net/mirror/gentoo/    http://mirrors.evowise.com/gentoo/      http://www.mirrorservice.org/sites/distfiles.gentoo.org/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j 24 -l 60"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac gdbm gif glamor gpm gtk handbook iconv icu ipv6 jpeg kde kipi kwallet lcms libnotify mad mng modules mp3 mp4 mpeg mtp multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session spell ssl startup-notification svg symlink tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xattr xcb xcomposite xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en-GB en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="pdfimport" LINGUAS="en_GB en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="amdgpu radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Erik Quaeghebeur 2017-05-19 11:01:56 UTC
I can confirm this. Similar issue with IMAP resource. Possibly similar issue with window theme. (Not filing separate bugs yet, because it feels all like the same issue to me.)
Comment 2 Andreas K. Hüttel gentoo-dev 2017-05-19 12:15:51 UTC
Did you stop and re-start all parts of "KDE"? (Ideally, log out and back in again?)
Comment 3 Erik Quaeghebeur 2017-05-19 12:20:59 UTC
(In reply to Andreas K. Hüttel from comment #2)
> Did you stop and re-start all parts of "KDE"? (Ideally, log out and back in
> again?)

Yes, the system has been rebooted since then.

While revdep-rebuild doesn't want to rebuild any kde4 stuff, I'll rebuild kontact to see if that fixes things.
Comment 4 peter@prh.myzen.co.uk 2017-05-19 12:35:34 UTC
(In reply to Andreas K. Hüttel from comment #2)
> Did you stop and re-start all parts of "KDE"? (Ideally, log out and back in
> again?)

Yes, I logged out, restarted xdm and logged back in again. When I found it was broken I rebooted, but it was still the same after that.

I should have noted that, in the folder list, the folders were listed in red. (The third sentence in the bug report.)

I could go forward to 4.8.7 again, with little effort, if you'd like to tell me how I can help with debugging.
Comment 5 Stephan Karacson 2017-05-19 17:02:56 UTC
Just to throw in.
As suggested from mrsteven in the forums a reemerge of kde4-stuff did help me:
revdep-rebuild --library='libQtCore.so.4'

see: https://forums.gentoo.org/viewtopic-t-1063730-start-0-postdays-0-postorder-asc-highlight-.html
Comment 6 Erik Quaeghebeur 2017-05-19 19:26:22 UTC
(In reply to Stephan Karacson from comment #5)
> Just to throw in.
> As suggested from mrsteven in the forums a reemerge of kde4-stuff did help
> me:
> revdep-rebuild --library='libQtCore.so.4'

I can confirm this.
Comment 7 Jonas Stein gentoo-dev 2017-05-19 21:17:23 UTC
Thank you. Can we close this ticket as solved?
Comment 8 Erik Quaeghebeur 2017-05-19 22:23:58 UTC
(In reply to Jonas Stein from comment #7)
> Thank you. Can we close this ticket as solved?
Well, I think at least a message pointing people to the solution that was found should be shown upon upgrade to 4.8.7 from 4.8.6; there are bound to be people that haven't done the upgrade yet.
Comment 9 peter@prh.myzen.co.uk 2017-05-20 02:13:16 UTC
(In reply to Erik Quaeghebeur from comment #6)
> (In reply to Stephan Karacson from comment #5)
> > Just to throw in.
> > As suggested from mrsteven in the forums a reemerge of kde4-stuff did help
> > me:
> > revdep-rebuild --library='libQtCore.so.4'
> 
> I can confirm this.

Yes, it worked here too. 71 packages.

I confirm what Eric said, too - I know there are people who haven't yet done the upgrade. There should be a pointer of some kind.
Comment 10 Davide Pesavento gentoo-dev 2017-05-20 16:59:10 UTC
Probably caused by bug 595618.

@qt, how do we want to proceed? ewarn or something?
Comment 11 Andreas Sturmlechner gentoo-dev 2017-06-02 01:04:31 UTC
I've revbumped kdepim-runtime with a minimum dependency on Qt-4.8.7 to ensure rebuild.
Comment 12 peter@prh.myzen.co.uk 2017-06-03 08:56:47 UTC
The update went smoothly here. I now have an empty package.mask directory.

Can this bug now be closed?