Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 618002 - =media-video/ffmpeg-3.3 can't be built with gold and LTO : could not run lto-wrapper
Summary: =media-video/ffmpeg-3.3 can't be built with gold and LTO : could not run lto-...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: lto
  Show dependency tree
 
Reported: 2017-05-09 18:07 UTC by Petross404(Petros S)
Modified: 2017-05-20 15:29 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (media-video:ffmpeg-3.3:20170422-201028.log.tar.bz2,57.04 KB, application/x-bzip)
2017-05-09 18:11 UTC, Petross404(Petros S)
Details
emerge --info (emerge-info,24.71 KB, text/plain)
2017-05-09 18:11 UTC, Petross404(Petros S)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petross404(Petros S) 2017-05-09 18:07:24 UTC
=media-video/ffmpeg-3.3 (this exact version only) can't be built with LTO and ld.gold but compiles fine with ld.bfd. 

Also =media-video/ffmpeg-3.2.4 *can* be compiled with LTO and ld.gold. I haven't tested other versions.

I am using GCC-7.1 and binutils 2.27.
Comment 1 Petross404(Petros S) 2017-05-09 18:11:07 UTC
Created attachment 472154 [details]
build.log
Comment 2 Petross404(Petros S) 2017-05-09 18:11:38 UTC
Created attachment 472156 [details]
emerge --info
Comment 3 Paolo Pedroni 2017-05-16 08:00:59 UTC
As a data point, it works fine with LTO and ld.gold, with gcc-6.3.0 and binutils-2.26.1
Comment 4 Petross404(Petros S) 2017-05-16 08:21:21 UTC
(In reply to Paolo Pedroni from comment #3)
> As a data point, it works fine with LTO and ld.gold, with gcc-6.3.0 and
> binutils-2.26.1

Can you confirm the problem with binutils 2.27 and 2.28 and/or with other GCCs?
Comment 5 Paolo Pedroni 2017-05-16 08:23:41 UTC
(In reply to Petross404(Petros S) from comment #4)
> Can you confirm the problem with binutils 2.27 and 2.28 and/or with other
> GCCs?

I may try later with newer binutils, if I have time. Gcc-7.1.0 is not an option for me ATM.
Comment 6 Steffen Hau 2017-05-16 14:52:35 UTC
It works fine with GCC 7.1.0 and Binutils 2.28.
Comment 7 Cănărău Constantin 2017-05-17 04:53:07 UTC
ffmpeg-3.3.1, binutils-2.28 (gold) and gcc-7.1.0 all good here with lto.
As 3.3.0 failed for me, too, it seems it was resolved in 3.3.1.