Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 616116 - app-text/po4a needs to be rebuilt on libperl updates
Summary: app-text/po4a needs to be rebuilt on libperl updates
Status: RESOLVED DUPLICATE of bug 592880
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Fat-Zer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-20 12:25 UTC by Pacho Ramos
Modified: 2017-04-20 16:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2017-04-20 12:25:18 UTC
Hence, maybe it should directly depend on it and rely on subslots rebuildings

This comes from perl-cleaner after recent perl update and depclean:
 * Beginning a clean up of .ph files
 * Excluding files for 5.24.1 and 5.24.1/x86_64-linux from cleaning

 * Locating ph files for removal

 * Locating packages for an update
 * Locating ebuilds linked against libperl
 *   Adding to list: media-gfx/imagemagick:0
 *   Adding to list: app-text/po4a:0
 *   Adding to list: sys-apps/texinfo:0
 * emerge -v1 --backtrack=200 --selective=n media-gfx/imagemagick:0 app-text/po4a:0 sys-apps/texinfo:0
Comment 1 Andreas K. Hüttel gentoo-dev 2017-04-20 16:54:36 UTC
po4a is long fixed. this is most likely the --with-bdeps portage bug (portage has a problem with calculating correct deptrees when that switch is off).

*** This bug has been marked as a duplicate of bug 592880 ***