Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 615312 - =x11-wm/evilwm-1.1.1 stabilization
Summary: =x11-wm/evilwm-1.1.1 stabilization
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: EAPI3Removal
  Show dependency tree
 
Reported: 2017-04-11 20:37 UTC by Andreas K. Hüttel
Modified: 2018-01-04 11:47 UTC (History)
1 user (show)

See Also:
Package list:
=x11-wm/evilwm-1.1.1
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel gentoo-dev 2017-04-11 20:37:43 UTC
Can we stabilize =x11-wm/evilwm-1.1.1 ?  If yes, please CC arches.

Current stable is EAPI=3 and needs to go.

Target: alpha amd64 ppc sparc x86
Comment 1 Jaco Kroon 2017-04-12 09:10:22 UTC
Hi Andreas,

I've reverted my installation back to 1.0.1 due to maximize issues between amongst others mplayer and 1.1.1 - I've spoken with the developer and based on that discussions it sounded more like an mplayer bug ... but alas, as these things go it's not one of those high priority things for me.

I'll retest 1.1.1 with mplayer again quickly, but failing that, could I generate a 1.0.1-r1 for you against a newer EAPI that we rather stabilize?  Doesn't look like there is a huge amount of change required.  Mostly I think it's just dropping a bunch of || die statements.

Kind Regards,
Jaco
Comment 2 Jaco Kroon 2017-04-13 11:03:43 UTC
There was another problem with evilwm 1.1.1 - skype locks up, and it's window becomes unusable, need to kill skype and restart completely.

May I rather update the EAPI for the 1.0.1 ebuild for you?
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2017-05-09 15:55:15 UTC
(In reply to Jaco Kroon from comment #2)
> There was another problem with evilwm 1.1.1 - skype locks up, and it's
> window becomes unusable, need to kill skype and restart completely.
> 
> May I rather update the EAPI for the 1.0.1 ebuild for you?

you can, with appropriate revision bump
Comment 4 Andreas K. Hüttel gentoo-dev 2017-07-29 13:43:51 UTC
(In reply to Mikle Kolyada from comment #3)
> (In reply to Jaco Kroon from comment #2)
> > There was another problem with evilwm 1.1.1 - skype locks up, and it's
> > window becomes unusable, need to kill skype and restart completely.
> > 
> > May I rather update the EAPI for the 1.0.1 ebuild for you?
> 
> you can, with appropriate revision bump

Yes, please- with revbump.
Comment 5 charles17 2017-09-12 13:47:01 UTC
(In reply to Andreas K. Hüttel from comment #4)
> > > [...]
> > > May I rather update the EAPI for the 1.0.1 ebuild for you?
> > 
> > you can, with appropriate revision bump
> 
> Yes, please- with revbump.

See https://github.com/gentoo/gentoo/pull/5691
Comment 6 Larry the Git Cow gentoo-dev 2017-12-28 10:10:11 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0342a180ba6e0e85ddd5461928438e946adda114

commit 0342a180ba6e0e85ddd5461928438e946adda114
Author:     charIes17 <charles17@arcor.de>
AuthorDate: 2017-12-19 13:00:51 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2017-12-28 10:09:59 +0000

    x11-wm/evilwm: Bump to EAPI=6
    
    Bug: https://bugs.gentoo.org/615312
    Package-Manager: Portage-2.3.13, Repoman-2.3.3
    Closes: https://github.com/gentoo/gentoo/pull/5691

 x11-wm/evilwm/evilwm-1.0.1-r1.ebuild | 47 ++++++++++++++++++++++++++++++++++++
 x11-wm/evilwm/evilwm-1.1.1.ebuild    | 36 +++++++++++++--------------
 2 files changed, 65 insertions(+), 18 deletions(-)}
Comment 7 Larry the Git Cow gentoo-dev 2018-01-04 11:45:40 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=656420e05df3794377332af791f361d35d56cef1

commit 656420e05df3794377332af791f361d35d56cef1
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2018-01-04 11:45:23 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2018-01-04 11:45:23 +0000

    x11-wm/evilwm: merge stable keywords (EAPI bump, no major changes)
    
    Bug: https://bugs.gentoo.org/615312
    Package-Manager: Portage-2.3.13, Repoman-2.3.3

 x11-wm/evilwm/evilwm-1.0.1-r1.ebuild | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)}
Comment 8 Larry the Git Cow gentoo-dev 2018-01-04 11:47:24 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7e6a892d00b791044dee52d4c377c33681c40813

commit 7e6a892d00b791044dee52d4c377c33681c40813
Author:     Mikle Kolyada <zlogene@gentoo.org>
AuthorDate: 2018-01-04 11:46:54 +0000
Commit:     Mikle Kolyada <zlogene@gentoo.org>
CommitDate: 2018-01-04 11:47:19 +0000

    x11-wm/evilwm: Drop old
    
    Closes: https://bugs.gentoo.org/615312
    Package-Manager: Portage-2.3.13, Repoman-2.3.3

 x11-wm/evilwm/evilwm-1.0.1.ebuild | 45 ---------------------------------------
 1 file changed, 45 deletions(-)