Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 614482 - dev-java/icu4j-54.1.1[doc] fails to build with error: cannot find symbol[javac] import com.sun.tools.doclets.internal.toolkit.taglets.TagletOutput;
Summary: dev-java/icu4j-54.1.1[doc] fails to build with error: cannot find symbol[java...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
: 673984 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-02 03:49 UTC by Alessandro Barbieri
Modified: 2020-11-19 10:22 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
log (icu4j.log,33.09 KB, text/plain)
2017-04-02 03:49 UTC, Alessandro Barbieri
Details
emerge info (icu4j.info,13.33 KB, text/plain)
2017-04-02 03:49 UTC, Alessandro Barbieri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Barbieri 2017-04-02 03:49:08 UTC
Created attachment 468936 [details]
log

see summary and attachments
Comment 1 Alessandro Barbieri 2017-04-02 03:49:50 UTC
Created attachment 468938 [details]
emerge info
Comment 2 Alessandro Barbieri 2017-04-02 03:51:26 UTC
see https://bugzilla.redhat.com/show_bug.cgi?id=1087450
Comment 3 Juergen Rose 2017-12-30 23:06:08 UTC
Any news? 'emerge -e world' complains about this error.
Comment 4 Juergen Rose 2018-12-29 14:06:10 UTC
(In reply to Juergen Rose from comment #3)
> Any news? 'emerge -e world' complains about this error.

One year later it still fails.
It seems to be a dependency of libgda-5.2.8 via dev-java/jython-2.7.0-r2:

root@lynx:/usr/src(66)#   emerge -puvDNt  --verbose-conflicts world 

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] dev-util/anjuta-3.28.0::gentoo  USE="devhelp glade introspection subversion vala -debug (-packagekit) -terminal -test" PYTHON_TARGETS="python2_7" 
[ebuild     U  ]  gnome-extra/libgda-5.2.8:5/4::gentoo [5.2.4-r2:5/4::gentoo] USE="berkdb gnome-keyring graphviz gtk http introspection java* ldap mysql postgres reports* ssl vala -canvas -debug -firebird -json -mdb -oci8 -sourceview" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  rR    ] sci-mathematics/yacas-1.6.1-r1:0/1::gentoo  USE="doc java jupyter -gui -static-libs" 0 KiB
[ebuild  rR    ] net-libs/libwebsockets-2.4.2:0/2.4.2::gentoo  USE="access-log cgi client generic-sessions http2 ipv6 lejp libuv server-status smtp sqlite3 ssl zip -caps -http-proxy -libev -libevent -libressl -peer-limits -socks5 -static-libs" 0 KiB
[nomerge       ] gnome-extra/gnome-shell-extension-gsconnect-12::gentoo 
[nomerge       ]  gnome-base/gnome-shell-3.26.2-r4::gentoo  USE="bluetooth browser-extension ibus networkmanager nsplugin systemd -elogind -telepathy -test" PYTHON_SINGLE_TARGET="python3_6 -python3_4 -python3_5" PYTHON_TARGETS="python3_6 -python3_4 -python3_5" 
[nomerge       ]   gnome-extra/evolution-data-server-3.26.6:0/60::local  USE="berkdb gnome-online-accounts gtk introspection ipv6 kerberos ldap vala weather -google -gtk-doc -test" 
[ebuild     U  ]    net-libs/gnome-online-accounts-3.28.0:0/1::gentoo [3.26.2:0/1::gentoo] USE="gnome introspection kerberos vala -debug" 0 KiB
[nomerge       ] app-office/gnumeric-1.12.43::gentoo  USE="introspection libgda perl python" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5" 
[nomerge       ]  gnome-extra/libgda-5.2.8:5/4::gentoo [5.2.4-r2:5/4::gentoo] USE="berkdb gnome-keyring graphviz gtk http introspection java* ldap mysql postgres reports* ssl vala -canvas -debug -firebird -json -mdb -oci8 -sourceview" PYTHON_TARGETS="python2_7" 
[ebuild  N     ]   dev-java/fop-2.0-r3::gentoo  USE="examples (-doc) -source -test" 0 KiB
[ebuild  N     ]    dev-java/batik-1.9:1.9::gentoo  USE="doc python tcl" 0 KiB
[ebuild  N     ]     dev-java/jython-2.7.0-r2:2.7::gentoo  USE="doc examples -source -test" 0 KiB
[ebuild  N     ]      dev-java/icu4j-54.1.1:52::gentoo  USE="doc examples -source -test" 0 KiB



icu4j-56.1 is emerged without problems. How can be jython-2.7.0-r2 convinced to accept icu4j-56.1 instead of icu4j-54.1.1?
Comment 5 Juergen Rose 2018-12-29 14:31:54 UTC
See also https://bugs.gentoo.org/673984 .
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2018-12-30 02:26:15 UTC
*** Bug 673984 has been marked as a duplicate of this bug. ***
Comment 7 Juergen Rose 2019-06-05 20:04:49 UTC
More than two years later. anjuta-3.28.0-r1 and gnumeric-1.12.44 still fails to emerge due to this bug.

Installing dev-java/jython-2.7.0-r3 corresponding https://bugs.gentoo.org/673984 solves this issue.
Comment 8 Leonid Kopylov 2020-11-19 10:22:55 UTC
any news on this?