Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 613278 - net-print/gutenprint-5.2.12 emerge fails, cannot find gtk includes
Summary: net-print/gutenprint-5.2.12 emerge fails, cannot find gtk includes
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Printing Team
Depends on:
Reported: 2017-03-19 23:22 UTC by alex Mezey
Modified: 2020-02-14 09:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

emerge-info.txt (emerge-info.txt,17.34 KB, text/plain)
2017-08-19 07:32 UTC, Toralf Förster
emerge-history.txt (emerge-history.txt,250.55 KB, text/plain)
2017-08-19 07:33 UTC, Toralf Förster
environment (environment,59.50 KB, text/plain)
2017-08-19 07:33 UTC, Toralf Förster
etc.portage.tbz2 (etc.portage.tbz2,29.73 KB, application/x-bzip)
2017-08-19 07:33 UTC, Toralf Förster
logs.tbz2 (logs.tbz2,24.27 KB, application/x-bzip)
2017-08-19 07:33 UTC, Toralf Förster
net-print:gutenprint-5.2.12:20170819-053306.log (net-print:gutenprint-5.2.12:20170819-053306.log,77.97 KB, text/plain)
2017-08-19 07:33 UTC, Toralf Förster
temp.tbz2 (temp.tbz2,26.15 KB, application/x-bzip)
2017-08-19 07:33 UTC, Toralf Förster

Note You need to log in before you can comment on or make changes to this bug.
Description alex Mezey 2017-03-19 23:22:43 UTC
cannot find gtk/gtk.h after workaround same error message with gdk/gdk.h
my /usr/include contains gtk-3.0 and gtk-2.0 including the above searched files. Well all the other stuff using gtk worked in my @world update, so i guess it's a gutenprint problem, or forgotten Adaption to multiple gtk versions.

Reproducible: Always

Steps to Reproduce:
1.emerge -v1 =net-print/gutenprint-5.2.12
Actual Results:  
emerge fails
I could install with the following workaround:
  ln -s ../../include/gtk-3.0/gtk /usr/local/include/gtk
  ln -s ../../include/gtk-3.0/gdk /usr/local/include/gdk
  ln -s ../../include/gtk-3.0/unix-print /usr/local/include/unix-print
I don't know whether the last line is needed. The first two are and I did not want to spend the time to try the 3rd (or loose functionality).

Expected Results:  
should emerge without adding links stuff in /usr/local/include/ or /usr/include/

Bug sucks, workaround took me some time and I hope I will not have problems later, if I forget I added the links in /usr/local/include or soon with other packages because they don't find there are 2 gtk versions available when the link exists and portage must have at least one reason to keep gtk-2.0
I don't have the log of the broken install left as it got overwritten with the succesfull workaround install, but:

denkmatte.~: emerge --info
Portage 2.3.3 (python 2.7.12-final-0, default/linux/amd64/13.0, gcc-4.9.4, glibc-2.23-r3, 4.0.5-gentoo x86_64)
System uname: Linux-4.0.5-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_L5640_@_2.27GHz-with-gentoo-2.3
KiB Mem:    12291644 total,   2442052 free
KiB Swap:   25147388 total,  24393524 free
Timestamp of repository gentoo: Fri, 17 Mar 2017 17:00:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.26.1 p1.0) 2.26.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.3_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23.2::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.26.1::gentoo
sys-devel/gcc:            4.9.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

    location: /usr/local/portage
    masters: gentoo
    priority: 0

    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

    location: /var/lib/layman/stefantalpalaru
    masters: gentoo
    priority: 50

    location: /var/lib/layman/sunrise
    masters: gentoo
    priority: 50

    location: /var/lib/layman/wish
    masters: gentoo
    priority: 50

CFLAGS="-O2 -pipe -march=corei7 -mcx16 -msahf"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=corei7 -mcx16 -msahf"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="16bit 16bit-indices 3dnow 3dnowext 3ds 64bit 7zip X X509 a52 aac aalib acl acpi addbookmarks aften afterimage allegro alsa amavis amd64 amrr ao apng artist-screen aspell audiofile auth avahi bash-completion battery berkdb binary-drivers binfilter bittorrent bluetooth buffysize bzip2 cairo cdaudio cdda cddb cdio cdr cdrom cg chipcard chm cleartype cli clock-screen colordiff colors consolekit corefonts cpufreq cracklib crypt css cupsddk cxx dawn dbus dc1394 dcc_voice declarative detex device-mapper dialup divx djvu doc doc-pdf docbook dot downloadorder dri dssi dv dvb dvbplayer dvbpsi dvbsetup dvd dvdarchive dvdchapjump dvdnav dvdr dvdread dvi dvi2tty editor em84xx embedded enca encode eu_epg examples exif ext4 extensions extra extras fading-colors ffmpeg file firefox3 flac flash fluidsynth fontconfig foomaticdb fortran fping fpx ftp fuse g3dvl gammu garmin gcj gcrypt gd gdbm gecko geldkarte geoip gif gimp glut gmedia gnome gnuplot gnutls gopher gpg gpgme gphoto2 gps grammar graphics gs gsl gsm gtk gtk2-perl gtkhotkey hbci hdaps help-screen high-ints highlight hpcups html htmlhandbook htmlsingle i18n ibam ibmacpi iconv icu id3 ieee1394 imagemagick imap infowidget injection inkjar ipfilter ipv6 irc jabber jadetex java java6 javascript jingle jpeg jpeg2k kde key-screen kpathsea laptop latex libnotify libsamplerate lm_sensors logrotate logviewer mad maildir masquerade matroska mbox md5sum mdnsresponder-compat mediaplayer melt metric midi mikmod mime mimencode mng mod modules mouse mozilla mp2 mp3 mp4 mpd mpeg mpeg2 mpi mplayer multilib multiuser musicbrainz mysql nat ncurses nfconntrack nls nntp nptl nsplugin nvidia obex ogg ogg123 oggvorbis ogm opengl openmp openstreetmap opera otr pam pcre pdf php plotutils png pnm policykit postfix private-headers procmail pulseaudio qt3support qt4 quicktime rar raw readline real realmedia romio rpm rss scanner schroedinger seccomp secure-delete session sftp sid smartcard sms speech speex sql sqlite sse sse2 ssl ssse3 stlport svg system-sqlite tcpd theora thesaurus threads tiff tk tor tordns truetype unicode unlock-notify usb v4l v4l2 vcd vcdinfo vcdx vim vim-pager vim-with-x vorbis vorbis-psy vpx webkit webm wifi win32 win64 wma wmf wmp wxwidgets x264 xattr xcf xine xinerama xml xpm xrender xscreensaver xterm-color xulrunner xvid xvmc zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.4"
Comment 1 Matthew Ogilvie 2017-04-23 01:33:22 UTC
I've also seen this on one of my machines, although I just ended up
uninstalling gutenprint rather than investigate in detail, since I
don't actually care about printing from that machine. 

However, I did note a few things that might be helpful with tracking
it down:

This fails to find gtk/gtk.h:
> [ebuild     U  ] net-print/gutenprint-5.2.12::gentoo [5.2.10::gentoo] 
> USE="gtk nls readline -cups -gimp -ppds -static-libs (-foomaticdb%)" 0 KiB
   - Although now that I think about it, I thought gutenprint was a cups
     plugin, so what does it mean to have cups and ppds support disabled?

On another machine, this works fine:
> [ebuild   R    ] net-print/gutenprint-5.2.12::gentoo  USE="cups nls ppds 
> readline -gimp -gtk -static-libs" 0 KiB

So it seems likely that a workaround would be to disable USE=-gtk for
gutenprint only (package.use), and/or other USE flag adjustments.
Not sure what effect that would have on the usability of the package.

Speculative cause: Maybe a combination of hypothetical/uncofirmed recent
changes in how gtk+ installs header files, and gutenprint using an
incorrect way of finding gtk include paths that doesn't work after the
Comment 2 Toralf Förster gentoo-dev 2017-08-19 07:32:56 UTC
appeared recently at the tinderbox image 20170819-073423_net-print_gutenprint-5.2.12
Comment 3 Toralf Förster gentoo-dev 2017-08-19 07:32:59 UTC
Created attachment 489594 [details]
Comment 4 Toralf Förster gentoo-dev 2017-08-19 07:33:03 UTC
Created attachment 489596 [details]
Comment 5 Toralf Förster gentoo-dev 2017-08-19 07:33:06 UTC
Created attachment 489598 [details]
Comment 6 Toralf Förster gentoo-dev 2017-08-19 07:33:10 UTC
Created attachment 489600 [details]
Comment 7 Toralf Förster gentoo-dev 2017-08-19 07:33:13 UTC
Created attachment 489602 [details]
Comment 8 Toralf Förster gentoo-dev 2017-08-19 07:33:16 UTC
Created attachment 489604 [details]
Comment 9 Toralf Förster gentoo-dev 2017-08-19 07:33:19 UTC
Created attachment 489606 [details]
Comment 10 Larry the Git Cow gentoo-dev 2020-02-14 09:10:05 UTC
The bug has been closed via the following commit(s):

commit 92d27c92930004acf7f2ae4b25a1fa2d331095f7
Author:     Miroslav Šulc <>
AuthorDate: 2020-02-14 09:09:46 +0000
Commit:     Miroslav Šulc <>
CommitDate: 2020-02-14 09:09:58 +0000

    net-print/gutenprint: restricted gimp version
    Package-Manager: Portage-2.3.88, Repoman-2.3.20
    Signed-off-by: Miroslav Šulc <>

 net-print/gutenprint/gutenprint-5.3.1.ebuild | 3 ++-
 net-print/gutenprint/gutenprint-5.3.3.ebuild | 5 +++--
 2 files changed, 5 insertions(+), 3 deletions(-)