Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 61272 - libstdc++-v3-3.3.3-r1 will fail when using -mcpu=G5
Summary: libstdc++-v3-3.3.3-r1 will fail when using -mcpu=G5
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: PPC64 Linux
: High normal (vote)
Assignee: ppc64 architecture team
Depends on:
Reported: 2004-08-22 10:24 UTC by Markus Rothe (RETIRED)
Modified: 2004-08-22 21:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Markus Rothe (RETIRED) gentoo-dev 2004-08-22 10:24:07 UTC

just tried to install libstdc++-v3-3.3.3-r1. But it failed with this line:

checking whether the C compiler ( /var/tmp/portage/libstdc++-v3-3.3.3-r1/work/build/gcc/xgcc -B/var/tmp/portage/libstdc++-v3-3.3.3-r1/work/build/gcc/ -B/usr/powerpc64-unknown-linux-gnu/bin/ -B/usr/powerpc64-unknown-linux-gnu/lib/ -isystem /usr/powerpc64-unknown-linux-gnu/include -O2 -mcpu=G5 -pipe -O2 ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
make: *** [configure-target-libiberty] Error 1

!!! Error: sys-libs/libstdc++-v3-3.3.3-r1 failed.
!!! Function src_compile, Line 169, Exitcode 2
!!! (no error message)

Seems to be the same problem as seen on amd64... I added this line to the ebuild and it works now:

    replace-flags -mcpu=G5 -mtune=G5

but there might be other -mcpu types be affected, so I guess the solution to this problem in the ebuild would be similar to the solution for amd64.

So maybe this works:

if use ppc64
  setting="`get-flag mcpu`"
  [ ! -z "$setting" ] && filter flags -mcpu="${setting}" -mtune="${setting}"

Comment 1 Markus Rothe (RETIRED) gentoo-dev 2004-08-22 10:29:00 UTC
by the way: the error occured while bootstrapping...

Comment 2 Tom Gall (RETIRED) gentoo-dev 2004-08-22 12:52:54 UTC
ahh .. yeah you can't use -mcpu=xxxx .  -mtune=970 is effectively the same thing according to alanm.  -mcpu is turning on some 32 bit flags and such I gather so that's why you don't want to use it 

It's a bug sure but a bug upstream that i don't think they are going to address.
Comment 3 Tom Gall (RETIRED) gentoo-dev 2004-08-22 21:11:38 UTC
stick a fork in it