Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 612446 - dev-perl/Wx-Scintilla-0.390.0-r2 : wx-scintilla/.../Editor.cxx:5871:23: error: call of overloaded ‘abs(XYPOSITION)’ is ambiguous
Summary: dev-perl/Wx-Scintilla-0.390.0-r2 : wx-scintilla/.../Editor.cxx:5871:23: error...
Status: RESOLVED DUPLICATE of bug 623042
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL: https://rt.cpan.org/Public/Bug/Displa...
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2017-03-12 21:21 UTC by Toralf Förster
Modified: 2017-07-21 16:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,5.72 KB, text/plain)
2017-03-12 21:21 UTC, Toralf Förster
Details
dev-perl:Wx-Scintilla-0.390.0-r2:20170312-211206.log (dev-perl:Wx-Scintilla-0.390.0-r2:20170312-211206.log,15.94 KB, text/plain)
2017-03-12 21:21 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,140.18 KB, text/plain)
2017-03-12 21:21 UTC, Toralf Förster
Details
environment (environment,114.88 KB, text/plain)
2017-03-12 21:21 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,22.14 KB, application/x-bzip)
2017-03-12 21:21 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,29.26 KB, application/x-bzip)
2017-03-12 21:21 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,15.42 KB, text/plain)
2017-06-24 16:56 UTC, Toralf Förster
Details
dev-perl:Wx-0.992.800:20170624-163829.log (dev-perl:Wx-0.992.800:20170624-163829.log,207.82 KB, text/plain)
2017-06-24 16:56 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,194.50 KB, text/plain)
2017-06-24 16:56 UTC, Toralf Förster
Details
environment (environment,114.43 KB, text/plain)
2017-06-24 16:56 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,22.68 KB, application/x-bzip)
2017-06-24 16:56 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,38.28 KB, application/x-bzip)
2017-06-24 16:56 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-03-12 21:21:37 UTC
                            ^~~~~~~~
wx-scintilla/src/scintilla/src/Editor.cxx: In function ‘bool Close(Point, Point)’:
wx-scintilla/src/scintilla/src/Editor.cxx:5871:23: error: call of overloaded ‘abs(XYPOSITION)’ is ambiguous
  if (abs(pt1.x - pt2.x) > 3)

                       ^

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named plasma-abi32+64_20170309-193709) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0 *
llvm-config:
3.9.1
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.3.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Comment 1 Toralf Förster gentoo-dev 2017-03-12 21:21:40 UTC
Created attachment 466848 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-03-12 21:21:43 UTC
Created attachment 466850 [details]
dev-perl:Wx-Scintilla-0.390.0-r2:20170312-211206.log
Comment 3 Toralf Förster gentoo-dev 2017-03-12 21:21:47 UTC
Created attachment 466852 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-03-12 21:21:50 UTC
Created attachment 466854 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-03-12 21:21:53 UTC
Created attachment 466856 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2017-03-12 21:21:56 UTC
Created attachment 466858 [details]
temp.tbz2
Comment 7 Andreas K. Hüttel gentoo-dev 2017-04-24 23:25:43 UTC
commit dba986281a22a17cb3bda851f50a5757ab17c051
Author: Andreas K. Hüttel <dilfridge@gentoo.org>
Date:   Tue Apr 25 01:24:50 2017 +0200

    dev-perl/Wx-Scintilla: Fix build with gcc-6, bug 612446
    
    Package-Manager: Portage-2.3.5, Repoman-2.3.2

 dev-perl/Wx-Scintilla/Manifest                            |  1 -
 dev-perl/Wx-Scintilla/Wx-Scintilla-0.390.0-r2.ebuild      |  6 +++---
 dev-perl/Wx-Scintilla/files/Wx-Scintilla-0.34-flags.patch | 19 +++++++++++++++++++
 dev-perl/Wx-Scintilla/files/Wx-Scintilla-0.39-gcc6.patch  | 32 ++++++++++++++++++++++++++++++++
 4 files changed, 54 insertions(+), 4 deletions(-)
Comment 8 Toralf Förster gentoo-dev 2017-06-24 16:56:21 UTC
same at the tinderbox image 17.0-desktop-gnome-systemd_abi32+64_20170619-222741
Comment 9 Toralf Förster gentoo-dev 2017-06-24 16:56:26 UTC
Created attachment 477860 [details]
emerge-info.txt
Comment 10 Toralf Förster gentoo-dev 2017-06-24 16:56:29 UTC
Created attachment 477862 [details]
dev-perl:Wx-0.992.800:20170624-163829.log
Comment 11 Toralf Förster gentoo-dev 2017-06-24 16:56:33 UTC
Created attachment 477864 [details]
emerge-history.txt
Comment 12 Toralf Förster gentoo-dev 2017-06-24 16:56:36 UTC
Created attachment 477866 [details]
environment
Comment 13 Toralf Förster gentoo-dev 2017-06-24 16:56:39 UTC
Created attachment 477868 [details]
etc.portage.tbz2
Comment 14 Toralf Förster gentoo-dev 2017-06-24 16:56:42 UTC
Created attachment 477870 [details]
temp.tbz2
Comment 15 Peter Levine 2017-07-21 04:36:03 UTC
(In reply to Toralf Förster from comment #10)
> Created attachment 477862 [details]
> dev-perl:Wx-0.992.800:20170624-163829.log

Please close this bug.  That bug is related to https://bugs.gentoo.org/show_bug.cgi?id=623042.
Comment 16 Toralf Förster gentoo-dev 2017-07-21 16:21:23 UTC

*** This bug has been marked as a duplicate of bug 623042 ***