Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 611628 - net-im/gajim: support dev-python/pycryptodome
Summary: net-im/gajim: support dev-python/pycryptodome
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Amadeusz Żołnowski
URL: https://dev.gajim.org/gajim/gajim/iss...
Whiteboard:
Keywords:
Depends on: 613896
Blocks: pycryptodome-tracker
  Show dependency tree
 
Reported: 2017-03-03 23:17 UTC by Michał Górny
Modified: 2019-05-25 06:19 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-03-03 23:17:37 UTC
See tracker.
Comment 1 Amadeusz Żołnowski gentoo-dev 2017-11-14 22:44:15 UTC
net-im/gajim: Drop pycrypto dependency, no longer supported by upstream

pycrypto itself is dead. There are problems with pycryptodome and
upstream doesn't actually care about pycrypto* at all.
Comment 2 Amadeusz Żołnowski gentoo-dev 2017-11-14 23:01:39 UTC
Fixed in gajim-0.16.8-r1.
Comment 3 Amadeusz Żołnowski gentoo-dev 2017-11-14 23:07:00 UTC
w8, it's actually not fixed. Just dependency has been removed, but still may be picked up if present on the system.

See also <https://dev.gajim.org/gajim/gajim/issues/5294>. Should be solved by upstream one way or the other.
Comment 4 Daniel Robbins 2017-12-22 21:11:51 UTC
What exactly are the problems with pycryptodome?
Comment 5 Daniel Robbins 2017-12-22 21:28:46 UTC
I've done a full code inspection on gajim, and except for its references to pycrypto in dependency files, it will work just fine with pycryptodome installed. If installed using emerge, it should be fine to simply change the dependency from pycrypto to pycryptodome to migrate to pycryptodome.
Comment 6 Amadeusz Żołnowski gentoo-dev 2017-12-23 10:23:24 UTC
When starting Gajim with pycrypdome installed instead it fails on:

ERROR: start symbol translation_unit_or_empty undefined
Comment 7 Daniel Robbins 2017-12-25 01:53:55 UTC
Will look into it. Maybe I missed something.
Comment 8 Daniel Robbins 2017-12-25 02:02:40 UTC
Amadeusz, the particular issue you are experiencing seems to be introduced by dev-python/pycparser-2.18. It can be worked around by downgrading to pycparser-2.17. Then gajim starts without issue.
Comment 9 Amadeusz Żołnowski gentoo-dev 2017-12-29 21:27:11 UTC
Daniel, thanks for testing that. I suppose it's not ideal to block dev-python/pycparser-2.18* in gajim ebuild.
Comment 10 Hanno Böck gentoo-dev 2019-05-25 06:19:04 UTC
This bug is obsolete, all gajim versions in the portage tree depend on pycryptodome.