Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 607176 - media-gfx/freecad-9999: ebuild is broken (wrong $S path and broken installation paths)
Summary: media-gfx/freecad-9999: ebuild is broken (wrong $S path and broken installati...
Status: RESOLVED DUPLICATE of bug 596958
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Michael Weber (RETIRED)
Depends on:
Reported: 2017-01-25 12:52 UTC by Miroslav Šulc
Modified: 2017-02-06 00:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Šulc gentoo-dev 2017-01-25 12:52:26 UTC
i tried to re-emerge freecad-9999 some time ago and i found there are several issues:
1) source dir has changed from FreeCAD-9999 to freecad-9999 ... this fix is trivial, S=... just has to be removed
2) after the fix in 1) freecad compiles fine but in the install phase many files are not installed in correct location in the image and it fails on registering icons (as that path does not exist in the image). i tried to fix that but i do not know cmake that well

the ebuild still suffers from configuration issue because of missing libmed package (which is not in the main tree so far) but i avoided that by installing the package using ebuild from elsewhere
Comment 1 Andreas Sturmlechner gentoo-dev 2017-02-06 00:49:45 UTC
There's more to that, 9999 ebuild should switch to BUILD_QT5 by default, but for that we will also need Qt5-based pyside and shiboken in tree (currently only the latter has a Qt5-based ebuild in qt overlay).
Comment 2 Andreas Sturmlechner gentoo-dev 2017-02-06 00:54:58 UTC
Well, one 9999 bug should be enough.

*** This bug has been marked as a duplicate of bug 596958 ***