Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 605780 - sci-astronomy/stellarium-0.15.1 : make[2]: *** No rule to make target '/var/tmp/portage/sci-astronomy/stellarium-0.15.1/work/stellarium-0.15.1/po/stellarium-remotecontrol/hi.po', needed by 'translations/stellarium-remotecontrol/hi.qm'. Stop.
Summary: sci-astronomy/stellarium-0.15.1 : make[2]: *** No rule to make target '/var/t...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Sci Astronomy Herd
URL:
Whiteboard:
Keywords:
: 648304 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-01-15 15:18 UTC by Toralf Förster
Modified: 2018-11-10 14:01 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,6.61 KB, text/plain)
2017-01-15 15:18 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,233.70 KB, text/plain)
2017-01-15 15:18 UTC, Toralf Förster
Details
environment (environment,134.71 KB, text/plain)
2017-01-15 15:18 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.07 KB, application/x-bzip)
2017-01-15 15:18 UTC, Toralf Förster
Details
sci-astronomy:stellarium-0.15.1:20170115-145240.log.bz2 (sci-astronomy:stellarium-0.15.1:20170115-145240.log.bz2,23.43 KB, application/x-bzip)
2017-01-15 15:18 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-01-15 15:18:09 UTC
make -f po/stellarium-remotecontrol/CMakeFiles/translations-stellarium-remotecontrol.dir/build.make po/stellarium-remotecontrol/CMakeFiles/translations-stellarium-remotecontrol.dir/build
make[2]: Entering directory '/var/tmp/portage/sci-astronomy/stellarium-0.15.1/work/stellarium-0.15.1_build'
make[2]: *** No rule to make target '/var/tmp/portage/sci-astronomy/stellarium-0.15.1/work/stellarium-0.15.1/po/stellarium-remotecontrol/hi.po', needed by 'translations/stellarium-remotecontrol/hi.qm'.  Stop.
make[2]: Leaving directory '/var/tmp/portage/sci-astronomy/stellarium-0.15.1/work/stellarium-0.15.1_build'
make[1]: *** [CMakeFiles/Makefile2:1824: po/stellarium-remotecontrol/CMakeFiles/translations-stellarium-remotecontrol.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/sci-astronomy/stellarium-0.15.1/work/stellarium-0.15.1_build'

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named gnome-systemd-unstable_20170110-104858) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config --version:
3.9.1
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Available Python interpreters, in order of preference:
  [1]   python2.7
  [2]   python3.4
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.2.0 [icedtea-bin-8]
  -----------------------------------------------------------------
Comment 1 Toralf Förster gentoo-dev 2017-01-15 15:18:12 UTC
Created attachment 460174 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-01-15 15:18:16 UTC
Created attachment 460176 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-01-15 15:18:19 UTC
Created attachment 460178 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-01-15 15:18:22 UTC
Created attachment 460180 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-01-15 15:18:25 UTC
Created attachment 460182 [details]
sci-astronomy:stellarium-0.15.1:20170115-145240.log.bz2
Comment 6 Adam Jones 2017-01-17 21:51:06 UTC
Setting USE="-nls" appears to work around this (at the cost of disabling translations, of course).
Comment 7 Martin von Gagern 2017-01-24 06:40:13 UTC
Same here with en_US instead of hi, probably due to my enabled LINGUAS.
Problem persists even with MAKEOPTS=-j1.
Comment 8 Fabio Scaccabarozzi 2017-04-01 23:31:57 UTC
(In reply to Martin von Gagern from comment #7)
> Same here with en_US instead of hi, probably due to my enabled LINGUAS.
> Problem persists even with MAKEOPTS=-j1.

The problem seems to be due to the fact that CMake is not checking whether the translation files are really there.

I have L10N="de it en en-GB en-US", but in po/stellarium-remotecontrol/ I can only see:
stellarium-0.15.1 # ll po/stellarium-remotecontrol/{de,it,en*}.po
-rw-r--r-- 1 portage portage 13K 17 dic 10.24 po/stellarium-remotecontrol/de.po
-rw-r--r-- 1 portage portage 11K 17 dic 10.24 po/stellarium-remotecontrol/en_GB.po
-rw-r--r-- 1 portage portage 11K 17 dic 10.24 po/stellarium-remotecontrol/en.po
-rw-r--r-- 1 portage portage 13K 17 dic 10.24 po/stellarium-remotecontrol/it.po

I think the ebuild needs some more rework to detect which L10N are present for each translation in each of the subfolders in po/.
Probably it's best to unset L10N via package.env and have all the locales generated for the package for the time being.
Comment 9 Konstantin Münning 2017-06-07 23:07:51 UTC
(In reply to Fabio Scaccabarozzi from comment #8)
> The problem seems to be due to the fact that CMake is not checking whether
> the translation files are really there.

Same with bg. I don't see why this should be CMake's fold. Just remove the non-existent languages from the LANGS list in the ebuild. The person that created the ebuild was maybe too optimistic ;-). Removing bg from the list works for me. So far (I didn't check the directory contents) the following LANGS should be removed from the ebuild:

bg
hi
en_US
Comment 10 Egor Y. Egorov 2018-01-08 16:59:36 UTC
same for ru_RU
Comment 11 Andreas Sturmlechner gentoo-dev 2018-11-10 13:59:42 UTC
*** Bug 648304 has been marked as a duplicate of this bug. ***
Comment 12 Andreas Sturmlechner gentoo-dev 2018-11-10 14:01:19 UTC
0.16.0-r1 was stabilised and old versions dropped.