Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 605486 - dev-perl/Server-Starter-0.330.0 : Compilation failed in require at Build.PL line 12.
Summary: dev-perl/Server-Starter-0.330.0 : Compilation failed in require at Build.PL l...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on: 598444
Blocks: build-order
  Show dependency tree
 
Reported: 2017-01-12 16:35 UTC by Toralf Förster
Modified: 2019-07-11 05:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,5.59 KB, text/plain)
2017-01-12 16:35 UTC, Toralf Förster
Details
dev-perl:Server-Starter-0.330.0:20170112-163056.log (dev-perl:Server-Starter-0.330.0:20170112-163056.log,2.54 KB, text/plain)
2017-01-12 16:35 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,48.38 KB, text/plain)
2017-01-12 16:35 UTC, Toralf Förster
Details
environment (environment,31.77 KB, text/plain)
2017-01-12 16:35 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.04 KB, application/x-bzip)
2017-01-12 16:35 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-01-12 16:35:14 UTC
 at builder/MyBuilder.pm line 4.
BEGIN failed--compilation aborted at builder/MyBuilder.pm line 4.
Compilation failed in require at Build.PL line 12.
BEGIN failed--compilation aborted at Build.PL line 12.
 * ERROR: dev-perl/Server-Starter-0.330.0::gentoo failed (configure phase):
 *   Unable to build!

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named plasma-systemd-libressl-unstable_20170111-153814) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config --version:
3.9.1

Available Python interpreters:
  [1]   python2.7
  [2]   python3.4 *

java-config:

  -----------------------------------------------------------------
Comment 1 Toralf Förster gentoo-dev 2017-01-12 16:35:17 UTC
Created attachment 459792 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-01-12 16:35:19 UTC
Created attachment 459794 [details]
dev-perl:Server-Starter-0.330.0:20170112-163056.log
Comment 3 Toralf Förster gentoo-dev 2017-01-12 16:35:22 UTC
Created attachment 459796 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2017-01-12 16:35:25 UTC
Created attachment 459798 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2017-01-12 16:35:28 UTC
Created attachment 459800 [details]
etc.portage.tbz2
Comment 6 Kent Fredric (IRC: kent\n) gentoo-dev 2017-01-14 16:15:11 UTC
This looks like another case of "Portage doesn't order bdeps properly".

Given that this error happens because Module/Build.pm is in none of @INC

And Module/Build.pm is not in @INC because:

Wed Jan 11 15:58:56 2017 <<< dev-lang/perl-5.22.3_rc4
Wed Jan 11 15:58:58 2017 >>> dev-lang/perl-5.24.1_rc4

And there's no dev-perl/Module-Build between that and the time Server-Starter needed installation.

This means this is a variation of bug #596664 and bug #592880, as it is declared as  BDEP, but portage hasn't ordered things to ensure its working at build time.