Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 604532 - dev-python/ipython-5.4.1 rekeyword request
Summary: dev-python/ipython-5.4.1 rekeyword request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on:
Blocks: 596714
  Show dependency tree
 
Reported: 2017-01-03 17:30 UTC by Pacho Ramos
Modified: 2018-03-27 23:31 UTC (History)
0 users

See Also:
Package list:
dev-python/backports-shutil_get_terminal_size-1.0.0-r1 dev-python/ipython-5.4.1 dev-python/ipython_genutils-0.2.0 dev-python/jedi-0.11.1 dev-python/pathlib-1.0.1-r1 dev-python/pickleshare-0.7.4-r1 dev-python/prompt_toolkit-1.0.15 dev-python/testpath-0.3.1 dev-python/traitlets-4.3.2 dev-python/wcwidth-0.1.7-r1 virtual/python-pathlib-1.0 dev-python/pathlib2-2.3.0 dev-python/scandir-1.7 dev-python/parso-0.1.1
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2017-01-03 17:30:41 UTC
It lost some keywords when being bumped
Comment 1 Stabilization helper bot gentoo-dev 2017-01-06 17:06:57 UTC
An automated check of this bug failed - repoman reported dependency errors (63 lines truncated): 

> dependency.bad dev-python/ipython/ipython-5.1.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pickleshare[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/traitlets-4.2.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/prompt_toolkit-1.0.3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/backports-shutil_get_terminal_size[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]', 'dev-python/testpath[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipython/ipython-5.1.0.ebuild: PDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/qtconsole', 'dev-python/ipyparallel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipython/ipython-5.1.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pickleshare[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/traitlets-4.2.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/prompt_toolkit-1.0.3[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/notebook[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/ipywidgets[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
Comment 2 Stabilization helper bot gentoo-dev 2017-01-07 14:46:58 UTC
An automated check of this bug failed - repoman reported dependency errors (355 lines truncated): 

> dependency.bad dev-python/qtconsole/qtconsole-4.2.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/jupyter_client-4.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.2.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/jupyter_client-4.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.2.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/jupyter_client-4.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipython/ipython-5.1.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/notebook[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/ipywidgets[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/traitlets/traitlets-4.3.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/traitlets/traitlets-4.3.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/traitlets/traitlets-4.3.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/prompt_toolkit/prompt_toolkit-1.0.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/wcwidth[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/prompt_toolkit/prompt_toolkit-1.0.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/wcwidth[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/prompt_toolkit/prompt_toolkit-1.0.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/wcwidth[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/notebook[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/notebook[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/notebook[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/pickleshare/pickleshare-0.7.3.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pathlib[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/pickleshare/pickleshare-0.7.3.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pathlib[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/pickleshare/pickleshare-0.7.3.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/pathlib[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['virtual/python-pathlib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['virtual/python-pathlib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop) ['virtual/python-pathlib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/prompt_toolkit/prompt_toolkit-1.0.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/wcwidth[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
Comment 3 Gleb 2017-08-15 21:17:32 UTC
There's no ipython-5.1.0 anymore. Probably 5.4.1 is a good choice as it should support multiline input in simple prompt (needed by emacs python-mode), and IPython 5 is a last version that support 2.7 branch (so called LTS release).
Comment 4 Andreas Sturmlechner gentoo-dev 2017-12-21 14:01:44 UTC
meh.
Comment 5 Stabilization helper bot gentoo-dev 2017-12-21 15:00:31 UTC
An automated check of this bug failed - the following atoms are unknown:

dev-python/prompt_toolkit-1.0.0
dev-python/prompt_toolkit-1.0.3
dev-python/qtconsole-4.2.1

Please verify the atom list.
Comment 6 Andreas Sturmlechner gentoo-dev 2017-12-21 16:17:42 UTC
of course.
Comment 7 Stabilization helper bot gentoo-dev 2017-12-21 17:02:26 UTC
An automated check of this bug failed - repoman reported dependency errors (414 lines truncated): 

> dependency.bad dev-python/pickleshare/pickleshare-0.7.3.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pathlib[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/pickleshare/pickleshare-0.7.3.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pathlib[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/pickleshare/pickleshare-0.7.3.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/pathlib[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/notebook[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/notebook[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', '>=dev-python/pyzmq-14.4.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/notebook[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipython/ipython-5.4.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/jedi-0.10.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/ipython/ipython-5.4.1.ebuild: PDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/notebook[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipywidgets[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipyparallel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/ipython/ipython-5.4.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/jedi-0.10.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'virtual/python-pathlib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.3.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/jupyter_core[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/jupyter_client-4.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.3.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/jupyter_core[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/jupyter_client-4.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.3.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/jupyter_core[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/jupyter_client-4.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/PyQt5[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),svg,testlib]', 'dev-python/PyQt5[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),svg]', '>=dev-python/pyzmq-13[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/prompt_toolkit/prompt_toolkit-1.0.15.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/wcwidth[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/prompt_toolkit/prompt_toolkit-1.0.15.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/wcwidth[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/prompt_toolkit/prompt_toolkit-1.0.15.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/wcwidth[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/traitlets/traitlets-4.3.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/traitlets/traitlets-4.3.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/traitlets/traitlets-4.3.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipython_genutils[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['virtual/python-pathlib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['virtual/python-pathlib[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 8 Stabilization helper bot gentoo-dev 2018-01-24 23:03:14 UTC
An automated check of this bug failed - repoman reported dependency errors (170 lines truncated): 

> dependency.bad dev-python/ipython/ipython-5.4.1.ebuild: PDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipywidgets[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipyparallel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/ipython/ipython-5.4.1.ebuild: PDEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipyparallel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/ipython/ipython-5.4.1.ebuild: PDEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/ipyparallel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/notebook/notebook-5.0.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/jupyter_core[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/nbformat[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/nbconvert-4.2.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/nose_warnings_filters[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'app-text/pandoc', 'dev-python/nbsphinx[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/notebook/notebook-5.0.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/jupyter_core[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/nbformat[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/nbconvert-4.2.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/notebook/notebook-5.0.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/jupyter_core[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/nbformat[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/nbconvert-4.2.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/nose_warnings_filters[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'app-text/pandoc', 'dev-python/nbsphinx[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.3.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/jupyter_core[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/jupyter_client-4.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.3.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/jupyter_core[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/jupyter_client-4.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.3.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/jupyter_core[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/jupyter_client-4.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/PyQt5[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),svg,testlib]', 'dev-python/PyQt5[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),svg]', '>=dev-python/pyzmq-13[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['>=dev-python/pyzmq-14.4.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]', 'dev-python/jupyter_client[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
Comment 9 Stabilization helper bot gentoo-dev 2018-01-25 12:04:38 UTC
An automated check of this bug failed - repoman reported dependency errors (422 lines truncated): 

> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/ipyparallel/ipyparallel-5.2.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.3.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.3.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/qtconsole/qtconsole-4.3.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/PyQt5[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),svg,testlib]', 'dev-python/PyQt5[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),svg]']
> dependency.bad dev-python/jupyter_core/jupyter_core-4.4.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/sphinxcontrib-github-alt[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/jupyter_core/jupyter_core-4.4.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/sphinxcontrib-github-alt[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/jupyter_core/jupyter_core-4.4.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/sphinxcontrib-github-alt[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pyzmq/pyzmq-16.0.2.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/numpydoc[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pyzmq/pyzmq-16.0.2.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/numpydoc[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/pyzmq/pyzmq-16.0.2.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop/gnome) ['dev-python/numpydoc[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/nbconvert/nbconvert-5.2.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/entrypoints-0.2.2[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/pandocfilters-1.4.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/nbconvert/nbconvert-5.2.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/entrypoints-0.2.2[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/pandocfilters-1.4.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/nbconvert/nbconvert-5.2.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['>=dev-python/entrypoints-0.2.2[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', '>=dev-python/pandocfilters-1.4.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]', 'dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/jupyter_client/jupyter_client-5.1.0-r1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/jupyter_client/jupyter_client-5.1.0-r1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/jupyter_client/jupyter_client-5.1.0-r1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/ipykernel[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/nbformat/nbformat-4.4.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/numpydoc[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/nbformat/nbformat-4.4.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/numpydoc[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 10 Stabilization helper bot gentoo-dev 2018-03-01 19:10:46 UTC
An automated check of this bug failed - repoman reported dependency errors (673 lines truncated): 

> dependency.bad dev-python/jedi/jedi-0.11.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/parso-0.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/jedi/jedi-0.11.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/parso-0.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/jedi/jedi-0.11.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['>=dev-python/parso-0.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad app-text/pandoc/pandoc-1.19.2.1-r1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['>=dev-haskell/aeson-0.7.0.5:=[profile?]', '<dev-haskell/aeson-1.2:=[profile?]', '>=dev-haskell/base64-bytestring-0.1:=[profile?]', '<dev-haskell/base64-bytestring-1.1:=[profile?]', '>=dev-haskell/blaze-html-0.5:=[profile?]', '<dev-haskell/blaze-html-0.10:=[profile?]', '>=dev-haskell/blaze-markup-0.5.1:=[profile?]', '<dev-haskell/blaze-markup-0.9:=[profile?]', '>=dev-haskell/cmark-0.5:=[profile?]', '<dev-haskell/cmark-0.6:=[profile?]', '>=dev-haskell/data-default-0.4:=[profile?]', '<dev-haskell/data-default-0.8:=[profile?]', '>=dev-haskell/doctemplates-0.1:=[profile?]', '<dev-haskell/doctemplates-0.2:=[profile?]', '>=dev-haskell/extensible-exceptions-0.1:=[profile?]', '<dev-haskell/extensible-exceptions-0.2:=[profile?]', '>=dev-haskell/filemanip-0.3:=[profile?]', '<dev-haskell/filemanip-0.4:=[profile?]', '>=dev-haskell/haddock-library-1.1:=[profile?]', '<dev-haskell/haddock-library-1.5:=[profile?]', '>=dev-haskell/hslua-0.3:=[profile?]', '<dev-haskell/hslua-0.5:=[profile?]', '>=dev-haskell/http-4000.0.5:=[profile?]', '<dev-haskell/http-4000.4:=[profile?]', '>=dev-haskell/juicypixels-3.1.6.1:=[profile?]', '<dev-haskell/juicypixels-3.3:=[profile?]', '>=dev-haskell/mtl-2.2:=[profile?]', '<dev-haskell/mtl-2.3:=[profile?]', '>=dev-haskell/old-locale-1:=[profile?]', '<dev-haskell/old-locale-1.1:=[profile?]', 'dev-haskell/old-time:=[profile?]', '>=dev-haskell/pandoc-types-1.17:=[profile?]', '<dev-haskell/pandoc-types-1.18:=[profile?]', '>=dev-haskell/parsec-3.1:=[profile?]', '<dev-haskell/parsec-3.2:=[profile?]', '>=dev-haskell/random-1:=[profile?]', '<dev-haskell/random-1.2:=[profile?]', '>=dev-haskell/scientific-0.2:=[profile?]', '<dev-haskell/scientific-0.4:=[profile?]', '>=dev-haskell/sha-1.6:=[profile?]', '<dev-haskell/sha-1.7:=[profile?]', '>=dev-haskell/skylighting-0.1.1.4:=[profile?]', '>=dev-haskell/syb-0.1:=[profile?]', '<dev-haskell/syb-0.7:=[profile?]', '>=dev-haskell/tagsoup-0.13.7:=[profile?]', '<dev-haskell/tagsoup-0.15:=[profile?]', '>=dev-haskell/temporary-1.1:=[profile?]', '<dev-haskell/temporary-1.3:=[profile?]', '>=dev-haskell/texmath-0.9:=[profile?]', '<dev-haskell/texmath-0.10:=[profile?]', '>=dev-haskell/text-0.11:=[profile?]', '<dev-haskell/text-1.3:=[profile?]', '>=dev-haskell/unordered-containers-0.2:=[profile?]', '<dev-haskell/unordered-containers-0.3:=[profile?]', '>=dev-haskell/vector-0.10:=[profile?]', '<dev-haskell/vector-0.13:=[profile?]', '>=dev-haskell/xml-1.3.12:=[profile?]', '<dev-haskell/xml-1.4:=[profile?]', '>=dev-haskell/yaml-0.8.8.2:=[profile?]', '<dev-haskell/yaml-0.9:=[profile?]', '>=dev-haskell/zip-archive-0.2.3.4:=[profile?]', '<dev-haskell/zip-archive-0.4:=[profile?]', '>=dev-haskell/zlib-0.5:=[profile?]', '<dev-haskell/zlib-0.7:=[profile?]', '>=dev-lang/ghc-7.8.2:=', '>=dev-haskell/http-client-0.4.30:=[profile?]', '<dev-haskell/http-client-0.6:=[profile?]', '>=dev-haskell/http-client-tls-0.2.4:=[profile?]', '<dev-haskell/http-client-tls-0.4:=[profile?]', '>=dev-haskell/http-types-0.8:=[profile?]', '<dev-haskell/http-types-0.10:=[profile?]', '>=dev-haskell/network-2.6:=[profile?]', '>=dev-haskell/network-uri-2.6:=[profile?]', '<dev-haskell/network-uri-2.7:=[profile?]', '>=dev-haskell/network-2:=[profile?]', '<dev-haskell/network-2.6:=[profile?]', '>=dev-haskell/wai-0.3:=[profile?]', 'dev-haskell/wai-extra:=[profile?]', 'dev-haskell/http-types:=[profile?]', '>=dev-haskell/weigh-0.0:=[profile?]', '<dev-haskell/weigh-0.1:=[profile?]', '>=dev-haskell/cabal-1.18.1.3', '>=dev-haskell/ansi-terminal-0.5', '<dev-haskell/ansi-terminal-0.7', '>=dev-haskell/diff-0.2', '<dev-haskell/diff-0.4', '>=dev-haskell/executable-path-0.0', '<dev-haskell/executable-path-0.1', '>=dev-haskell/hunit-1.2', '<dev-haskell/hunit-1.6', '>=dev-haskell/quickcheck-2.4', '<dev-haskell/quickcheck-2.10', '>=dev-haskell/test-framework-0.3', '<dev-haskell/test-framework-0.9', '>=dev-haskell/test-framework-hunit-0.2', '<dev-haskell/test-framework-hunit-0.4', '>=dev-haskell/test-framework-quickcheck2-0.2.9', '<dev-haskell/test-framework-quickcheck2-0.4', 'dev-haskell/hsb2hs', 'dev-haskell/haddock', 'dev-haskell/hscolour']
> dependency.bad app-text/pandoc/pandoc-1.19.2.1-r1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['>=dev-haskell/aeson-0.7.0.5:=[profile?]', '<dev-haskell/aeson-1.2:=[profile?]', '>=dev-haskell/base64-bytestring-0.1:=[profile?]', '<dev-haskell/base64-bytestring-1.1:=[profile?]', '>=dev-haskell/blaze-html-0.5:=[profile?]', '<dev-haskell/blaze-html-0.10:=[profile?]', '>=dev-haskell/blaze-markup-0.5.1:=[profile?]', '<dev-haskell/blaze-markup-0.9:=[profile?]', '>=dev-haskell/cmark-0.5:=[profile?]', '<dev-haskell/cmark-0.6:=[profile?]', '>=dev-haskell/data-default-0.4:=[profile?]', '<dev-haskell/data-default-0.8:=[profile?]', '>=dev-haskell/doctemplates-0.1:=[profile?]', '<dev-haskell/doctemplates-0.2:=[profile?]', '>=dev-haskell/extensible-exceptions-0.1:=[profile?]', '<dev-haskell/extensible-exceptions-0.2:=[profile?]', '>=dev-haskell/filemanip-0.3:=[profile?]', '<dev-haskell/filemanip-0.4:=[profile?]', '>=dev-haskell/haddock-library-1.1:=[profile?]', '<dev-haskell/haddock-library-1.5:=[profile?]', '>=dev-haskell/hslua-0.3:=[profile?]', '<dev-haskell/hslua-0.5:=[profile?]', '>=dev-haskell/http-4000.0.5:=[profile?]', '<dev-haskell/http-4000.4:=[profile?]', '>=dev-haskell/juicypixels-3.1.6.1:=[profile?]', '<dev-haskell/juicypixels-3.3:=[profile?]', '>=dev-haskell/mtl-2.2:=[profile?]', '<dev-haskell/mtl-2.3:=[profile?]', '>=dev-haskell/old-locale-1:=[profile?]', '<dev-haskell/old-locale-1.1:=[profile?]', 'dev-haskell/old-time:=[profile?]', '>=dev-haskell/pandoc-types-1.17:=[profile?]', '<dev-haskell/pandoc-types-1.18:=[profile?]', '>=dev-haskell/parsec-3.1:=[profile?]', '<dev-haskell/parsec-3.2:=[profile?]', '>=dev-haskell/random-1:=[profile?]', '<dev-haskell/random-1.2:=[profile?]', '>=dev-haskell/scientific-0.2:=[profile?]', '<dev-haskell/scientific-0.4:=[profile?]', '>=dev-haskell/sha-1.6:=[profile?]', '<dev-haskell/sha-1.7:=[profile?]', '>=dev-haskell/skylighting-0.1.1.4:=[profile?]', '>=dev-haskell/syb-0.1:=[profile?]', '<dev-haskell/syb-0.7:=[profile?]', '>=dev-haskell/tagsoup-0.13.7:=[profile?]', '<dev-haskell/tagsoup-0.15:=[profile?]', '>=dev-haskell/temporary-1.1:=[profile?]', '<dev-haskell/temporary-1.3:=[profile?]', '>=dev-haskell/texmath-0.9:=[profile?]', '<dev-haskell/texmath-0.10:=[profile?]', '>=dev-haskell/text-0.11:=[profile?]', '<dev-haskell/text-1.3:=[profile?]', '>=dev-haskell/unordered-containers-0.2:=[profile?]', '<dev-haskell/unordered-containers-0.3:=[profile?]', '>=dev-haskell/vector-0.10:=[profile?]', '<dev-haskell/vector-0.13:=[profile?]', '>=dev-haskell/xml-1.3.12:=[profile?]', '<dev-haskell/xml-1.4:=[profile?]', '>=dev-haskell/yaml-0.8.8.2:=[profile?]', '<dev-haskell/yaml-0.9:=[profile?]', '>=dev-haskell/zip-archive-0.2.3.4:=[profile?]', '<dev-haskell/zip-archive-0.4:=[profile?]', '>=dev-haskell/zlib-0.5:=[profile?]', '<dev-haskell/zlib-0.7:=[profile?]', '>=dev-lang/ghc-7.8.2:=', '>=dev-haskell/http-client-0.4.30:=[profile?]', '<dev-haskell/http-client-0.6:=[profile?]', '>=dev-haskell/http-client-tls-0.2.4:=[profile?]', '<dev-haskell/http-client-tls-0.4:=[profile?]', '>=dev-haskell/http-types-0.8:=[profile?]', '<dev-haskell/http-types-0.10:=[profile?]', '>=dev-haskell/network-2.6:=[profile?]', '>=dev-haskell/network-uri-2.6:=[profile?]', '<dev-haskell/network-uri-2.7:=[profile?]', '>=dev-haskell/network-2:=[profile?]', '<dev-haskell/network-2.6:=[profile?]', '>=dev-haskell/wai-0.3:=[profile?]', 'dev-haskell/wai-extra:=[profile?]', 'dev-haskell/http-types:=[profile?]', '>=dev-haskell/weigh-0.0:=[profile?]', '<dev-haskell/weigh-0.1:=[profile?]']
> dependency.bad app-text/pandoc/pandoc-1.19.2.1-r1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['>=dev-haskell/aeson-0.7.0.5:=[profile?]', '<dev-haskell/aeson-1.2:=[profile?]', '>=dev-haskell/base64-bytestring-0.1:=[profile?]', '<dev-haskell/base64-bytestring-1.1:=[profile?]', '>=dev-haskell/blaze-html-0.5:=[profile?]', '<dev-haskell/blaze-html-0.10:=[profile?]', '>=dev-haskell/blaze-markup-0.5.1:=[profile?]', '<dev-haskell/blaze-markup-0.9:=[profile?]', '>=dev-haskell/cmark-0.5:=[profile?]', '<dev-haskell/cmark-0.6:=[profile?]', '>=dev-haskell/data-default-0.4:=[profile?]', '<dev-haskell/data-default-0.8:=[profile?]', '>=dev-haskell/doctemplates-0.1:=[profile?]', '<dev-haskell/doctemplates-0.2:=[profile?]', '>=dev-haskell/filemanip-0.3:=[profile?]', '<dev-haskell/filemanip-0.4:=[profile?]', '>=dev-haskell/haddock-library-1.1:=[profile?]', '<dev-haskell/haddock-library-1.5:=[profile?]', '>=dev-haskell/hslua-0.3:=[profile?]', '<dev-haskell/hslua-0.5:=[profile?]', '>=dev-haskell/juicypixels-3.1.6.1:=[profile?]', '<dev-haskell/juicypixels-3.3:=[profile?]', '>=dev-haskell/pandoc-types-1.17:=[profile?]', '<dev-haskell/pandoc-types-1.18:=[profile?]', '>=dev-haskell/scientific-0.2:=[profile?]', '<dev-haskell/scientific-0.4:=[profile?]', '>=dev-haskell/sha-1.6:=[profile?]', '<dev-haskell/sha-1.7:=[profile?]', '>=dev-haskell/skylighting-0.1.1.4:=[profile?]', '>=dev-haskell/tagsoup-0.13.7:=[profile?]', '<dev-haskell/tagsoup-0.15:=[profile?]', '>=dev-haskell/temporary-1.1:=[profile?]', '<dev-haskell/temporary-1.3:=[profile?]', '>=dev-haskell/texmath-0.9:=[profile?]', '<dev-haskell/texmath-0.10:=[profile?]', '>=dev-haskell/unordered-containers-0.2:=[profile?]', '<dev-haskell/unordered-containers-0.3:=[profile?]', '>=dev-haskell/yaml-0.8.8.2:=[profile?]', '<dev-haskell/yaml-0.9:=[profile?]', '>=dev-haskell/http-client-0.4.30:=[profile?]', '<dev-haskell/http-client-0.6:=[profile?]', '>=dev-haskell/http-client-tls-0.2.4:=[profile?]', '<dev-haskell/http-client-tls-0.4:=[profile?]', '>=dev-haskell/http-types-0.8:=[profile?]', '<dev-haskell/http-types-0.10:=[profile?]', '>=dev-haskell/wai-0.3:=[profile?]', 'dev-haskell/wai-extra:=[profile?]', 'dev-haskell/http-types:=[profile?]', '>=dev-haskell/weigh-0.0:=[profile?]', '<dev-haskell/weigh-0.1:=[profile?]', '>=dev-haskell/diff-0.2', '<dev-haskell/diff-0.4', '>=dev-haskell/executable-path-0.0', '<dev-haskell/executable-path-0.1', 'dev-haskell/hsb2hs']
> dependency.bad dev-python/pickleshare/pickleshare-0.7.4-r1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pathlib2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/pickleshare/pickleshare-0.7.4-r1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pathlib2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/pickleshare/pickleshare-0.7.4-r1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/pathlib2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pathlib2[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/pathlib2[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/pathlib2[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/nbconvert/nbconvert-5.2.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/pandocfilters-1.4.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/nbconvert/nbconvert-5.2.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/pandocfilters-1.4.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/nbconvert/nbconvert-5.2.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['>=dev-python/pandocfilters-1.4.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/ipywidgets/ipywidgets-7.0.0.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/widgetsnbextension-3.0.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/ipywidgets/ipywidgets-7.0.0.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/widgetsnbextension-3.0.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/ipywidgets/ipywidgets-7.0.0.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['>=dev-python/widgetsnbextension-3.0.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/ipython/ipython-3.2.1-r1.ebuild: DEPEND: arm(default/linux/arm/13.0) ['>=dev-python/pyzmq-13[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/ipython/ipython-3.2.1-r1.ebuild: RDEPEND: arm(default/linux/arm/13.0) ['>=dev-python/pyzmq-13[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 11 Andreas Sturmlechner gentoo-dev 2018-03-02 00:54:32 UTC
okay, 3 steps back, adding USE-masks, new attempt.
Comment 12 Stabilization helper bot gentoo-dev 2018-03-02 01:03:42 UTC
An automated check of this bug failed - repoman reported dependency errors (266 lines truncated): 

> dependency.bad dev-python/pickleshare/pickleshare-0.7.4-r1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pathlib2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/pickleshare/pickleshare-0.7.4-r1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pathlib2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/pickleshare/pickleshare-0.7.4-r1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/pathlib2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)]']
> dependency.bad dev-python/jedi/jedi-0.11.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/parso-0.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/jedi/jedi-0.11.1.ebuild: RDEPEND: ~arm(default/linux/arm/13.0) ['>=dev-python/parso-0.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/jedi/jedi-0.11.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['>=dev-python/parso-0.1.1[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.1.ebuild: DEPEND: ~arm(default/linux/arm/13.0) ['dev-python/pathlib2[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0) ['dev-python/pathlib2[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
> dependency.bad dev-python/testpath/testpath-0.3.1.ebuild: DEPEND: ~ppc(default/linux/powerpc/ppc32/13.0/desktop) ['dev-python/pathlib2[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]']
Comment 13 Sergei Trofimovich gentoo-dev 2018-03-06 23:33:48 UTC
commit a02176de631dea5e82490224435c5649ab3e3f9a
Author: Sergei Trofimovich <slyfox@gentoo.org>
Date:   Sun Mar 4 22:38:56 2018 +0000

    dev-python/ipython: stable 5.4.1 for ppc64, bug #596714
Comment 14 Matt Turner gentoo-dev 2018-03-12 00:47:30 UTC
added ~ppc
Comment 15 Andreas Sturmlechner gentoo-dev 2018-03-15 15:01:09 UTC
ping arm
Comment 16 Markus Meier gentoo-dev 2018-03-21 20:24:59 UTC
~arm added.
Comment 17 Matt Turner gentoo-dev 2018-03-27 23:31:12 UTC
mips seems to require a bunch more packages than are listed. Going to ignore this for now and maybe revisit when the mips tree is less broken.