Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 604480 - sys-boot/plymouth-0.9.2 : libply-splash-core/.../libply-splash-core.so: undefined reference to `minor'
Summary: sys-boot/plymouth-0.9.2 : libply-splash-core/.../libply-splash-core.so: undef...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Deadline: 2017-09-02
Assignee: Matthew Thode ( prometheanfire )
URL:
Whiteboard:
Keywords: InVCS
: 627496 627690 (view as bug list)
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2017-01-03 09:06 UTC by Toralf Förster
Modified: 2017-08-18 23:18 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,48.41 KB, text/plain)
2017-01-03 09:06 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,274.33 KB, text/plain)
2017-01-03 09:06 UTC, Toralf Förster
Details
environment (environment,115.67 KB, text/plain)
2017-01-03 09:06 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.60 KB, application/x-bzip)
2017-01-03 09:06 UTC, Toralf Förster
Details
sys-boot:plymouth-0.9.2:20170103-043745.log (sys-boot:plymouth-0.9.2:20170103-043745.log,93.87 KB, text/plain)
2017-01-03 09:06 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,5.68 KB, text/plain)
2017-02-23 17:22 UTC, Toralf Förster
Details
config.log.tbz2 (config.log.tbz2,10.71 KB, application/x-bzip)
2017-02-23 17:22 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,267.04 KB, text/plain)
2017-02-23 17:22 UTC, Toralf Förster
Details
environment (environment,114.12 KB, text/plain)
2017-02-23 17:22 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,22.76 KB, application/x-bzip)
2017-02-23 17:22 UTC, Toralf Förster
Details
sys-boot:plymouth-0.9.2:20170223-165717.log (sys-boot:plymouth-0.9.2:20170223-165717.log,96.04 KB, text/plain)
2017-02-23 17:22 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-01-03 09:06:40 UTC
/bin/sh ../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -Wall -Wno-sign-compare -Wno-deprecated-declarations -rdynamic -DPLYMOUTH_PLUGIN_PATH=\"/usr/lib64/plymouth/\" -DPLYMOUTH_THEME_PATH=\"/usr/share/plymouth/themes/\" -DPLYMOUTH_POLICY_DIR=\"/usr/share/plymouth//\" -DPLYMOUTH_RUNTIME_DIR=\"/var/run/plymouth\" -DPLYMOUTH_CONF_DIR=\"/etc/plymouth//\" -O2 -pipe -march=native -Wall  -Wl,-O1 -Wl,--as-needed -o plymouthd plymouthd-ply-boot-server.o plymouthd-plugin.o plymouthd-main.o -lm -lrt -ldl libply/libply.la libply-splash-core/libply-splash-core.la 
libtool: link: x86_64-pc-linux-gnu-gcc -Wall -Wno-sign-compare -Wno-deprecated-declarations -rdynamic -DPLYMOUTH_PLUGIN_PATH=\"/usr/lib64/plymouth/\" -DPLYMOUTH_THEME_PATH=\"/usr/share/plymouth/themes/\" -DPLYMOUTH_POLICY_DIR=\"/usr/share/plymouth//\" -DPLYMOUTH_RUNTIME_DIR=\"/var/run/plymouth\" -DPLYMOUTH_CONF_DIR=\"/etc/plymouth//\" -O2 -pipe -march=native -Wall -Wl,-O1 -o .libs/plymouthd plymouthd-ply-boot-server.o plymouthd-plugin.o plymouthd-main.o  -Wl,--as-needed libply/.libs/libply.so libply-splash-core/.libs/libply-splash-core.so -ludev /var/tmp/portage/sys-boot/plymouth-0.9.2/work/plymouth-0.9.2_build/src/libply/.libs/libply.so -lm -lrt -ldl
libply-splash-core/.libs/libply-splash-core.so: undefined reference to `minor'

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named gnome-libressl-unstable_20161228-111942) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  from make.conf:
USE="  -openssl -gnutls libressl pax_kernel xtpax -cdinstall -oci8 -bindist ssp -avformat consolekit go ldap libkms libvirtd logrotate lzma mad -pcre16 -plotutils pypy qt5 rendering secure-delete -spice uml -utils vpx wayland webstart -xmp"

gcc-config -l:
 [1] x86_64-pc-linux-gnu-5.4.0 *
llvm-config --version:
3.9.1
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Available Python interpreters, in order of preference:
  [1]   python2.7
  [2]   python3.4
  [3]   python3.5 (fallback)
  [4]   jython2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.2.0 [icedtea-bin-8]
  -----------------------------------------------------------------



$ cat emerge-info.txt
Portage 2.3.3 (python 2.7.12-final-0, default/linux/amd64/13.0/desktop/gnome, gcc-5.4.0, glibc-2.24, 4.8.15-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.8.15-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285560 total,   1262320 free
KiB Swap:   67108860 total,  67091616 free
Timestamp of repository gentoo: Tue, 03 Jan 2017 02:02:47 +0000
sh bash 4.4_p5-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4_p5-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.2::gentoo
dev-util/cmake:           3.7.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.27::gentoo
sys-devel/gcc:            5.4.0-r2::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.24::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

tinderbox
    location: /tmp/tb/data/portage
    masters: gentoo
    priority: 2

local
    location: /usr/local/portage
    masters: gentoo
    priority: 99

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -Wall"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/omega.conf /opt/openfire/resources/security/ /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit convert cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam ffmpeg firefox flac fortran gd gdbm gif glamor gnome gnome-keyring gnome-online-accounts go gpm gstreamer gtk iconv icu introspection ipv6 jpeg lcms ldap libkms libnotify libressl libsecret libvirtd logrotate lzma mad messages mikmod mmx mmxext mng mod modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pax_kernel pcre pdf png policykit ppds pulseaudio pypy python qml qt3support qt4 qt5 readline rendering sdl seccomp secure-delete session spell sse sse2 ssl ssp startup-notification svc svg system-ffmpeg tcpd tiff tracker truetype udev udisks uml unicode upower usb video vorbis vpx wayland webstart wxwidgets x264 xattr xcb xml xtpax xv xvid zlib" ABI_X86="32 64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="libressl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="bs es-419 fy ja ks ku sq st sv" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2017-01-03 09:06:46 UTC
Created attachment 458484 [details]
config.log
Comment 2 Toralf Förster gentoo-dev 2017-01-03 09:06:49 UTC
Created attachment 458486 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-01-03 09:06:52 UTC
Created attachment 458488 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-01-03 09:06:55 UTC
Created attachment 458490 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-01-03 09:06:58 UTC
Created attachment 458492 [details]
sys-boot:plymouth-0.9.2:20170103-043745.log
Comment 6 Michael Weber (RETIRED) gentoo-dev 2017-02-23 12:40:53 UTC
could not reproduce.
Comment 7 Toralf Förster gentoo-dev 2017-02-23 17:22:06 UTC
same at a tinderbox image
Comment 8 Toralf Förster gentoo-dev 2017-02-23 17:22:16 UTC
reproducible at another tinderbox image
Comment 9 Toralf Förster gentoo-dev 2017-02-23 17:22:18 UTC
Created attachment 464908 [details]
emerge-info.txt
Comment 10 Toralf Förster gentoo-dev 2017-02-23 17:22:22 UTC
Created attachment 464910 [details]
config.log.tbz2
Comment 11 Toralf Förster gentoo-dev 2017-02-23 17:22:25 UTC
Created attachment 464912 [details]
emerge-history.txt
Comment 12 Toralf Förster gentoo-dev 2017-02-23 17:22:28 UTC
Created attachment 464914 [details]
environment
Comment 13 Toralf Förster gentoo-dev 2017-02-23 17:22:31 UTC
Created attachment 464916 [details]
etc.portage.tbz2
Comment 14 Toralf Förster gentoo-dev 2017-02-23 17:22:34 UTC
Created attachment 464918 [details]
sys-boot:plymouth-0.9.2:20170223-165717.log
Comment 15 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-08-03 20:11:57 UTC
# Michał Górny <mgorny@gentoo.org> (04 Aug 2017)
# sys-boot/plymouth is unmaintained since Apr 2016. The current version
# has multiple bugs, including not supporting OpenRC. It really needs
# an active maintainer. Removal in 30 days. Bug #621470.
#
# The remaining packages are sys-boot/plymouth reverse dependencies.
# They have no use without it, so they are being removed as well.
kde-plasma/breeze-plymouth
kde-plasma/plymouth-kcm
sys-boot/plymouth
sys-boot/plymouth-openrc-plugin
Comment 16 Gilles Dartiguelongue gentoo-dev 2017-08-11 21:50:33 UTC
*** Bug 627496 has been marked as a duplicate of this bug. ***
Comment 17 Gilles Dartiguelongue gentoo-dev 2017-08-14 16:47:01 UTC
*** Bug 627690 has been marked as a duplicate of this bug. ***
Comment 18 Maciej Piechotka 2017-08-14 18:11:05 UTC
As a side note (for all future people running into this) - there is working patch attached to one of duplicate bugs:
https://627496.bugs.gentoo.org/attachment.cgi?id=488550
Comment 19 Gilles Dartiguelongue gentoo-dev 2017-08-17 22:47:08 UTC
Applied patch provided in bug #627496.