Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 603074 - net-irc/quassel-0.12.4[X,-qt5]: input widget backlog is unusable
Summary: net-irc/quassel-0.12.4[X,-qt5]: input widget backlog is unusable
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-19 09:58 UTC by Sam Jorna (wraeth)
Modified: 2017-12-03 17:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam Jorna (wraeth) gentoo-dev 2016-12-19 09:58:51 UTC
When quassel (client) is built with USE="X -qt5", the input widget's backlog/history seems prepend the input with a colour code, making text either repeated from history or entered after scrolling through history to be (in my case) black, and invalidating any "/" commands.

Steps to reproduce:
1. emerge net-irc/quassel[X,-qt5] (note that deps may be involved)
2. Connect to a network
3. Send a message
4. Press up and resend message

Expected Results:
Text to be entered verbatim

Actual Results:
Text is prefixed with a colour code, causing coloured text in channels without +c and invalidating any client/server commands (eg. /mode).

I suspect this is due to a dependency issue between the two USE flags.

Also, both the X and qt5 USE flags describe building the Qt5 GUI. It probably doesn't make sense to be able to install with these flags, so perhaps either use REQUIRED_USE or remove the qt5 flag to make it implicit.
Comment 1 Johannes Huber gentoo-dev 2017-06-05 11:27:47 UTC
Please paste the output of emerge --info =net-irc/quassel-0.12.4. qt5 use flag will be dropped in 0.13.0. So you could try with 9999 where the change is already applied.
Comment 2 Larry the Git Cow gentoo-dev 2017-12-03 17:02:44 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c96e81087ffa6f944548d2279c822f825065f220

commit c96e81087ffa6f944548d2279c822f825065f220
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2017-12-03 16:43:32 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2017-12-03 17:01:39 +0000

    net-irc/quassel: Drop USE=qt5, build with Qt5 unconditionally
    
    Acked-by: Patrick Lauer <patrick@gentoo.org>
    Closes: https://bugs.gentoo.org/639608
    Closes: https://bugs.gentoo.org/603074
    Package-Manager: Portage-2.3.16, Repoman-2.3.6

 net-irc/quassel/Manifest              |  2 +-
 net-irc/quassel/quassel-0.12.4.ebuild | 92 +++++++++++------------------------
 2 files changed, 30 insertions(+), 64 deletions(-)