Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 601692 - sys-fabric/ofed-4.17 version bump
Summary: sys-fabric/ofed-4.17 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Cluster Team
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2016-12-05 16:42 UTC by Adam Tygart
Modified: 2022-02-15 09:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Tygart 2016-12-05 16:42:59 UTC
The current stable release (per the openfabrics alliance) is 3.18-2 and was released in July. In particular the new libfabric library and the updates to mlx4 and mlx5 drivers would be nice.

Reproducible: Always
Comment 1 Timo Rothenpieler 2019-06-18 10:21:58 UTC
The whole IB system seems to be in need of a lot of work.
According to https://www.openfabrics.org/downloads/verbs/
A lot of the libraries have been consolidated in https://github.com/linux-rdma/rdma-core
Comment 3 Timo Rothenpieler 2019-09-08 11:20:52 UTC
Is there a particular reason you removed all the special handling to enable proper PYTHON_TARGETS support?

Also, why is it moved to sys-cluster from sys-fabric? This is for InfiniBand support, so sys-fabric seems way more fitting to me, specially as all the packages it replaces are there.
Comment 4 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-09-08 11:30:23 UTC
(In reply to Timo Rothenpieler from comment #3)
> Is there a particular reason you removed all the special handling to enable
> proper PYTHON_TARGETS support?
> 
> Also, why is it moved to sys-cluster from sys-fabric? This is for InfiniBand
> support, so sys-fabric seems way more fitting to me, specially as all the
> packages it replaces are there.

Hi,

there is no really special python support, so standard eclass is more than enough to handle all the python-ish stuff. 

As for a category, alexxy (who is the original supporter) and I have discussed this privately and decided to drop sys-fabric as a category once rdma-core is stable, because only few package are going to be left in the there otherwise, I will pull the rest out soonish and last-rite the whole sys-fabric/* as well (along with openib eclass).
Comment 5 Larry the Git Cow gentoo-dev 2022-01-16 18:26:58 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=64c4669b760a6db1f123dc033440ea371200f443

commit 64c4669b760a6db1f123dc033440ea371200f443
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2022-01-16 18:26:50 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2022-01-16 18:26:50 +0000

    openib.eclass: last-rite for removal
    
    Closes: https://github.com/gentoo/gentoo/pull/23716
    Bug: https://bugs.gentoo.org/601692
    Bug: https://bugs.gentoo.org/830999
    Signed-off-by: David Seifert <soap@gentoo.org>

 eclass/openib.eclass | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a8d67eb0ac4ef3dfb726aad6cf527b5c0d4ed03f

commit a8d67eb0ac4ef3dfb726aad6cf527b5c0d4ed03f
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2022-01-16 18:26:47 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2022-01-16 18:26:47 +0000

    profiles: last-rite most of sys-fabric/*
    
    Bug: https://bugs.gentoo.org/601692
    Bug: https://bugs.gentoo.org/830999
    Signed-off-by: David Seifert <soap@gentoo.org>

 profiles/package.mask | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
Comment 6 Larry the Git Cow gentoo-dev 2022-02-15 09:24:08 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b44fc7b306628880684f75650bec93b5933de1fb

commit b44fc7b306628880684f75650bec93b5933de1fb
Author:     Jakov Smolić <jsmolic@gentoo.org>
AuthorDate: 2022-02-15 09:09:32 +0000
Commit:     Jakov Smolić <jsmolic@gentoo.org>
CommitDate: 2022-02-15 09:22:33 +0000

    sys-fabric/ofed: treeclean
    
    Closes: https://bugs.gentoo.org/601692
    Closes: https://bugs.gentoo.org/806290
    Closes: https://bugs.gentoo.org/642494
    Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>

 profiles/package.mask                 |   1 -
 sys-fabric/ofed/Manifest              |   1 -
 sys-fabric/ofed/files/90-ib.rules     |   5 -
 sys-fabric/ofed/files/openib          | 242 ----------------------------------
 sys-fabric/ofed/files/openib.conf     |  27 ----
 sys-fabric/ofed/files/openib.env      |   1 -
 sys-fabric/ofed/files/openib.modprobe |  12 --
 sys-fabric/ofed/metadata.xml          |  17 ---
 sys-fabric/ofed/ofed-3.12_rc1.ebuild  | 147 ---------------------
 9 files changed, 453 deletions(-)