Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 601068 - media-libs/jasper-2.0.0 should depend on x11-libs/libXmu...no, not really
Summary: media-libs/jasper-2.0.0 should depend on x11-libs/libXmu...no, not really
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2016-11-28 12:40 UTC by Jan-Matthias Braun
Modified: 2019-08-27 09:07 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Add the missing multilib dependency on libXmu. (jasper-2.0.0_add_libXmu_multilib_dep.patch,319 bytes, patch)
2016-11-28 12:40 UTC, Jan-Matthias Braun
Details | Diff
build.log (build.log,57.38 KB, text/plain)
2016-11-29 19:58 UTC, jospezial
Details
patch for jasper sources (jasper-opengl-cleanup.patch,2.30 KB, patch)
2017-06-15 13:47 UTC, Rafał Mużyło
Details | Diff
patch for the ebuild (jasper-ebuild.patch,978 bytes, patch)
2017-06-15 13:50 UTC, Rafał Mużyło
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan-Matthias Braun 2016-11-28 12:40:17 UTC
Created attachment 454588 [details, diff]
Add the missing multilib dependency on libXmu.

When compiled in my multilib-environment, libXmu is missing for the abi32 compile.
Comment 1 Jeroen Roovers gentoo-dev 2016-11-28 13:17:51 UTC
*** Bug 601070 has been marked as a duplicate of this bug. ***
Comment 2 Jeroen Roovers gentoo-dev 2016-11-28 13:20:03 UTC
Comment on attachment 454588 [details, diff]
Add the missing multilib dependency on libXmu.

Confirmed. Sorry for the earlier confusion.
Comment 3 Agostino Sarubbo gentoo-dev 2016-11-29 16:41:54 UTC
(In reply to Jan-Matthias Braun from comment #0)
> Created attachment 454588 [details, diff] [details, diff]
> Add the missing multilib dependency on libXmu.
> 
> When compiled in my multilib-environment, libXmu is missing for the abi32
> compile.

Jan, thanks for the report.

Does it happen only with USE opengl enabled or also with -opengl?
Comment 4 jospezial 2016-11-29 19:57:36 UTC
In build log you see where the dependency comes from:

-- Found OpenGL: /usr/lib32/libGL.so  
-- Found GLUT: /usr/lib32/libglut.so  
-- Looking for include file GL/glut.h
-- Looking for include file GL/glut.h - found
GLUT library found: TRUE
GLUT libraries: /usr/lib32/libglut.so;/usr/lib/libXmu.so;/usr/lib32/libXi.so
GLUT include directory: /usr/include
JAS_HAVE_GL_GLUT_H: 1
Comment 5 jospezial 2016-11-29 19:58:57 UTC
Created attachment 454708 [details]
build.log
Comment 6 Jan-Matthias Braun 2016-11-30 20:25:51 UTC
(In reply to Agostino Sarubbo from comment #3)
> (In reply to Jan-Matthias Braun from comment #0)
> > Created attachment 454588 [details, diff] [details, diff] [details, diff]
> > Add the missing multilib dependency on libXmu.
> > 
> > When compiled in my multilib-environment, libXmu is missing for the abi32
> > compile.
> 
> Jan, thanks for the report.
> 
> Does it happen only with USE opengl enabled or also with -opengl?

Yes, it only happens with USE="opengl".
Comment 7 Jan-Matthias Braun 2016-12-05 10:20:02 UTC
Hi! With the updated jasper-2.0.0.ebuild in portage, this can be closed, right?

At least it works quite fine for me. Thanks a lot!
Comment 8 jospezial 2016-12-05 20:23:12 UTC
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-libs/jasper-2.0.0::gentoo[opengl]
# required by media-gfx/gimp-2.9.4-r1::gentoo[jpeg2k]
# required by @__auto_slot_operator_replace_installed__ (argument)
>=x11-libs/libXmu-1.1.2 abi_x86_32

nice!
Comment 9 Rafał Mużyło 2017-05-08 12:59:17 UTC
Sorry to jump in this late, but this fix isn't really proper, not for Gentoo at least.

This is a case of "the problem lies elsewhere".

Let's trace it back to the source...

The error comes from FindGLUT macro, originating from cmake itself.

Now, why the above "fix" is wrong ?

It's actually pretty simple, this macro was written with original, *underlinked* GLUT in mind, not freeglut (which is what Gentoo uses). freeglut doesn't use libXmu, not according to ldd output nor its ebuild.

The problem is of course a proper fix would involve patching the incorrect macro in cmake (well, a temporary fix could just ship a local version of fixed macro).

Well, at least for the other packages, for jasper we could go with a simple hack:
in toplevel CMakeLists.txt, there's that long-winded Fedora comment. I strongly suspect Fedora noticed this problem in cmake and patched it in some way (perhaps an incomplete one). I've only done a rough test, but it looks, that this whole section should simply be turned into unconditional 'set(GLUT_LIBRARIES "${GLUT_glut_LIBRARY}")'.

Though, perhaps I'm not searching the sources correctly, cause it seems glut is only used by jiv executable, so glut dep should be only valid for native, whereas 32bit should simply built with opengl disabled.
Comment 10 Rafał Mużyło 2017-05-08 13:01:31 UTC
...of course the last sentence was written from amd64 perspective, not really valid for x86.
Comment 11 Rafał Mużyło 2017-05-08 13:13:27 UTC
...there's a catch though: it looks like jasper caches glut detection value in its config header.

Though it seems, that this is simply from improper porting from previous build system, when somebody took "one size fits all" approach to all build conditionals.

Perhaps those two values should simply be removed from the header template ?
Comment 12 Rafał Mużyło 2017-05-22 20:09:07 UTC
OK, let's see if cmake maintainers will add something.
Comment 13 Rafał Mużyło 2017-06-15 13:47:43 UTC
Created attachment 476530 [details, diff]
patch for jasper sources

Well, seeing as this is going nowhere on its own, following patches seem to make things work as they're supposed to.
Comment 14 Rafał Mużyło 2017-06-15 13:50:05 UTC
Created attachment 476532 [details, diff]
patch for the ebuild
Comment 15 Larry the Git Cow gentoo-dev 2019-07-14 10:30:13 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c70fe723dcfe0fabab75f3a76942207018e83e1f

commit c70fe723dcfe0fabab75f3a76942207018e83e1f
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2019-07-14 10:29:20 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2019-07-14 10:29:20 +0000

    package.mask: Last rite media-libs/jasper
    
    Bug: https://bugs.gentoo.org/601068
    Bug: https://bugs.gentoo.org/614028
    Bug: https://bugs.gentoo.org/614032
    Bug: https://bugs.gentoo.org/614566
    Bug: https://bugs.gentoo.org/619120
    Bug: https://bugs.gentoo.org/624988
    Bug: https://bugs.gentoo.org/629286
    Bug: https://bugs.gentoo.org/635552
    Bug: https://bugs.gentoo.org/662160
    Bug: https://bugs.gentoo.org/674154
    Bug: https://bugs.gentoo.org/674214
    Bug: https://bugs.gentoo.org/684826
    Bug: https://bugs.gentoo.org/689784
    Signed-off-by: David Seifert <soap@gentoo.org>

 profiles/base/package.use.mask | 23 +++++++++++++++++++++++
 profiles/package.mask          |  7 +++++++
 2 files changed, 30 insertions(+)
Comment 16 Larry the Git Cow gentoo-dev 2019-08-27 09:07:48 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=77aebdf0b31765b33831ca5b02ea3d98f13c46cd

commit 77aebdf0b31765b33831ca5b02ea3d98f13c46cd
Author:     David Seifert <soap@gentoo.org>
AuthorDate: 2019-08-27 09:07:01 +0000
Commit:     David Seifert <soap@gentoo.org>
CommitDate: 2019-08-27 09:07:01 +0000

    media-libs/jasper: Remove from tree
    
    Bug: https://bugs.gentoo.org/674214
    Closes: https://bugs.gentoo.org/601068
    Closes: https://bugs.gentoo.org/614028
    Closes: https://bugs.gentoo.org/614032
    Closes: https://bugs.gentoo.org/614566
    Closes: https://bugs.gentoo.org/619120
    Closes: https://bugs.gentoo.org/624988
    Closes: https://bugs.gentoo.org/629286
    Closes: https://bugs.gentoo.org/635552
    Closes: https://bugs.gentoo.org/662160
    Closes: https://bugs.gentoo.org/674154
    Closes: https://bugs.gentoo.org/684826
    Closes: https://bugs.gentoo.org/689784
    Package-Manager: Portage-2.3.72, Repoman-2.3.17
    Signed-off-by: David Seifert <soap@gentoo.org>

 media-libs/jasper/Manifest                         |  2 -
 .../files/jasper-2.0.14-fix-test-suite.patch       | 28 ---------
 media-libs/jasper/jasper-2.0.14.ebuild             | 67 ----------------------
 media-libs/jasper/jasper-2.0.16.ebuild             | 65 ---------------------
 media-libs/jasper/jasper-9999.ebuild               | 65 ---------------------
 media-libs/jasper/metadata.xml                     | 11 ----
 6 files changed, 238 deletions(-)