Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 59998 - Gentoo crashes when building glibc-
Summary: Gentoo crashes when building glibc-
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo Toolchain Maintainers
Depends on:
Reported: 2004-08-10 15:37 UTC by Bengt Frost
Modified: 2004-08-14 15:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

glibc- - build output (emerge --update system) (glibc-,107.57 KB, application/x-bzip)
2004-08-11 13:27 UTC, Bengt Frost
build output glibc- (glibc-,1.96 KB, text/plain)
2004-08-11 13:53 UTC, Bengt Frost

Note You need to log in before you can comment on or make changes to this bug.
Description Bengt Frost 2004-08-10 15:37:25 UTC
emerge --update system builds glibc- and the system
then crashes after a while.

Last lines of output before crash:
gcc auth_none.c -c -std=gnu99 -O2 -Wall -Winline -Wstrict-prototypes -Wwrite-strings -freorder-blocks -march=athlon-xp -mpreferred-stack-boundary=2     -I../include -I. -I/var/tmp/portage/glibc- -I.. -I../libio  -I/var/tmp/portage/glibc- -I../sysdeps/i386/elf -I../linuxthreads/sysdeps/unix/sysv/linux/i386 -I../linuxthreads/sysdeps/unix/sysv/linux -I../linuxthreads/sysdeps/pthread -I../sysdeps/pthread -I../linuxthreads/sysdeps/unix/sysv -I../linuxthreads/sysdeps/unix -I../linuxthreads/sysdeps/i386/i686 -I../linuxthreads/sysdeps/i386 -I../sysdeps/unix/sysv/linux/i386 -I./*

Reproducible: Always
Steps to Reproduce:
1. emerge --update system

Actual Results:  
Gentoo crashes and reboots.

Expected Results:  
Build gnu-c library.

System uname: 2.4.27 i686 AMD Athlon(tm) XP 2400+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.3
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs ccache sandbox"
USE="X apache2 apm arts avi berkdb cdr crypt cups encode esd foomaticdb gdbm gif
gnome gpm gtk gtk2 imlib java jpeg libg++ libwww mad mikmod motif mozilla mpeg
ncurses nls oggvorbis opengl oss pam pdflib perl png python quicktime readline
sdl slang spell ssl svg svga tcltk tcpd truetype unicode x86 xml2 xmms xv zlib"
Comment 1 Bengt Frost 2004-08-11 13:27:06 UTC
Created attachment 37244 [details]
glibc- - build output (emerge --update system)

New build (emerge --update system) - August 11 2004
Comment 2 solar (RETIRED) gentoo-dev 2004-08-11 13:32:58 UTC
You attachment is a binary file and unreadable. 
Please attach a readable text/plain output.
Comment 3 Bengt Frost 2004-08-11 13:53:26 UTC
Created attachment 37245 [details]
build output glibc-

end of build output before system crash.
Comment 4 solar (RETIRED) gentoo-dev 2004-08-11 17:41:42 UTC
I've only heard of one other person that this has ever happened for. 
Till now I assumed it was bad hardware.
Can you confirm it happens in the exact same place every time?

Could you also please test with CFLAGS="-march=i686 -mcpu=athlon-xp -O2"
And then maybe USE="-*" 
Comment 5 Gustavo Zacarias (RETIRED) gentoo-dev 2004-08-11 18:02:17 UTC
I upgraded fine with CFLAGS="-march=athlon-xp -O3 -pipe" on my athlon64 here.
My USE flags are quite extensive too:

USE="3dnow X Xaw3d aac aalib accessibility acpi aim alsa apm arts avi berkdb bonobo cdr cjk crypt cups doc dvd dvdr encode esd faad ffmpeg flac flash foomaticdb gdbm gif glade gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile icq ieee1394 imagemagick imap imlib ipv6 java jpeg kde lcms ldap libcaca libg++ libwww mad mikmod mmx mng motif mozilla mpeg msn nas ncurses nls offensive oggvorbis opengl oss pam pda pdflib perl png ppds python qt quicktime radeon readline samba scanner sdl slang slp socks5 speex spell sse ssl svga tcltk tcpd tetex theora tiff truetype unicode usb wmf x86 xinerama xml xml2 xmms xv xvid yahoo zlib"
Comment 6 Bengt Frost 2004-08-12 07:39:11 UTC
I've tried with both build flags and with and without USE-flags which sadly still results in a system crash. It is probably hardware error because build stops at different places (in memory) every time. I think it is a harddisk- or graphic error so I have to buy this "stuff" and then compile and install Gentoo again. I be back. Thank you for helping me. By the way how stable is ReiserFS ? I am using it on two of my disks.
Comment 7 Bengt Frost 2004-08-14 14:28:58 UTC
After upgrading my BIOS, bought a new harddisk and videocard (needed anyway), switching CPU's I finally found the problem to be a corruct RAM so I changed it and voila problem solved. I now also have a "freshly" build Gentoo 2004.2. Nice.
Again thanks for the advices I've recieved. 
Comment 8 Bengt Frost 2004-08-14 14:33:08 UTC
Problem solved. See previous message.
Comment 9 solar (RETIRED) gentoo-dev 2004-08-14 15:21:36 UTC
This should of been closed as INVALID and the Gentoo Team fixed nothing in this case.