Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 598454 - media-gfx/graphicsmagick-1.3.25 : magick/blob.c:4675:48: error: ‘MagickFileHandle {aka union _MagickFileHandle}’ has no member named ‘gz’; did you mean ‘bz’?
Summary: media-gfx/graphicsmagick-1.3.25 : magick/blob.c:4675:48: error: ‘MagickFileHa...
Status: RESOLVED DUPLICATE of bug 641164
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-29 15:16 UTC by Toralf Förster
Modified: 2019-04-03 09:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,172.92 KB, text/plain)
2016-10-29 15:16 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,200.21 KB, text/plain)
2016-10-29 15:16 UTC, Toralf Förster
Details
environment (environment,70.84 KB, text/plain)
2016-10-29 15:16 UTC, Toralf Förster
Details
media-gfx:graphicsmagick-1.3.25:20161029-145028.log (media-gfx:graphicsmagick-1.3.25:20161029-145028.log,25.88 KB, text/plain)
2016-10-29 15:16 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,15.68 KB, text/plain)
2018-02-05 18:34 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,222.05 KB, text/plain)
2018-02-05 18:34 UTC, Toralf Förster
Details
environment (environment,58.72 KB, text/plain)
2018-02-05 18:34 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,15.63 KB, application/x-bzip)
2018-02-05 18:34 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,18.54 KB, application/x-bzip)
2018-02-05 18:34 UTC, Toralf Förster
Details
media-gfx:graphicsmagick-1.3.28:20180205-021735.log (media-gfx:graphicsmagick-1.3.28:20180205-021735.log,26.09 KB, text/plain)
2018-02-05 18:34 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,23.71 KB, application/x-bzip)
2018-02-05 18:34 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-10-29 15:16:36 UTC
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -fopenmp -march=native -O2 -pipe -Wall -c magick/blob.c  -fPIC -DPIC -o magick/.libs/magick_libGraphicsMagick_la-blob.o
magick/blob.c: In function ‘WriteBlob’:
magick/blob.c:4675:48: error: ‘MagickFileHandle {aka union _MagickFileHandle}’ has no member named ‘gz’; did you mean ‘bz’?
           count=BZ2_bzwrite(image->blob->handle.gz,
                                                ^
make[1]: *** [Makefile:7067: magick/magick_libGraphicsMagick_la-blob.lo] Error 1


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-13.0-libressl-unstable_20161026-090714) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags ...

  ... in make.conf:
USE="  -openssl -gnutls libressl pax_kernel xtpax -cdinstall -oci8 -bindist ssp designer dot dvb -emacs ext4 -fitz -gd gif gstreamer ipv6 lapack melt opus -postscript python qml sasl sddm -ssh-askpass system-harfbuzz utils vim widgets xa xinetd xmp xscreensaver -zlib"

  ... in /etc/portage/package.use/*:
  mail-mta/ssmtp      mta ssl
  net-misc/wget       ssl
  app-editors/xemacs  -nopie
  dev-db/sqlite           secure-delete
  dev-lang/python         sqlite
  dev-qt/qtsql            sqlite
  mail-client/thunderbird -pulseaudio system-icu
  media-libs/libvpx       postproc
  media-libs/libpng       apng
  media-sound/pulseaudio  alsa
  media-video/ffmpeg      sdl
  sys-libs/ntdb           python
  sys-libs/tdb            python
  sys-libs/tevent         python
  x11-libs/cairo          X
  x11-libs/libxcb         xkb
  www-client/firefox      -pulseaudio system-icu
  app-crypt/mit-krb5      -pkinit
  media-video/ffmpeg      -sdl
  sys-devel/llvm          clang
  sys-libs/zlib           minizip
  x11-base/xorg-server    glamor -minimal
  app-crypt/pinentry  -qt4
  app-editors/emacs   -dbus -gtk -gtk3 -ssl -svg
  app-text/xmlto      -latex
  dev-libs/boehm-gc   threads
  dev-libs/libpcre    pcre16
  dev-lang/python     threads
  dev-qt/qtgui        egl eglfs
  dev-util/cmake      -qt4 -qt5
  dev-vcs/git         -gtk -perl
  gnome-base/librsvg  -tools
  media-libs/mesa     -vaapi
  net-nds/openldap    -sasl
  sys-apps/kmod       tools
  sys-libs/ncurses    -gpm
  x11-libs/gtk+       -cups
  net-misc/iputils -caps -filecaps
  dev-db/mysql-connector-c  -ssl
  dev-lang/python           -tk
  dev-qt/qtsql              -mysql
  mail-mta/ssmtp            libressl -gnutls

  entries in /etc/portage/package.unmask/*:
  ~sys-apps/sandbox-2.11
  ~dev-libs/botan-1.11.32
  sys-devel/gcc:6.2.0
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.2.0 *
llvm-config --version:
3.9.0

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)

java-config:

  -----------------------------------------------------------------

Portage 2.3.2 (python 3.4.5-final-0, default/linux/amd64/13.0, gcc-6.2.0, glibc-2.23-r2, 4.7.10-hardened-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.7.10-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285608 total,   7868168 free
KiB Swap:   67108860 total,  67106248 free
Timestamp of repository gentoo: Sat, 29 Oct 2016 12:42:08 +0000
sh bash 4.4-r1
ld GNU ld (Gentoo 2.26.1 p1.0) 2.26.1
ccache version 3.2.7 [disabled]
app-shells/bash:          4.4-r1::gentoo
dev-lang/perl:            5.24.0-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/ccache:          3.2.7::gentoo
dev-util/cmake:           3.6.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.2::gentoo
sys-apps/sandbox:         2.11-r2::gentoo
sys-devel/autoconf:       2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.26.1::gentoo
sys-devel/gcc:            6.2.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/fax /usr/share/config /usr/share/gnupg/qualified.txt /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-Werror=terminate -march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cxx designer dot dri dvb ext4 fortran gdbm gif gstreamer iconv ipv6 lapack libressl melt mmx mmxext modules multilib ncurses nls nptl openmp opus pam pax_kernel pcre python qml readline sasl sddm seccomp session sse sse2 ssl ssp system-harfbuzz tcpd unicode utils vim widgets xa xattr xinetd xmp xscreensaver xtpax" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="libressl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="as en-GB lv sv" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-10-29 15:16:43 UTC
Created attachment 451880 [details]
config.log
Comment 2 Toralf Förster gentoo-dev 2016-10-29 15:16:45 UTC
Created attachment 451882 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-10-29 15:16:48 UTC
Created attachment 451884 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2016-10-29 15:16:51 UTC
Created attachment 451886 [details]
media-gfx:graphicsmagick-1.3.25:20161029-145028.log
Comment 5 Andreas K. Hüttel gentoo-dev 2017-09-30 17:47:44 UTC
Hmm, I can't reproduce this. Cosmic radiation?

Closing for now...
Comment 6 Toralf Förster gentoo-dev 2018-02-05 18:34:09 UTC
got at the unstable amd64 chroot image 17.0-systemd_abi32+64_20180131-183348 this : magick/blob.c:4928:42: error: MagickFileHandle {aka union _MagickFileHandle} has no member named gz
Comment 7 Toralf Förster gentoo-dev 2018-02-05 18:34:15 UTC
Created attachment 517890 [details]
emerge-info.txt
Comment 8 Toralf Förster gentoo-dev 2018-02-05 18:34:18 UTC
Created attachment 517892 [details]
emerge-history.txt
Comment 9 Toralf Förster gentoo-dev 2018-02-05 18:34:20 UTC
Created attachment 517894 [details]
environment
Comment 10 Toralf Förster gentoo-dev 2018-02-05 18:34:23 UTC
Created attachment 517898 [details]
etc.portage.tbz2
Comment 11 Toralf Förster gentoo-dev 2018-02-05 18:34:26 UTC
Created attachment 517900 [details]
logs.tbz2
Comment 12 Toralf Förster gentoo-dev 2018-02-05 18:34:29 UTC
Created attachment 517902 [details]
media-gfx:graphicsmagick-1.3.28:20180205-021735.log
Comment 13 Toralf Förster gentoo-dev 2018-02-05 18:34:32 UTC
Created attachment 517904 [details]
temp.tbz2
Comment 14 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-04-03 09:03:56 UTC
This doesn't seem related to GCC version.  Closing as dupe of a bug with better explanation.

*** This bug has been marked as a duplicate of bug 641164 ***