Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 598452 - media-libs/smpeg-0.4.4-r10 : /.../huffmantable.cpp:587:1: error: narrowing conversion of ‘-1’ from ‘int’ to ‘unsigned int’ inside { } [-Wnarrowing]
Summary: media-libs/smpeg-0.4.4-r10 : /.../huffmantable.cpp:587:1: error: narrowing co...
Status: RESOLVED DUPLICATE of bug 592450
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-29 15:15 UTC by Toralf Förster
Modified: 2016-11-15 16:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,37.16 KB, text/plain)
2016-10-29 15:15 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,58.86 KB, text/plain)
2016-10-29 15:15 UTC, Toralf Förster
Details
environment (environment,130.06 KB, text/plain)
2016-10-29 15:15 UTC, Toralf Förster
Details
media-libs:smpeg-0.4.4-r10:20161029-142259.log (media-libs:smpeg-0.4.4-r10:20161029-142259.log,21.12 KB, text/plain)
2016-10-29 15:15 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-10-29 15:15:39 UTC
/bin/sh ../libtool  --tag=CXX   --mode=compile x86_64-pc-linux-gnu-g++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"smpeg\" -DVERSION=\"0.4.4\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -I. -I/var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4/audio     -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DTHREADED_AUDIO  -DNDEBUG -I.. -DNOCONTROLS -I/var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4 -I/var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4/audio -I/var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4/video -Werror=terminate -march=native -O2 -pipe -fno-exceptions -fno-rtti -c -o huffmantable.lo /var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4/audio/huffmantable.cpp
libtool: compile:  x86_64-pc-linux-gnu-g++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"smpeg\" -DVERSION=\"0.4.4\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -I. -I/var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4/audio -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -DTHREADED_AUDIO -DNDEBUG -I.. -DNOCONTROLS -I/var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4 -I/var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4/audio -I/var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4/video -Werror=terminate -march=native -O2 -pipe -fno-exceptions -fno-rtti -c /var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4/audio/huffmantable.cpp  -fPIC -DPIC -o .libs/huffmantable.o
/var/tmp/portage/media-libs/smpeg-0.4.4-r10/work/smpeg-0.4.4/audio/huffmantable.cpp:587:1: error: narrowing conversion of ‘-1’ from ‘int’ to ‘unsigned int’ inside { } [-Wnarrowing]
 };
 ^


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-plasma-unstable_20161028-093759) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags ...

  ... in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist ssp avformat dot gnome-keyring infinality introspection jadetex kerberos ldap logrotate lvm mbox -mdnsresponder-compat networking obj -offensive pcre16 png policykit -qt5 -sdl server tcl -thinkpad -tk traceroute wma xcb xetex xscreensaver"

  ... in /etc/portage/package.use/*:
  mail-mta/ssmtp      mta ssl
  net-misc/wget       ssl
  app-editors/xemacs  -nopie
  dev-db/sqlite           secure-delete
  dev-lang/python         sqlite
  dev-qt/qtsql            sqlite
  mail-client/thunderbird -pulseaudio system-icu
  media-libs/libvpx       postproc
  media-libs/libpng       apng
  media-sound/pulseaudio  alsa
  media-video/ffmpeg      sdl
  sys-libs/ntdb           python
  sys-libs/tdb            python
  sys-libs/tevent         python
  x11-libs/cairo          X
  x11-libs/libxcb         xkb
  www-client/firefox      -pulseaudio system-icu
  app-crypt/mit-krb5      -pkinit
  media-video/ffmpeg      -sdl
  sys-devel/llvm          clang
  sys-libs/zlib           minizip
  x11-base/xorg-server    glamor -minimal
  app-crypt/pinentry  -qt4
  app-editors/emacs   -dbus -gtk -gtk3 -ssl -svg
  app-text/xmlto      -latex
  dev-libs/boehm-gc   threads
  dev-libs/libpcre    pcre16
  dev-lang/python     threads
  dev-qt/qtgui        egl eglfs
  dev-util/cmake      -qt4 -qt5
  dev-vcs/git         -gtk -perl
  gnome-base/librsvg  -tools
  media-libs/mesa     -vaapi
  net-nds/openldap    -sasl
  sys-apps/kmod       tools
  sys-libs/ncurses    -gpm
  x11-libs/gtk+       -cups
  net-misc/iputils -caps -filecaps
  >=sys-auth/polkit-qt-0.112.0-r1 qt5

  entries in /etc/portage/package.unmask/*:
  ~sys-apps/sandbox-2.11
  ~dev-libs/botan-1.11.32
  sys-devel/gcc:6.2.0
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.2.0 *
llvm-config --version:
3.9.0
Available Java Virtual Machines:
  (none found)
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
  [3]   pypy (fallback)

java-config:
The following VMs are available for generation-2:
  -----------------------------------------------------------------

Portage 2.3.0 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-6.2.0, glibc-2.23-r2, 4.7.10-hardened-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.7.10-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285608 total,   9006492 free
KiB Swap:   67108860 total,  67106248 free
Timestamp of repository gentoo: Sat, 29 Oct 2016 12:42:08 +0000
sh bash 4.4-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.6.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.2::gentoo
sys-apps/sandbox:         2.11-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.14.1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.26.1::gentoo
sys-devel/gcc:            6.2.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/rancid/.cloginrc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Werror=terminate -march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 avformat berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dot dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gnome-keyring gpm gtk iconv infinality introspection ipv6 jadetex jpeg kde kerberos kipi lcms ldap libnotify logrotate lvm mad mbox mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses networking nls nptl obj ogg opengl openmp pam pango pax_kernel pcre pcre16 pdf phonon plasma png policykit ppds qml qt3support qt4 readline seccomp semantic-desktop server session spell sse sse2 ssl ssp startup-notification svg tcl tcpd tiff traceroute truetype udev udisks unicode upower usb vorbis widgets wma wxwidgets x264 xattr xcb xcomposite xetex xinerama xml xscreensaver xtpax xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="am chr ug" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-10-29 15:15:42 UTC
Created attachment 451872 [details]
config.log
Comment 2 Toralf Förster gentoo-dev 2016-10-29 15:15:45 UTC
Created attachment 451874 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-10-29 15:15:47 UTC
Created attachment 451876 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2016-10-29 15:15:50 UTC
Created attachment 451878 [details]
media-libs:smpeg-0.4.4-r10:20161029-142259.log
Comment 5 Francesco Turco 2016-11-15 16:49:36 UTC
Is this the same as bug 592450?
Comment 6 Toralf Förster gentoo-dev 2016-11-15 16:58:08 UTC
indeed

*** This bug has been marked as a duplicate of bug 592450 ***