Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 595414 - app-text/pdftk-2.02 : make: *** No rule to make target '/var/tmp/portage/app-text/pdftk-2.02/work/pdftk-2.02-dist/pdftk/../java/java_lib.o', needed by 'pdftk.o'. Stop.
Summary: app-text/pdftk-2.02 : make: *** No rule to make target '/var/tmp/portage/app-...
Status: RESOLVED DUPLICATE of bug 562568
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-28 17:05 UTC by Toralf Förster
Modified: 2017-02-20 01:48 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
app-text:pdftk-2.02:20160928-100229.log (app-text:pdftk-2.02:20160928-100229.log,174.69 KB, text/plain)
2016-09-28 17:05 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,301.92 KB, text/plain)
2016-09-28 17:05 UTC, Toralf Förster
Details
environment (environment,76.80 KB, text/plain)
2016-09-28 17:05 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-09-28 17:05:27 UTC
make[1]: [Makefile:52: java_lib.o] Error 127 (ignored)
make[1]: Leaving directory '/var/tmp/portage/app-text/pdftk-2.02/work/pdftk-2.02-dist/java'
make: *** No rule to make target '/var/tmp/portage/app-text/pdftk-2.02/work/pdftk-2.02-dist/pdftk/../java/java_lib.o', needed by 'pdftk.o'.  Stop.
 * ERROR: app-text/pdftk-2.02::gentoo failed (compile phase):
 *   emake failed
 * 


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-plasma-unstable_20160922-223846) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags ...

  ... in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist aes-ni btrfs -cxx dbus ecc -evdev -exif extra gcj gles2 gnomecanvas gnome-keyring -graphtft hdf5 ibus icu imap inifile introspection -ldap lvm mad mod mpeg2 mpi mssql mta mysql ncurses nls openexr pcre16 pkcs11 python qt4 rendering smartcard smime smpeg sslv2 sslv3 system-jpeg tcpd -tk truetype ufed usb usbredir v4l2 vlc vorbis wayland wxwidgets xa -xinetd xmlreader xz"

  ... in /etc/portage/package.use/*:
  mail-mta/ssmtp      ssl mta
  net-misc/wget       ssl
  app-crypt/pinentry  -qt4
  app-editors/emacs   -dbus -svg -ssl -gtk -gtk3
  app-text/xmlto      -latex
  dev-libs/boehm-gc   threads
  dev-libs/libpcre    pcre16
  dev-lang/python     threads
  dev-qt/qtgui        egl eglfs
  net-nds/openldap    -sasl
  dev-util/cmake      -qt4 -qt5
  dev-vcs/git         -perl
  media-libs/mesa     -vaapi
  sys-apps/kmod       tools
  <=net-misc/openssh-7.3_p1-r2    -hpn
  net-misc/iputils -caps -filecaps
  >=app-text/poppler-0.47.0 cxx

  entries in /etc/portage/package.unmask/*:
  media-video/ffmpeg
  sys-devel/gcc:6.2.0
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-4.9.3
 [2] x86_64-pc-linux-gnu-6.2.0 *
llvm-config --version:
3.8.1

Available Python interpreters, in order of preference:
  [1]   python2.7
  [2]   python3.4
  [3]   python3.5 (fallback)
  [4]   pypy3 (fallback)

  -----------------------------------------------------------------

Portage 2.3.1 (python 2.7.12-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-6.2.0, glibc-2.23-r2, 4.7.4-hardened-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.7.4-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285480 total,   1688588 free
KiB Swap:   67108860 total,  67102176 free
Timestamp of repository gentoo: Wed, 28 Sep 2016 06:09:16 +0000
sh bash 4.3_p46-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p46-r1::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.2::gentoo
dev-util/cmake:           3.6.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.26.1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 6.2.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/omega.conf /etc/stunnel/stunnel.conf /usr/share/config /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Werror=terminate -march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes-ni alsa amd64 berkdb bluetooth branding btrfs bzip2 cairo cdda cdr cli consolekit cracklib crypt cups dbus declarative dri dts dvd dvdr ecc emboss encode extra fam firefox flac fortran gcj gdbm gif glamor gles2 gnome-keyring gnomecanvas gpm gtk hdf5 ibus iconv icu imap inifile introspection ipv6 jpeg kde kipi lcms libnotify lvm mad mmx mmxext mng mod modules mp3 mp4 mpeg mpeg2 mpi mssql mta multilib mysql ncurses nls nptl ogg openexr opengl openmp pam pango pax_kernel pcre pcre16 pdf phonon pkcs11 plasma png policykit ppds python qml qt3support qt4 qt5 readline rendering sdl seccomp semantic-desktop session smartcard smime smpeg spell sse sse2 ssl sslv2 sslv3 startup-notification svg system-jpeg tcpd tiff truetype udev udisks ufed unicode upower usb usbredir v4l2 vlc vorbis wayland widgets wxwidgets x264 xa xattr xcb xcomposite xinerama xml xmlreader xscreensaver xtpax xv xvid xz zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="fa gd is" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-09-28 17:05:30 UTC
Created attachment 448316 [details]
app-text:pdftk-2.02:20160928-100229.log
Comment 2 Toralf Förster gentoo-dev 2016-09-28 17:05:32 UTC
Created attachment 448318 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-09-28 17:05:35 UTC
Created attachment 448320 [details]
environment
Comment 4 Jan-Matthias Braun 2017-02-05 14:36:44 UTC
(In reply to Toralf Förster from comment #1)
> Created attachment 448316 [details]
> app-text:pdftk-2.02:20160928-100229.log

From the log:
/bin/sh: gcj: command not found

I would assume that this is an issue with using gcc 6 and therefore a duplicate of https://bugs.gentoo.org/show_bug.cgi?id=562568 .
Comment 5 Andreas K. Hüttel gentoo-dev 2017-02-19 18:35:38 UTC
(In reply to Jan-Matthias Braun from comment #4)
> (In reply to Toralf Förster from comment #1)
> > Created attachment 448316 [details]
> > app-text:pdftk-2.02:20160928-100229.log
> 
> From the log:
> /bin/sh: gcj: command not found
> 
> I would assume that this is an issue with using gcc 6 and therefore a
> duplicate of https://bugs.gentoo.org/show_bug.cgi?id=562568 .

Ack

*** This bug has been marked as a duplicate of bug 562568 ***
Comment 6 Andrew John Hughes 2017-02-20 01:48:14 UTC
Sounds like a dependency issue if pdftk is not depending on a version of gcc with gcj installed.