Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 595346 - dev-perl/Term-ReadLine-Gnu-1.310.0: missing -ltinfo
Summary: dev-perl/Term-ReadLine-Gnu-1.310.0: missing -ltinfo
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tinfo 593674
  Show dependency tree
 
Reported: 2016-09-28 09:06 UTC by Michał Górny
Modified: 2020-04-26 17:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-perl:Term-ReadLine-Gnu-1.310.0:20160928-085925.log (dev-perl:Term-ReadLine-Gnu-1.310.0:20160928-085925.log,5.42 KB, text/x-log)
2016-09-28 09:06 UTC, Michał Górny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2016-09-28 09:06:11 UTC
Created attachment 448198 [details]
dev-perl:Term-ReadLine-Gnu-1.310.0:20160928-085925.log

LD_RUN_PATH="/lib64" x86_64-pc-linux-gnu-gcc-5.4.0  -shared -march=k8-sse3 -mcx16 -msahf --param l1-cache-size=64 --param l1-cache-line-size=64 --param l2-cache-size=512 -O2 -pipe -frecord-gcc-switches -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu Gnu.o -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,-z,defs -Wl,--no-allow-shlib-undefined -o blib/arch/auto/Term/ReadLine/Gnu/Gnu.so 	\
   -lreadline -lncurses  	\
  
/usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: Gnu.o: undefined reference to symbol 'tgetstr'
/lib64/libtinfo.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status



Note: -Wl,-z,defs is necessary to reproduce since it's a shared lib.
Comment 1 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-06-20 08:14:18 UTC
Ping.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2019-07-15 10:16:17 UTC
Please test if this still happens with dev-perl/Term-ReadLine-Gnu-1.360.0 

I cannot reproduce because the build fails in a different way when I add "-Wl,-z,defs" to my LDFLAGS...