Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 595106 - app-forensics/afl fails to build with sys-devel/llvm-3.8.1-r2[default-compiler-rt default-libcxx]: unable to load plugin '../afl-llvm-pass.so': '../afl-llvm-pass.so: undefined symbol
Summary: app-forensics/afl fails to build with sys-devel/llvm-3.8.1-r2[default-compile...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Hanno Böck
URL:
Whiteboard:
Keywords:
: 663420 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-25 14:52 UTC by jo77ah
Modified: 2018-12-06 10:15 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (afl-2.32b:20160925-165255.log,6.82 KB, text/x-log)
2016-09-25 16:56 UTC, Agostino Sarubbo
Details
afl-2.35b.ebuild-force-clang-rtlib-stdlib.patch (file_595106.txt,400 bytes, patch)
2016-11-03 18:56 UTC, Quentin Minster
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jo77ah 2016-09-25 14:52:22 UTC
If sys-devel/llvm-3.8.1-r2 is compiled with USE="default-libcxx default-compiler-rt", afl fails to compile llvm_mode.

I don't have the old build.log around, but i could recompile llvm and reproduce it, if needed.
Comment 1 Agostino Sarubbo gentoo-dev 2016-09-25 16:24:55 UTC
I'm checking.
Comment 2 Agostino Sarubbo gentoo-dev 2016-09-25 16:56:37 UTC
Created attachment 447868 [details]
build log
Comment 3 jo77ah 2016-09-26 15:51:19 UTC
that is the error i got.
Comment 4 Hanno Böck gentoo-dev 2016-09-26 17:41:54 UTC
CCing llvm team, maybe they have an idea.
I'm not familiar with these use flags.
Comment 5 Quentin Minster 2016-11-03 18:56:08 UTC
Created attachment 452282 [details, diff]
afl-2.35b.ebuild-force-clang-rtlib-stdlib.patch
Comment 6 Quentin Minster 2016-11-03 18:57:05 UTC
Same error here. This can be worked around by forcing clang to use the standard stdlib and rtlib, see attached ebuild patch.

But then that makes it deviate from the user's choice to default to compiler-rt and libc++. I'm not sure that qualifies as a proper, tree-worthy fix.
Comment 7 Hanno Böck gentoo-dev 2016-11-05 12:12:12 UTC
I must admit I'm unfamiliar how the different compilers and standard libraries interact. Anyone from the llvm team wants to comment?

If we commit something to support that useflag combination I'd appreciate if I could get confirmation from some Gentoo dev familiar with that stuff that it's a good solution.
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2016-11-05 14:03:02 UTC
The whole issue looks weird. I don't know what AFL is supposed to do but it looks that the pass is missing libraries, and -stdlib/-rtlib exposing it is purely a coincidence.
Comment 9 Hanno Böck gentoo-dev 2018-12-06 10:15:29 UTC
*** Bug 663420 has been marked as a duplicate of this bug. ***