Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 594518 - kde-frameworks/solid-5.23.0 - .../work/solid-5.23.0/src/solid/devices/backends/fstab/fstabhandling.cpp:36:24: fatal error: sys/mnttab.h: No such file or directory
Summary: kde-frameworks/solid-5.23.0 - .../work/solid-5.23.0/src/solid/devices/backend...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2016-09-20 14:20 UTC by anonymous
Modified: 2017-11-12 10:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,549.33 KB, text/plain)
2016-09-20 14:21 UTC, anonymous
PUMP MODE cat `find /tmp/distcc* | grep CheckIn` (file_594518.txt,1.41 KB, text/plain)
2016-09-24 00:16 UTC, anonymous

Note You need to log in before you can comment on or make changes to this bug.
Description anonymous 2016-09-20 14:20:11 UTC
kde-frameworks/solid-5.23.0 fails to build with sys-devel/distcc-3.2_rc1-r4 (distcc-pump mode). Errors below:

/var/tmp/portage/kde-frameworks/solid-5.23.0/work/solid-5.23.0/src/solid/devices/backends/fstab/fstabhandling.cpp:36:24: fatal error: sys/mnttab.h: No such file or directory
compilation terminated.
distcc[11132] ERROR: compile /var/tmp/portage/kde-frameworks/solid-5.23.0/work/solid-5.23.0/src/solid/devices/backends/fstab/fstabhandling.cpp on localhost failed
src/solid/CMakeFiles/KF5Solid.dir/build.make:2102: recipe for target 'src/solid/CMakeFiles/KF5Solid.dir/devices/backends/fstab/fstabhandling.cpp.o' failed
make[2]: *** [src/solid/CMakeFiles/KF5Solid.dir/devices/backends/fstab/fstabhandling.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....

Reproducible: Always

In plain distcc mode all builds fine.

# emerge --info '=kde-frameworks/solid-5.23.0::gentoo'
Portage 2.2.28 (python 2.7.10-final-0, hardened/linux/amd64, gcc-5.3.0, glibc-2.22-r4, 4.4.6-gentoo x86_64)
                         System Settings
System uname: Linux-4.4.6-gentoo-x86_64-AMD_E-300_APU_with_Radeon-tm-_HD_Graphics-with-gentoo-2.2
KiB Mem:     1642804 total,    154232 free
KiB Swap:    2097148 total,   1726256 free
Timestamp of repository gentoo: Sun, 18 Sep 2016 16:07:02 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            5.3.0::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo

    location: /usr/portage
    sync-type: git
    priority: -1000

    location: /var/lib/layman/kde
    sync-type: laymansync
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /var/lib/layman/mooyooma
    sync-type: laymansync
    masters: gentoo
    priority: 50

CFLAGS="-O2 -pipe -march=btver1"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=btver1"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distcc distcc-pump distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j6 -l3"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X acl alsa amd64 berkdb bzip2 cli cracklib crypt cxx dbus dri gdbm glamor gnutls hardened iconv ipv6 justify mmx mmxext modules multilib ncurses networkmanager nls nptl opengl openmp pam pax_kernel pcre pie policykit qt5 readline seccomp semantic-desktop session sse sse2 ssl ssp symlink systemd tcpd unicode urandom vdpau xattr xtpax zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="ru ru_RU en uk uk_UA" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru ru_RU en uk uk_UA" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 anonymous 2016-09-20 14:21:24 UTC
Created attachment 446914 [details]
Comment 2 Michael Palimaka (kensington) gentoo-dev 2016-09-21 15:39:08 UTC
Does mnttab.h exist on any of the involved hosts?
Comment 3 anonymous 2016-09-22 11:48:30 UTC
(In reply to Michael Palimaka (kensington) from comment #2)
> Does mnttab.h exist on any of the involved hosts?

No, mnttab.h doesn't exist on any of my host.
Comment 4 Michael Palimaka (kensington) gentoo-dev 2016-09-22 12:02:58 UTC
@cluster, any ideas?

There's a few of these bugs floating around, in each case failing with distcc-pump in a similar way. In this case, sys/mnttab.h is somehow found during configure, cause build to fail later as the file actually does not exist.
Comment 5 anonymous 2016-09-24 00:14:29 UTC
Well, I made some research.
It's about cmake and include_server(1) from distcc.

Every time when CMake check include file (via macro "check_include_files") it generate new .c file with the same name. For example, "/var/tmp/portage/kde-frameworks/kpty-5.23.0/work/kpty-5.23.0_build/CMakeFiles/CMakeTmp/CheckIncludeFiles.c"

After that this file compile again and again. And if we use distcc, then this file can be sended to remote host and remote host try to compile it.

When we use plain distcc - then all fine, this file sending every time with new content each time.

When we use pump mode... caching? I don't know, but look this:

First of all I have added to ebuild lines:

>src_configure() {
>        local mycmakeargs=(
>                '--debug-trycompile'
>        )
>        kde5_src_configure

Now CMake don't delete temporary files and I can explore them.

Next I add to distccd environment variable DISTCC_SAVE_TEMPS=1, and restart distccd. So, distccd keep all temporary files too.

Okay, on master I run:

> ebuild /usr/portage/kde-frameworks/kpty/kpty-5.23.0.ebuild digest clean configure

On slave I run:

cat `find /tmp/distcc* | grep CheckIn`

Look output in attached file: all files are identical! So, all compilation result OK, and CMake think that header is found.
Comment 6 anonymous 2016-09-24 00:16:15 UTC
Created attachment 447668 [details]
PUMP MODE cat `find /tmp/distcc* | grep CheckIn`
Comment 7 anonymous 2016-09-24 00:24:24 UTC
So, look, please, to "man 1 include_server" about changed source files during compilation. I don't know proper workaround for Gentoo :(
Comment 8 anonymous 2016-09-24 00:27:17 UTC
(In reply to Chaser from comment #5)
> When we use plain distcc - then all fine, this file sending every time with
> new content each time.
Sorry, then this file preprocessing locally every time, and only object-files sending to remote host.