Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 593990 - dev-python/ipython-5.1.0: missing dependency on dev-python/pathlib
Summary: dev-python/ipython-5.1.0: missing dependency on dev-python/pathlib
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
: 594402 (view as bug list)
Depends on:
Blocks: 596714
  Show dependency tree
 
Reported: 2016-09-16 16:36 UTC by Tim Jones
Modified: 2017-02-13 13:57 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Jones 2016-09-16 16:36:40 UTC
In dev-python/ipython-5.1.0, trying to run ipython2 gave the standard import error for a missing module, "pathlib2". Just emerging virtual/python-pathlib-1.0 which pulled in stable dev-python/pathlib-1.0.1-r1 did the trick. Nothing in ipython-5.1.0.ebuild about pathlib. The python3 version worked fine.

I got to this issue because the matplotlib-1.5.3 ebuild was trying to build its docs for the python2 target and complained that ipython was not installed.

Reproducible: Always

Steps to Reproduce:
1. don't install dev-python/pathlib
2. try to run ipython2

Actual Results:  
import error for pathlib2
Comment 1 Marek Szuba gentoo-dev 2016-09-22 06:42:33 UTC
*** Bug 594402 has been marked as a duplicate of this bug. ***
Comment 2 Marius Brehler 2017-01-16 21:51:23 UTC
Thanks Tim for the report. pathlib is imported in IPython/utils/text.py [1]. Will add it soon to the deps (currently very little time).



[1] https://github.com/ipython/ipython/blob/master/IPython/utils/text.py#L17
Comment 3 Marius Brehler 2017-02-03 12:37:24 UTC
https://github.com/gentoo/gentoo/pull/3789
Comment 4 Marius Brehler 2017-02-13 13:57:35 UTC
commit 2c1adcdbb08568901808d09bee7cd85277839792
Author: Marius Brehler <marbre@linux.sungazer.de>
Date:   Mon Feb 6 08:18:55 2017 +0100

    dev-python/ipython: Add dependecy on pathlib
    
    Gentoo-Bug: https://bugs.gentoo.org/604372
    
    Package-Manager: portage-2.3.3
    Closes: https://github.com/gentoo/gentoo/pull/3789