Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 593350 - dev-perl/Gtk2-Ex-PrintDialog-0.30.0-r1 : * ERROR: dev-perl/Gtk2-Ex-PrintDialog-0.30.0-r1::gentoo failed (configure phase):
Summary: dev-perl/Gtk2-Ex-PrintDialog-0.30.0-r1 : * ERROR: dev-perl/Gtk2-Ex-PrintDial...
Status: RESOLVED DUPLICATE of bug 592880
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-09-10 07:31 UTC by Toralf Förster
Modified: 2016-09-10 07:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-perl:Gtk2-Ex-PrintDialog-0.30.0-r1:20160910-002942.log (dev-perl:Gtk2-Ex-PrintDialog-0.30.0-r1:20160910-002942.log,2.17 KB, text/plain)
2016-09-10 07:31 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,92.49 KB, text/plain)
2016-09-10 07:31 UTC, Toralf Förster
Details
environment (environment,101.34 KB, text/plain)
2016-09-10 07:31 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-09-10 07:31:46 UTC
Please install these modules first and rerun 'perl Makefile.PL'.
 * ERROR: dev-perl/Gtk2-Ex-PrintDialog-0.30.0-r1::gentoo failed (configure phase):
 *   Unable to build!
 * 
 * Call stack:


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-plasma-systemd-unstable_20160907-222201) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------
  USE flags ...

  ... in make.conf:
USE="  pax_kernel xtpax -cdinstall -oci8 -bindist apache apache2 avformat bugzilla consolekit contrib curl custom-cflags custom-optimization declarative dnssec dot -emacs extraengine fontconfig fpm git gles2 gnomecanvas icu javaxml jpeg lapack libinput libvirtd llvm lvm minimal mpi mta mysqli nss openexr openssl -postproc -pwquality qt3support scripts sourceview spice ssl sslv2 sslv3 system-cairo system-ffmpeg system-libs system-libvpx tcl tcpd timidity tk usb v4l vaapi -webstart xa -xml xslt ziffy"

  ... in /etc/portage/package.use/*:
  mail-mta/ssmtp      ssl mta
  net-misc/wget       ssl
  app-editors/emacs   -dbus -svg -ssl -gtk -gtk3
  app-text/xmlto      -latex
  dev-libs/boehm-gc   threads
  dev-libs/libpcre    pcre16
  dev-util/cmake      -qt4 -qt5
  dev-vcs/git         -perl
  gnome-base/librsvg  -tools
  media-libs/mesa     -vaapi
  <=net-misc/openssh-7.3_p1-r2    -hpn
  >=dev-lang/python-2.7.12:2.7 xml
  >=dev-lang/python-3.4.5:3.4 xml
  dev-qt/qtgui egl

  entries in /etc/portage/package.unmask/*:
  media-video/ffmpeg
  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-4.9.3
 [2] x86_64-pc-linux-gnu-5.4.0 *
Available Java Virtual Machines:
  [1]   icedtea-bin-7 
  [2]   icedtea-bin-8  system-vm
Available Python interpreters, in order of preference:
  [1]   python2.7
  [2]   python3.4
  [3]   pypy3 (fallback)
Available Ruby profiles:
  [1]   ruby20 (with Rubygems) *
  [2]   ruby21 (with Rubygems)
  -----------------------------------------------------------------

Portage 2.2.28 (python 2.7.12-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-5.4.0, glibc-2.23-r2, 4.7.3-hardened x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.7.3-hardened-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.3
KiB Mem:    65285352 total,   1308696 free
KiB Swap:   67108860 total,  67108860 free
Timestamp of repository gentoo: Fri, 09 Sep 2016 22:06:11 +0000
sh bash 4.3_p46
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p46::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.6.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.21.7::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.13.4-r1::gentoo, 1.14.1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 apache apache2 avformat berkdb bluetooth branding bugzilla bzip2 cairo cdda cdr cli contrib cracklib crypt cups curl custom-cflags custom-optimization cxx dbus declarative dnssec dot dri dts dvd dvdr emboss encode exif extraengine fam firefox flac fontconfig fortran fpm gdbm gif git glamor gles2 gnomecanvas gpm gtk iconv icu ipv6 javaxml jpeg kde kipi lapack lcms ldap libinput libnotify libvirtd llvm lvm mad minimal mmx mmxext mng modules mp3 mp4 mpeg mpi mta multilib mysqli ncurses nls nptl nss ogg openexr opengl openmp openssl pam pango pax_kernel pcre pdf phonon plasma png policykit ppds qml qt3support qt4 qt5 readline scripts sdl seccomp semantic-desktop session sourceview spell spice sse sse2 ssl sslv2 sslv3 startup-notification svg system-cairo system-ffmpeg system-libs system-libvpx systemd tcl tcpd tiff timidity tk truetype udev udisks unicode upower usb v4l vaapi vorbis widgets wxwidgets x264 xa xattr xcb xcomposite xinerama xscreensaver xslt xtpax xv xvid ziffy zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" L10N="bo es-AR gu ko pt-PT sid sr-Latn zu" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-09-10 07:31:48 UTC
Created attachment 445364 [details]
dev-perl:Gtk2-Ex-PrintDialog-0.30.0-r1:20160910-002942.log
Comment 2 Toralf Förster gentoo-dev 2016-09-10 07:31:51 UTC
Created attachment 445366 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-09-10 07:31:54 UTC
Created attachment 445368 [details]
environment
Comment 4 Kent Fredric (IRC: kent\n) gentoo-dev 2016-09-10 07:40:53 UTC
Another case of Locale-gettext not being pulled into the dependency cycle by portage not being too bright.

*** This bug has been marked as a duplicate of bug 592880 ***