Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 593024 - app-emulation/qemu-2.7.0[static-user] sizeof(size_t) doesn't match GLIB_SIZEOF_SIZE_T
Summary: app-emulation/qemu-2.7.0[static-user] sizeof(size_t) doesn't match GLIB_SIZEO...
Status: RESOLVED DUPLICATE of bug 588952
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo QEMU Project
Depends on:
Reported: 2016-09-07 07:39 UTC by Jasen Borisov
Modified: 2016-11-15 04:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,10.73 KB, text/x-log)
2016-09-07 07:39 UTC, Jasen Borisov
emerge --info output (emergeinfo,21.02 KB, text/plain)
2016-09-07 07:41 UTC, Jasen Borisov

Note You need to log in before you can comment on or make changes to this bug.
Description Jasen Borisov 2016-09-07 07:39:52 UTC
Created attachment 445126 [details]

Tried to install qemu 2.7 on my system and got a build failure at configure stage, with this message (full build.log attached):

ERROR: sizeof(size_t) doesn't match GLIB_SIZEOF_SIZE_T.
       You probably need to set PKG_CONFIG_LIBDIR
       to point to the right pkg-config files for your
       build target
Comment 1 Jasen Borisov 2016-09-07 07:41:36 UTC
Created attachment 445128 [details]
emerge --info output
Comment 2 Mike Gilbert gentoo-dev 2016-09-07 16:06:53 UTC
Possible duplicate of bug 591202.
Comment 3 Matthias Maier gentoo-dev 2016-09-07 17:23:58 UTC
Can you please rebuild libpcre with static-libs use flag as discussed on bug #591202 and try again?
Comment 4 Jasen Borisov 2016-09-07 17:43:38 UTC
It worked. Thank you.

Unlike the other bug report, I am not cross-compiling, and already had qemu 2.6 on my system, which worked fine. libpcre[static-libs] must be a new requirement with 2.7.
Comment 5 Matthias Maier gentoo-dev 2016-09-09 05:24:46 UTC
Fixed in 2.7.0-r1

commit b28fcd11405545eb2e4973f96823337531eebb08
Author: Matthias Maier <>
Date:   Fri Sep 9 00:10:05 2016 -0500

    app-emulation/qemu: fix static-user dep, security patches, bug #593038
    This commit resolves
      bug #591202
      bug #593024
      bug #593034 CVE-2016-7155
      bug #593036 CVE-2016-7156
      bug #593038 CVE-2016-7157
    Package-Manager: portage-2.2.28
Comment 6 SpanKY gentoo-dev 2016-11-15 04:56:21 UTC
this isn't a bug in qemu.  i'll revert the libpcre dep.

*** This bug has been marked as a duplicate of bug 588952 ***