Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 592456 - media-libs/opusfile fails to build with >=dev-libs/openssl-1.1.0
Summary: media-libs/opusfile fails to build with >=dev-libs/openssl-1.1.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Markos Chandras (RETIRED)
URL: https://git.xiph.org/?p=opusfile.git;...
Whiteboard:
Keywords:
Depends on:
Blocks: openssl-1.1
  Show dependency tree
 
Reported: 2016-08-30 16:58 UTC by Lars Wendler (Polynomial-C)
Modified: 2018-06-13 16:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,15.91 KB, text/plain)
2016-08-30 16:58 UTC, Lars Wendler (Polynomial-C)
Details
0001-Use-ASN1_STRING_get0_data-for-openssl-1.1.0.patch (0001-Use-ASN1_STRING_get0_data-for-openssl-1.1.0.patch,2.90 KB, patch)
2017-01-02 18:59 UTC, eroen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2016-08-30 16:58:32 UTC
Created attachment 444470 [details]
build.log

See attached build.log
Comment 1 eroen 2017-01-02 18:59:27 UTC
Created attachment 458398 [details, diff]
0001-Use-ASN1_STRING_get0_data-for-openssl-1.1.0.patch

I submitted a patch for this to upstream's mailing list, but apparently it takes a while before it shows up in the list archive.

I have attached a version of the patch backported to opusfile-0.8.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2018-06-13 16:28:19 UTC
Seems to be fixed meanwhile.