Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 589180 - media-video/subtitleeditor-0.52.1 will not build
Summary: media-video/subtitleeditor-0.52.1 will not build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gilles Dartiguelongue
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2016-07-19 20:02 UTC by deference
Modified: 2016-10-16 22:24 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build-subtitleeditor-0.52.1.txt,179.89 KB, text/plain)
2016-07-19 20:02 UTC, deference
Details
emerge --info (emergeinfo-subtitleeditor-0.52.1.txt,28.03 KB, text/plain)
2016-07-19 20:03 UTC, deference
Details
emerge --info (successful build) (emerge--info.log,5.98 KB, text/plain)
2016-07-20 13:03 UTC, Jonas Stein
Details
subtitleeditor-0.52.1-fix-include-order.patch (subtitleeditor-0.52.1-fix-include-order.patch,1.35 KB, patch)
2016-09-21 16:21 UTC, Peter Levine
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description deference 2016-07-19 20:02:54 UTC
Created attachment 441150 [details]
build.log

[ebuild     U ] media-video/subtitleeditor-0.52.1 [0.41.1-r1] USE="-debug -nls (-opengl%*)"

In file included from utility.h:34:0,
                 from subtitle.cc:25:
/usr/include/libintl.h: At global scope:

/usr/include/libintl.h:39:14: error: expected unqualified-id before 'const'
 extern char *gettext (const char *__msgid)
              ^
/usr/include/libintl.h:39:14: error: expected ')' before 'const'
/usr/include/libintl.h:39:14: error: expected initializer before 'const'
/usr/include/libintl.h:44:14: error: expected unqualified-id before 'const'
 extern char *dgettext (const char *__domainname, const char *__msgid)
              ^
/usr/include/libintl.h:44:14: error: expected ')' before 'const'
/usr/include/libintl.h:44:14: error: expected initializer before 'const'
/usr/include/libintl.h:51:14: error: expected unqualified-id before 'const'
 extern char *dcgettext (const char *__domainname,
              ^
/usr/include/libintl.h:51:14: error: expected ')' before 'const'
/usr/include/libintl.h:51:14: error: expected initializer before 'const'
/usr/include/libintl.h:61:14: error: expected unqualified-id before 'unsigned'
 extern char *ngettext (const char *__msgid1, const char *__msgid2,
              ^
/usr/include/libintl.h:61:14: error: expected ')' before 'unsigned'

/usr/include/libintl.h:61:14: error: expected ')' before 'unsigned'
/usr/include/libintl.h:61:14: error: expected ')' before 'unsigned'
/usr/include/libintl.h:61:14: error: expected initializer before 'unsigned'
/usr/include/libintl.h:82:14: error: expected unqualified-id before 'const'
 extern char *textdomain (const char *__domainname) __THROW;
              ^
/usr/include/libintl.h:82:14: error: expected ')' before 'const'
/usr/include/libintl.h:82:14: error: expected initializer before 'const'
/usr/include/libintl.h:86:14: error: expected unqualified-id before 'const'
 extern char *bindtextdomain (const char *__domainname,
              ^
/usr/include/libintl.h:86:14: error: expected ')' before 'const'
/usr/include/libintl.h:86:14: error: expected initializer before 'const'
/usr/include/libintl.h:91:14: error: expected unqualified-id before 'const'
 extern char *bind_textdomain_codeset (const char *__domainname,
              ^
/usr/include/libintl.h:91:14: error: expected ')' before 'const'
/usr/include/libintl.h:91:14: error: expected initializer before 'const'
Comment 1 deference 2016-07-19 20:03:22 UTC
Created attachment 441152 [details]
emerge --info
Comment 2 Jonas Stein gentoo-dev 2016-07-20 13:01:48 UTC
I could compile and install
media-video/subtitleeditor-0.52.1
here.
But I got plenty of broken type errors like uint <-> int. This will lead to strange bugs in the program.
Someone, who uses the program, should report them upstream.



btw: Thank you for all your reports. You can improve your subject lines next time, by adding the CATEGORY to the package name:
media-video/subtitleeditor instead of subtitleeditor

https://wiki.gentoo.org/wiki/Project:Bug-wranglers#Assessing_bug_reports
Comment 3 Jonas Stein gentoo-dev 2016-07-20 13:03:45 UTC
Created attachment 441210 [details]
emerge --info (successful build)
Comment 4 Pacho Ramos gentoo-dev 2016-07-30 19:53:31 UTC
I can neither reproduce the build issue
Comment 5 deference 2016-07-31 17:59:32 UTC
I just re-emerged glibc and virtual/libintl. Then I tried to install subtitleeditor. It failed again. Same errors. Is it possible to install dev-libs/libintl instead of glibc. Is that the case in your install?
I will try to find what differences cause the problem. I would ask that you keep tsubtitleeditor-0.41.1-r1 in portage until this problem gets fixed or worked around.
As you have the full build log could you either submit it here so that I can submit it upstream or do so yourself with my build log.
Thanks
Comment 6 Gilles Dartiguelongue gentoo-dev 2016-08-16 12:30:24 UTC
If you run glibc, there is no reason to have libintl installed. You should probably try to remove it and see if subtitleeditor builds.
Comment 7 deference 2016-09-12 05:25:23 UTC
virtual/libintl is needed by several packages.
I broken my system and then tried to install subtitleeditor again. It still fails.
Comment 8 Pacho Ramos gentoo-dev 2016-09-17 12:44:08 UTC
Please also retry with 0.53.0
Comment 9 Peter Levine 2016-09-18 05:21:12 UTC
The problem only occurs on my end with USE="-nls".

Not sure if this is a gcc-6 problem.  I'm able to reproduce this issue with a custom sys-devel/gcc-5.4.0-rc20160527.
Comment 10 Peter Levine 2016-09-21 16:21:49 UTC
Created attachment 447050 [details, diff]
subtitleeditor-0.52.1-fix-include-order.patch

Bug and patch submitted upstream:

https://gna.org/support/index.php?3373
Comment 11 Peter Levine 2016-09-26 19:41:08 UTC
(In reply to Peter Levine from comment #10)
> Created attachment 447050 [details, diff] [details, diff]
> subtitleeditor-0.52.1-fix-include-order.patch
> 
> Bug and patch submitted upstream:
> 
> https://gna.org/support/index.php?3373

Accepted upstream.
Comment 12 deference 2016-10-05 15:53:37 UTC
Foolish me. All this time I did not notice that you used nls. I assumed that you tried to build with the same USE flags I did. Changing to +nls solved the issue. 
Thanks
Comment 13 Maurice van der Pot 2016-10-16 14:49:02 UTC
Still an issue with 0.53.0, but the patch works. Could you please add it to the ebuild?
Comment 14 Gilles Dartiguelongue gentoo-dev 2016-10-16 22:24:16 UTC
After digging a bit because I could not understand how your patch fixed the problem, I came around https://github.com/minetest/minetest/issues/4446. I have now included this in tree in 0.53.0 https://cgit.gentoo.org/repo/gentoo.git/commit/. Thanks for reporting.