Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 589028 - games-puzzle/tetrinet-0.11 - No client connection works.
Summary: games-puzzle/tetrinet-0.11 - No client connection works.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Games
Depends on:
Reported: 2016-07-17 19:23 UTC by Christian Fladung
Modified: 2016-07-18 05:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Christian Fladung 2016-07-17 19:23:19 UTC
The port is open, when i run tetrinet-server. A .tetrinet file is made in the directory where i started the daemon.
Then i connect via gtetrinet client, or an original TetriNET for windows, via wine...
There, the partyline only shows: "*** Server has shutdown!"...
The tetrinet console client shows that:
$ tetrinet -fast -log tetrinet1.log flash
Server closed connection

Also the gtetrinet client and the wine emulated TETRINET.EXE are very unstable.
They are crashing, when i tried to connect via: IP:PORT and USERNAME in client settings.

When i give only the IP. The client is showing: *** Server has shutdown...
Linux mode 1 and 0 tried.
$ cat .tetrinet
classic 1
initiallevel 1
linesperlevel 2
levelinc 1
averagelevels 1
speciallines 1
specialcount 1
specialcapacity 18
pieces 14 14 15 14 14 14 15
specials 18 18 3 12 0 16 3 12 18
linuxmode 1
ipv6_only 0

The console client shows this in the log: I can't do F1, (blocks) F2, (partyline) and F3 ... only F10 for QUIT is working. And writing messages.
Go command doesn't work there.. I don't know if I'm really connected (locally).

$ cat tetrinet1.log
[1468779478.124] >>> 00459B25AF28AA2BA7389B257DD20E5AF56FBEDA3153B7
[1468779478.124] <<< playernum 1
[1468779478.124] >>> team 1
[1468779478.124] <<< winlist
[1468779480.193] >>> pline 1 go
[1468779484.273] >>> pline 1 [[A
[1468779487.134] >>> pline 1 /go

The main problem is, that the gtetrinet client doesn't connect well to the 'tetrinet-server' daemon. There it opens a window where it stands: "Connecting to Server." There is a blue progress bar, which is stopping in the middle. 50%.. And then the application hangs.

Comment 1 Christian Fladung 2016-07-17 19:52:04 UTC
Now i get this with the console client when i write: /start and /end.
*** The Game Has Started
*** The Game Has Ended
*** The Game Has Started

I don't have the right console support. But the bug report here stays.
Because of gtetrinet doesn't connect. It is *NOT* showing these partyline messages for the started game...
Comment 2 Christian Fladung 2016-07-17 20:46:00 UTC
I can login on localhost via console client.
But from VPN it is not working!
This is via VPN client station:

./tetrinet -fancy -log tetrinet1.log flash
Couldn't connect to server Success

./tetrinet -fancy -log tetrinet1.log flash
Server closed connection
Comment 3 Christian Fladung 2016-07-17 20:56:55 UTC
I've tested it on another server with direct Internet Connection.
Without the traversal through the VPN...
That is working in gtetrinet!
But via openvpn i can't connect to!
Comment 4 Christian Fladung 2016-07-18 05:50:56 UTC
On debian: apt-get install tetrinet-server
and starting the server via: tetrinet-server & does work!

On Gentoo, the tetrinet-server, ... I have made the INPUT policy for iptables = ACCEPT .. the port is open, tcp... also i opened SYN.. and then, udp, too..

When i start gtetrinet in the console it says on connect:

** (gtetrinet:22056): WARNING **: End of file (server closed connection).

** (gtetrinet:22056): WARNING **: client_readmsg failed, aborting connection

** (gtetrinet:22056): WARNING **: End of file (server closed connection).

** (gtetrinet:22056): WARNING **: client_readmsg failed, aborting connection

On the debian server i can play...