Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 586356 - net-analyzer/snips-1.2-r2 : etherload.c:(.text+0x18d): undefined reference to `flush_device'
Summary: net-analyzer/snips-1.2-r2 : etherload.c:(.text+0x18d): undefined reference to...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords: PMASKED
: 574338 585582 (view as bug list)
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2016-06-19 09:16 UTC by Toralf Förster
Modified: 2017-01-30 08:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,226.57 KB, text/plain)
2016-06-19 09:17 UTC, Toralf Förster
Details
net-analyzer:snips-1.2-r2:20160619-082234.log (net-analyzer:snips-1.2-r2:20160619-082234.log,73.99 KB, text/plain)
2016-06-19 09:17 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-06-19 09:16:57 UTC
x86_64-pc-linux-gnu-gcc -o etherload -march=native -O2 -pipe -fPIC -DSNIPS  -DRRDTOOL  -I/var/tmp/portage/net-analyzer/snips-1.2-r2/work/snips-1.2/include bpf.o etherload.o dlpi.o main.o nit.o pfilt.o snoop.o linux.o util.o snips_specific.o get_devlist.o -L/var/tmp/portage/net-analyzer/snips-1.2-r2/work/snips-1.2/lib  -lsnips -L/usr/lib/ -lrrd
etherload.o: In function `etherload':
etherload.c:(.text+0x18d): undefined reference to `flush_device'


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-13.0-no-multilib-unstable_20160616-094217) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="pax_kernel xtpax -cdinstall -oci8 -bindist alsa avcodec cgi consolekit dec_av2 drmkms emacs ffmpeg ftp -gcj gd gif gtk2 imlib introspection logrotate mdnsresponder-compat -minizip modplug -mpeg mssql -multitarget networking nss ois -openexr pcre16 php png printsupport -pyqt4 python smartcard snmp -sockets sql sqlite -system-cairo system-icu system-sqlite threads tools tracepath -vdpau vpx X xml xmp zenmap"

  -----------------------------------------------------------------

Portage 2.3.0_rc1 (python 3.4.4-final-0, default/linux/amd64/13.0/no-multilib, gcc-5.4.0, glibc-2.23-r2, 4.5.7-hardened-r2 x86_64)
=================================================================
System uname: Linux-4.5.7-hardened-r2-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16157888 total,   1739876 free
KiB Swap:   16777212 total,  16483856 free
Timestamp of repository gentoo: Sun, 19 Jun 2016 06:42:09 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
ccache version 3.2.5 [disabled]
app-shells/bash:          4.3_p42-r2::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.4::gentoo, 3.5.1-r3::gentoo
dev-util/ccache:          3.2.5::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.21::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl alsa amd64 avcodec berkdb bzip2 cgi cli consolekit cracklib crypt cxx dec_av2 dri drmkms emacs ffmpeg fortran ftp gd gdbm gif gtk2 iconv imlib introspection ipv6 logrotate mdnsresponder-compat mmx mmxext modplug modules mssql ncurses networking nls nptl nss ois openmp pam pax_kernel pcre pcre16 php png printsupport python readline seccomp session smartcard snmp sql sqlite sse sse2 ssl system-icu system-sqlite tcpd threads tools tracepath unicode vpx xattr xml xmp xtpax zenmap zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-06-19 09:17:03 UTC
Created attachment 438010 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-06-19 09:17:06 UTC
Created attachment 438012 [details]
net-analyzer:snips-1.2-r2:20160619-082234.log
Comment 3 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2016-06-19 15:51:35 UTC
I just did a ebuild install with the following use flags and it workedforme...

USE="X acl alsa amd64 avcodec berkdb bzip2 cgi cli consolekit cracklib crypt cxx dec_av2 dri drmkms emacs ffmpeg fortran ftp gd gdbm gif gtk2 iconv imlib introspection ipv6 logrotate mdnsresponder-compat mmx mmxext modplug modules mssql ncurses networking nls nptl nss ois openmp pam pax_kernel pcre pcre16 php png printsupport python readline seccomp session smartcard snmp sql sqlite sse sse2 ssl system-icu system-sqlite tcpd threads tools tracepath unicode vpx xattr xml xmp xtpax zenmap zlib"
Comment 4 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2016-06-19 15:53:18 UTC
uh, this doesn't seem to be related to net-misc/memcached, but net-analyzer/snips.  @toralf can you confirm?
Comment 5 Toralf Förster gentoo-dev 2016-06-19 16:21:43 UTC
(In reply to Matthew Thode ( prometheanfire ) from comment #4)
indeed - I have to look if I messed up my bugz script - sry
Comment 6 Toralf Förster gentoo-dev 2016-06-19 19:14:56 UTC
pfffrrrr :

1. the package failed in the compile step but eventually errored too late in pkg_postinst(), or ? - see bug #586404 too
2. that uncovered a bug in my script to catch the failed package name
3. therefore the wrong title and missing log files for the package
Comment 7 Toralf Förster gentoo-dev 2016-06-19 19:22:32 UTC
*** Bug 574338 has been marked as a duplicate of this bug. ***
Comment 8 Toralf Förster gentoo-dev 2016-12-06 07:59:30 UTC
*** Bug 585582 has been marked as a duplicate of this bug. ***
Comment 9 David Seifert gentoo-dev 2016-12-20 21:16:10 UTC
snips is broken beyond repair. Removal in 30 days.

commit a25b3b409c5eaf616823ace003f4cd5072449940
Author: David Seifert <soap@gentoo.org>
Date:   Tue Dec 20 22:13:05 2016 +0100

    profiles: Mask net-analyzer/snips for removal
    
    Gentoo-bug: 586356
Comment 10 David Seifert gentoo-dev 2017-01-30 08:29:34 UTC
Removed from tree.

commit 9b5612b068f12a94455e7dc1055e9b976d6880e5
Author: David Seifert <soap@gentoo.org>
Date:   Mon Jan 30 09:24:04 2017 +0100

    net-analyzer/snips: Remove from tree