Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 586330 - www-servers/varnish: invalid use of := in || () dep
Summary: www-servers/varnish: invalid use of := in || () dep
Status: IN_PROGRESS
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Anthony Basile
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 586238
  Show dependency tree
 
Reported: 2016-06-18 19:40 UTC by Michał Górny
Modified: 2018-07-23 08:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2016-06-18 19:40:34 UTC
|| ( dev-libs/libedit sys-libs/readline:= )

:= inside || is forbidden and broken. Also automagic switching between two libs is a bad idea.
Comment 1 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2016-06-21 19:21:18 UTC
commit d46a4711f181e81394f409f035c3b54b03f88038
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: Tue Jun 21 21:19:38 2016
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: Tue Jun 21 21:20:31 2016

    www-servers/varnish: Remove invalid := slotop from || (), #586330


I've just removed the op to fix the immediate issue. However, you still need to fix the automagic dep.
Comment 2 Anthony Basile gentoo-dev 2016-07-10 18:06:58 UTC
I don't see a point to depending on either readline or libedit.  I've just dropped this to sys-libs/readline:0= for the latest ebuild I added.  Once 3.0.7 and 4.0.3 are off the tree, we should be rid of all the automagic.