Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 585876 - net-analyzer/snips: chown: cannot access '/usr/snips/bin/etherload': No such file or directory
Summary: net-analyzer/snips: chown: cannot access '/usr/snips/bin/etherload': No such ...
Status: RESOLVED DUPLICATE of bug 549552
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2016-06-13 22:53 UTC by Toralf Förster
Modified: 2016-06-19 19:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,329.46 KB, text/plain)
2016-06-13 22:53 UTC, Toralf Förster
Details
net-analyzer:snips-1.2-r2:20160613-224726.log (net-analyzer:snips-1.2-r2:20160613-224726.log,74.03 KB, text/plain)
2016-06-13 22:53 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-06-13 22:53:31 UTC
x86_64-pc-linux-gnu-gcc -o etherload -march=native -O2 -pipe -fPIC -DSNIPS  -DRRDTOOL  -I/var/tmp/portage/net-analyzer/snips-1.2-r2/work/snips-1.2/include bpf.o etherload.o dlpi.o main.o nit.o pfilt.o snoop.o linux.o util.o snips_specific.o get_devlist.o -L/var/tmp/portage/net-analyzer/snips-1.2-r2/work/snips-1.2/lib  -lsnips -L/usr/lib/ -lrrd
etherload.o: In function `etherload':
etherload.c:(.text+0x18d): undefined reference to `flush_device'


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-gnome-unstable_20160608-203042) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="sse2 pax_kernel xtpax -cdinstall -oci8 -bindist aes-ni alisp avformat cddb consolekit curl custom-cflags dbus dnssec extra fortran fpm -freetds gd gles2 graphtft gtkstyle -gui hdf5 icu -inifile ithreads javascript jpeg llvm mad midi modplug mp4 mta nls nscd -obj openssl pcre16 pkcs11 qml rdoc scrypt source sql ssse3 system-cairo -system-ffmpeg system-harfbuzz system-icu system-libs ufed v4l vdpau x265 xetex xslt zip"

  -----------------------------------------------------------------

Portage 2.3.0_rc1 (python 3.4.4-final-0, default/linux/amd64/13.0/desktop/gnome, gcc-5.3.0, glibc-2.23-r2, 4.5.7-hardened-r1 x86_64)
=================================================================
System uname: Linux-4.5.7-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16157888 total,   2026440 free
KiB Swap:   16777212 total,  16159428 free
Timestamp of repository gentoo: Mon, 13 Jun 2016 22:02:03 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
ccache version 3.2.5 [disabled]
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.4::gentoo, 3.5.1-r3::gentoo
dev-util/ccache:          3.2.5::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.21::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.3.0::gentoo, 5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/tomoyo/conf /usr/share/config /usr/share/maven-bin-3.3/conf /usr/share/qpsmtpd/plugins /var/lib/hsqldb /var/lib/otrs/Kernel/Config.pm /var/lib/otrs/Kernel/Config/GenericAgent.pm"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes-ni alisp alsa amd64 avformat berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli colord consolekit cracklib crypt cups curl custom-cflags cxx dbus dnssec dri dts dvd dvdr eds emboss encode evo exif extra fam firefox flac fortran fpm gd gdbm gif glamor gles2 gnome gnome-keyring gnome-online-accounts gpm graphtft gstreamer gtk gtkstyle hdf5 iconv icu introspection ipv6 ithreads javascript jpeg lcms ldap libnotify libsecret llvm mad midi mmx mmxext mng modplug modules mp3 mp4 mpeg mta multilib nautilus ncurses nls nptl nscd ogg opengl openmp openssl pam pango pax_kernel pcre pcre16 pdf pkcs11 png policykit ppds pulseaudio qml qt3support qt4 rdoc readline scrypt sdl seccomp session source spell sql sse sse2 ssl ssse3 startup-notification svg system-cairo system-harfbuzz system-icu system-libs tcpd tiff tracker truetype udev udisks ufed unicode upower usb v4l vdpau vorbis wxwidgets x264 x265 xattr xcb xetex xml xslt xtpax xv xvid zip zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-06-13 22:53:38 UTC
Created attachment 437454 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-06-13 22:53:40 UTC
Created attachment 437456 [details]
net-analyzer:snips-1.2-r2:20160613-224726.log
Comment 3 Sławek Lis (RETIRED) gentoo-dev 2016-06-14 04:12:08 UTC
I'm not a maintainer of net-analyzer/snips.
Can you please verify your report and eighter provide error log for django-classy-tags or assign snips's maintainer?

Thanks!
Comment 4 Toralf Förster gentoo-dev 2016-06-19 19:22:00 UTC

*** This bug has been marked as a duplicate of bug 549552 ***