Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 585094 - dev-lang/perl: 17983 Segmentation fault /usr/bin/makeinfo --no-split /var/.../gpm-1.20.7-abi_x86_64.amd64/doc/gpm.texinfo -o /var/.../gpm-1.20.7-abi_x86_64.amd64/doc/gpm.info
Summary: dev-lang/perl: 17983 Segmentation fault /usr/bin/makeinfo --no-split /va...
Status: RESOLVED DUPLICATE of bug 585048
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
: 585020 585198 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-05 10:39 UTC by Toralf Förster
Modified: 2016-06-06 19:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,11.15 KB, text/plain)
2016-06-05 10:39 UTC, Toralf Förster
Details
environment (environment,119.39 KB, text/plain)
2016-06-05 10:39 UTC, Toralf Förster
Details
sys-libs:gpm-1.20.7-r2:20160605-103615.log (sys-libs:gpm-1.20.7-r2:20160605-103615.log,64.97 KB, text/plain)
2016-06-05 10:39 UTC, Toralf Förster
Details
emerge.log (emerge.log,130.08 KB, text/x-log)
2016-06-05 15:30 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-06-05 10:39:00 UTC
chmod 400 /var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_64.amd64/doc/gpm.texinfo
if [ "/usr/bin/makeinfo" != "no" ]; then /usr/bin/makeinfo --no-split /var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_64.amd64/doc/gpm.texinfo -o /var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_64.amd64/doc/gpm.info; fi
/bin/sh: line 1: 17983 Segmentation fault      /usr/bin/makeinfo --no-split /var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_64.amd64/doc/gpm.texinfo -o /var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_64.amd64/doc/gpm.info
make[1]: *** [Makefile:53: /var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_64.amd64/doc/gpm.info] Error 139
rm /var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_64.amd64/doc/gpm.texinfo
make[1]: Leaving directory '/var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_64.amd64/doc'


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-plasma-unstable_20160605-104609) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="sse2 pax_kernel xtpax -cdinstall -oci8 -bindist -alisp alsa avcodec avformat -avx -bzip2 cdda -corefonts custom-cflags -dot emacs gzip ipv6 isag javaxml logrotate lzma -mdnsresponder-compat melt mpeg mssql mta mysqli networking objc opencv php pyqt4 python qt3support -qt4 qt5 sddm sockets -spice ssh ssh-askpass system-cairo system-harfbuzz system-libevent tcpd uxa wav -x264 xinerama"

  -----------------------------------------------------------------

Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-4.9.3, glibc-2.23-r2, 4.5.5-hardened-r2 x86_64)
=================================================================
System uname: Linux-4.5.5-hardened-r2-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16157888 total,   1314016 free
KiB Swap:   16777212 total,  16733508 free
Timestamp of repository gentoo: Sun, 05 Jun 2016 10:11:32 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r2::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.69-r2::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.2-r2::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 avcodec avformat berkdb bluetooth branding cairo cdda cdr cli consolekit cracklib crypt cups custom-cflags cxx dbus declarative dri dts dvd dvdr emacs emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk gzip iconv ipv6 isag javaxml jpeg kde kipi lcms ldap libnotify logrotate lzma mad melt mmx mmxext mng modules mp3 mp4 mpeg mssql mta multilib mysqli ncurses networking nls nptl objc ogg opencv opengl openmp pam pango pax_kernel pcre pdf phonon php plasma png policykit ppds pyqt4 python qml qt3support qt5 readline sddm sdl seccomp semantic-desktop session sockets spell sse sse2 ssh ssh-askpass ssl startup-notification svg system-cairo system-harfbuzz system-libevent tcpd tiff truetype udev udisks unicode upower usb uxa vorbis wav widgets wxwidgets xattr xcb xcomposite xinerama xml xscreensaver xtpax xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-06-05 10:39:02 UTC
Created attachment 436534 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-06-05 10:39:05 UTC
Created attachment 436536 [details]
environment
Comment 3 Toralf Förster gentoo-dev 2016-06-05 10:39:07 UTC
Created attachment 436538 [details]
sys-libs:gpm-1.20.7-r2:20160605-103615.log
Comment 4 Toralf Förster gentoo-dev 2016-06-05 10:51:56 UTC
it failed at 3 different plasma images whereas in other profiles it emerged fine (in the past) :
tinderbox@ms-magpie ~ $ for i in amd64-*; do echo $i; qlop -u -l -H -g -f $i/var/log/emerge.log sys-libs/gpm; done
amd64-13.0-no-multilib-unstable_20160602-150050
Sun Jun  5 09:57:59 2016 >>> sys-libs/gpm-1.20.7-r2
gpm: Sun Jun  5 09:57:28 2016: 31 seconds
gpm: 1 times
amd64-13.0-unstable_20160604-200858
amd64-desktop-unstable_20160602-152726
Thu Jun  2 15:46:13 2016 >>> sys-libs/gpm-1.20.7-r2
Thu Jun  2 16:14:46 2016 <<< sys-libs/gpm-1.20.7-r2
Thu Jun  2 16:14:51 2016 >>> sys-libs/gpm-1.20.7-r2
gpm: Thu Jun  2 15:45:46 2016: 27 seconds
gpm: Thu Jun  2 16:14:22 2016: 29 seconds
gpm: 2 times
amd64-gnome-unstable_20160604-185706
Sat Jun  4 19:16:55 2016 >>> sys-libs/gpm-1.20.7-r2
Sat Jun  4 19:48:29 2016 <<< sys-libs/gpm-1.20.7-r2
Sat Jun  4 19:48:30 2016 >>> sys-libs/gpm-1.20.7-r2
gpm: Sat Jun  4 19:16:25 2016: 30 seconds
gpm: Sat Jun  4 19:48:03 2016: 27 seconds
gpm: 2 times
amd64-hardened-no-multilib-stable_20160602-160217
Fri Jun  3 09:53:32 2016 >>> sys-libs/gpm-1.20.7-r2
gpm: Fri Jun  3 09:53:01 2016: 31 seconds
gpm: 1 times
Comment 5 Toralf Förster gentoo-dev 2016-06-05 15:08:51 UTC
At the same image it is now possible to update gpm, b/c texinfo was upgraded too (likely changed USE flags):

Sun Jun  5 12:36:04 2016 >>> app-shells/bash-4.3_p42-r2
Sun Jun  5 12:36:16 2016 >>> x11-proto/inputproto-2.3.2
Sun Jun  5 12:39:02 2016 <<< sys-apps/texinfo-6.1
Sun Jun  5 12:39:03 2016 >>> sys-apps/texinfo-6.1
Sun Jun  5 12:42:51 2016 >>> net-misc/dibbler-1.0.1
Sun Jun  5 12:44:22 2016 >>> dev-python/pbr-1.10.0
Sun Jun  5 12:44:31 2016 >>> dev-python/six-1.10.0
Sun Jun  5 12:44:41 2016 >>> dev-python/pyasn1-0.1.9
Sun Jun  5 12:44:51 2016 >>> dev-python/appdirs-1.4.0
Sun Jun  5 12:44:59 2016 >>> dev-python/requestsexceptions-1.1.3
Sun Jun  5 12:45:08 2016 >>> dev-python/pyyaml-3.11
Sun Jun  5 12:45:17 2016 >>> dev-python/positional-1.0.1
Sun Jun  5 12:45:27 2016 >>> dev-python/stevedore-1.12.0
Sun Jun  5 12:45:35 2016 >>> dev-python/iso8601-0.1.11
Sun Jun  5 12:45:47 2016 >>> dev-python/chardet-2.3.0
Sun Jun  5 12:45:58 2016 >>> dev-python/py-1.4.31
Sun Jun  5 12:46:05 2016 >>> dev-python/PySocks-1.5.6
Sun Jun  5 12:46:13 2016 >>> dev-python/backports-1.0
Sun Jun  5 12:46:22 2016 >>> dev-python/backports-ssl-match-hostname-3.5.0.1-r1
Sun Jun  5 12:46:32 2016 >>> dev-python/idna-2.1
Sun Jun  5 12:46:40 2016 >>> dev-python/enum34-1.1.3
Sun Jun  5 12:46:51 2016 >>> dev-python/ply-3.8
Sun Jun  5 12:47:01 2016 >>> dev-python/pycparser-2.14
Sun Jun  5 12:47:16 2016 >>> dev-python/cffi-1.6.0
Sun Jun  5 12:47:24 2016 >>> dev-python/ipaddress-1.0.16
Sun Jun  5 12:47:29 2016 >>> virtual/python-ipaddress-1.0
Sun Jun  5 12:48:32 2016 >>> dev-python/cryptography-1.3.4
Sun Jun  5 12:48:41 2016 >>> dev-python/pyopenssl-16.0.0
Sun Jun  5 12:48:51 2016 >>> dev-python/ndg-httpsclient-0.4.0
Sun Jun  5 12:49:01 2016 >>> dev-python/urllib3-1.14
Sun Jun  5 12:49:09 2016 >>> dev-python/requests-2.9.1-r2
Sun Jun  5 12:49:20 2016 >>> dev-python/keystoneauth-2.4.1
Sun Jun  5 12:49:29 2016 >>> dev-python/os-client-config-1.16.0
Sun Jun  5 16:56:20 2016 >>> sys-apps/mlocate-0.26-r1
Sun Jun  5 17:03:14 2016 >>> sys-libs/gpm-1.20.7-r2
Sun Jun  5 17:03:35 2016 <<< sys-libs/gpm-1.20.7-r2
Sun Jun  5 17:04:42 2016 >>> sys-libs/gpm-1.20.7-r2



So let gpm build-depend on texinfo, right ?
Comment 6 Toralf Förster gentoo-dev 2016-06-05 15:30:36 UTC
Created attachment 436564 [details]
emerge.log

the whole emerge log
Comment 7 SpanKY gentoo-dev 2016-06-06 18:01:33 UTC
*** Bug 585198 has been marked as a duplicate of this bug. ***
Comment 8 SpanKY gentoo-dev 2016-06-06 18:04:30 UTC
gpm should include a generated info page itself.  we're working this out upstream.

that said, makeinfo is simply a perl script, and perl shouldn't segfault.  afaict, a revdep rebuild shouldn't matter as texinfo only installs perl modules (pm files) and no compiled code.
Comment 9 SpanKY gentoo-dev 2016-06-06 18:59:10 UTC
(In reply to SpanKY from comment #8)

i've worked around the gpm/info dep in the mean time:
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2cbf041b6cf2fea23d2a706521ee35b948201174
Comment 10 Andreas K. Hüttel gentoo-dev 2016-06-06 19:04:54 UTC
> that said, makeinfo is simply a perl script, and perl shouldn't segfault. 
> afaict, a revdep rebuild shouldn't matter as texinfo only installs perl
> modules (pm files) and no compiled code.

Sure about that?

huettel@pinacolada ~ $ equery -C files texinfo|grep so
/usr/lib/debug/usr/lib64/texinfo/XSParagraph.so.debug
/usr/lib64/texinfo/XSParagraph.so

... and the script refers to XS code, so ...

* The paths are all off btw, texinfo might need some perl-ification.

* Things do segfault if loading old libperl into new perl, so this can be related to bug 585048
Comment 11 SpanKY gentoo-dev 2016-06-06 19:19:56 UTC
(In reply to Andreas K. Hüttel from comment #10)

ah, i was looking at texinfo-6.0, and it does not install any .so files.  looks like that is new to texinfo-6.1, and i'm guessing Toralf is running that version too.

if texinfo needs any perl/eclass changes/love, feel free to make them.  you're certainly more knowledgeable of perl stuff and i'm likely to just bugger it.

i agree this looks like a dupe more or less.  portage's package scheduling might have been off since gpm lacked a DEPEND on texinfo, but that's a moot point now in light of comment #9.

*** This bug has been marked as a duplicate of bug 585048 ***
Comment 12 Toralf Förster gentoo-dev 2016-06-06 19:22:35 UTC
*** Bug 585020 has been marked as a duplicate of this bug. ***