Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 585078 - www-client/chromium-53.0.2756.0 failed to build - GzipStringRsyncable failure
Summary: www-client/chromium-53.0.2756.0 failed to build - GzipStringRsyncable failure
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Chromium Project
: 589714 (view as bug list)
Depends on: 587592
  Show dependency tree
Reported: 2016-06-05 09:14 UTC by Andrew Waters
Modified: 2016-11-19 02:10 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Compressed build log (build.log.gz,179.22 KB, application/gzip)
2016-06-05 15:49 UTC, Andrew Waters
Build log for failed chromium-53.0.2756.0 (build.log.gz,178.70 KB, application/gzip)
2016-06-10 21:40 UTC, Nick
Build log for failed chromium-53.0.2763.0 (build.log.2763.gz,177.92 KB, application/gzip)
2016-06-15 22:11 UTC, Nick
Build log for failed chromium-53.0.2767.4 (build.log.bz2,104.97 KB, application/x-bzip2)
2016-06-24 05:51 UTC, Andrew Waters
Build log for failed chromium-53.0.2774.3 (build.log.bz2,104.13 KB, application/x-bzip2)
2016-06-28 05:36 UTC, Andrew Waters

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Waters 2016-06-05 09:14:38 UTC
[4190/19338] cd ../../mojo; python ../mojo/public/tools/bindings/ --use_bundled_pylibs generate public/interfaces/bindings/interface_control_messages.mojom public/interfaces/bindings/pipe_control_messages.mojom -d .. -I.. -I../mojo/services -I.. -o ../out/Release/gen "--java_output_directory=../out/Release/java_mojo/mojo_interface_bindings_mojom/src" --variant none -g c++,javascript,java --typemap ../out/Release/gen/mojo/mojo_interface_bindings_mojom_type_mappings --bytecode_path ../out/Release/gen/mojo/public/tools/bindings
[4191/19338] cd ../../content/app/strings; python ../../../tools/grit/ -i content_strings.grd build -f ../../../tools/gritsettings/resource_ids -o ../../../out/Release/gen/content/app/strings "--write-only-new=1" -D _chromium -E "CHROMIUM_BUILD=chromium" -D desktop_linux -D toolkit_views -D use_aura -D use_nss_certs -D enable_extensions -D enable_plugins -D enable_printing -D enable_print_preview -D enable_themes -D use_concatenated_impulse_responses -D enable_media_router -D enable_webrtc -D enable_hangout_services_extension -D enable_task_manager -D enable_notifications -D enable_service_discovery
FAILED: cd ../../content; python ../tools/grit/ -i content_resources.grd build -f ../tools/gritsettings/resource_ids -o ../out/Release/gen/content "--write-only-new=1" -D _chromium -E "CHROMIUM_BUILD=chromium" -D desktop_linux -D toolkit_views -D use_aura -D use_nss_certs -D enable_extensions -D enable_plugins -D enable_printing -D enable_print_preview -D enable_themes -D use_concatenated_impulse_responses -D enable_media_router -D enable_webrtc -D enable_hangout_services_extension -D enable_task_manager -D enable_notifications -D enable_service_discovery -E "root_out_dir=../out/Release"
Error processing node <?xml version="1.0" encoding="UTF-8"?>
<include allowexternalscript="true" compress="gzip" file="browser/resources/appcache/appcache_internals.html" flattenhtml="true" name="IDR_APPCACHE_INTERNALS_HTML" type="BINDATA" />
Traceback (most recent call last):
  File "../tools/grit/", line 15, in <module>
  File "/var/tmp/portage/www-client/chromium-53.0.2756.0/work/chromium-53.0.2756.0/tools/grit/grit/", line 268, in Main
    toolobject.Run(options, args[1:])
  File "/var/tmp/portage/www-client/chromium-53.0.2756.0/work/chromium-53.0.2756.0/tools/grit/grit/tool/", line 230, in Run
  File "/var/tmp/portage/www-client/chromium-53.0.2756.0/work/chromium-53.0.2756.0/tools/grit/grit/tool/", line 360, in Process
    self.ProcessNode(self.res, output, outfile)
  File "/var/tmp/portage/www-client/chromium-53.0.2756.0/work/chromium-53.0.2756.0/tools/grit/grit/tool/", line 297, in ProcessNode
    formatted = formatter(node, output_node.GetLanguage(), output_dir=base_dir)
  File "/var/tmp/portage/www-client/chromium-53.0.2756.0/work/chromium-53.0.2756.0/tools/grit/grit/format/", line 45, in Format
    id, value = node.GetDataPackPair(lang, UTF8)
  File "/var/tmp/portage/www-client/chromium-53.0.2756.0/work/chromium-53.0.2756.0/tools/grit/grit/node/", line 102, in GetDataPackPair
    data = grit.format.gzip_string.GzipStringRsyncable(data)
  File "/var/tmp/portage/www-client/chromium-53.0.2756.0/work/chromium-53.0.2756.0/tools/grit/grit/format/", line 26, in GzipStringRsyncable
subprocess.CalledProcessError: Command 'gzip' returned non-zero exit status 1
ninja: build stopped: subcommand failed.
Comment 1 Andrew Waters 2016-06-05 09:17:23 UTC
This looks like failure
Comment 2 Andrew Waters 2016-06-05 09:18:00 UTC
# emerge --info
Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.22-r4, 4.6.1-gentoo x86_64)
System uname: Linux-4.6.1-gentoo-x86_64-Intel-R-_Core-TM-_i7-3720QM_CPU_@_2.60GHz-with-gentoo-2.2
KiB Mem:    16314316 total,   9662568 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of repository gentoo: Sun, 05 Jun 2016 08:15:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
ccache version 3.2.4 [disabled]
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt /usr/share/maven-bin-2.2/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi aes alsa amd64 apache2 avx berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr encode evo exif fam ffmpeg filecaps firefox flac gdbm gif gimp glamor glut gnutls gpm gstreamer gtk iconv icu idn imagemagick ios ipod ipv6 java jpeg jpeg2k lcms ldap libnotify mad mmap mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl nsplugin ogg opengl openmp opus pam pango pcre pdf png policykit popcnt posix postscript ppds qt4 quicktime raw rdesktop readline samba sasl sdl seccomp session smp spell sqlite sse sse2 sse3 sse4 sse4_1 sse4_2 ssl ssse3 startup-notification subversion svg tcpd theora threads tiff truetype udev udisks unicode upower usb vim-syntax vorbis wavpack win32codecs wmf wxwidgets x264 x265 xattr xcb xcomposite xine xml xpm xscreensaver xv xvid zeroconf zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="nouveau intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 3 Tomáš Mózes 2016-06-05 09:54:30 UTC
Please attach the full build log.
Comment 4 Andrew Waters 2016-06-05 10:20:26 UTC
I have tried adding an attachment but I get a site can't be reached error when I press submit.
Comment 5 Andrew Waters 2016-06-05 15:49:01 UTC
Created attachment 436566 [details]
Compressed build log
Comment 6 Nick 2016-06-10 21:40:52 UTC
Created attachment 437094 [details]
Build log for failed chromium-53.0.2756.0

The chromium-53.0.2756.0 build fails for me as well.
Comment 7 Nick 2016-06-15 22:11:52 UTC
Created attachment 437686 [details]
Build log for failed chromium-53.0.2763.0

The same error also occurs for chromium-53.0.2763.0
Comment 8 Andrew Waters 2016-06-24 05:51:12 UTC
Created attachment 438608 [details]
Build log for failed chromium-53.0.2767.4
Comment 9 Andrew Waters 2016-06-28 05:36:39 UTC
Created attachment 439030 [details]
Build log for failed chromium-53.0.2774.3
Comment 10 Andrew Waters 2016-06-30 12:13:45 UTC
Having done some investigation on the failure of chromium-53.0.2774.3 the issue now appears to be not having a late enough version of gzip.

The build is trying to use the gzip --rsyncable flag. The flag does not exist until app-arch/gzip-1.7. The stable version is currently 1.6. So this ebuild has a dependency on gzip-1.7.

I updated to the latest gzip-1.8 and the build completed.
Comment 11 Mike Gilbert gentoo-dev 2016-06-30 14:32:53 UTC
(In reply to Andrew Waters from comment #10)

Nice, thanks for the research!
Comment 12 Mike Gilbert gentoo-dev 2016-06-30 14:47:12 UTC
commit 9090f33d41214acc0bfc2da4b7c9bbcd815c7d99
Author: Mike Gilbert <>
Date:   Thu Jun 30 10:46:03 2016 -0400

    www-client/chromium: depend on >=app-arch/gzip-1.7

    The build process calls gzip --rsyncable, which was added in gzip-1.7.
    Thanks to Andrew Waters for the research.

    Package-Manager: portage-2.3.0_p7

 www-client/chromium/chromium-53.0.2774.3.ebuild | 1 +
 1 file changed, 1 insertion(+)
Comment 13 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2016-08-20 12:02:39 UTC
*** Bug 589714 has been marked as a duplicate of this bug. ***