kde-apps/khelpcenter-16.04.1:5/5 and kde-base/baloo-4.14.3:4/4.14 use different versions of dev-libs/xapian and causes a conflict between them
Total: 2 packages (1 downgrade, 1 reinstall), Size of downloads: 0 KiB
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
(dev-libs/xapian-1.2.23:0/1.2.22::gentoo, ebuild scheduled for merge) pulled in by
=dev-libs/xapian-1.2*[chert] required by (kde-base/baloo-4.14.3:4/4.14::gentoo, ebuild scheduled for merge)
(dev-libs/xapian-1.3.6:0/1.3.7::gentoo, installed) pulled in by
dev-libs/xapian:0/1.3.7= required by (kde-apps/khelpcenter-16.04.1:5/5::gentoo, installed)
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
$ grep xapian /usr/portage/kde-apps/khelpcenter/*
Only your *installed* version of khelpcenter-16.04.1 uses xapian-1.3.6, it does not require a specific one. Building baloo:4 requires indeed =xapian-1.2* so if you downgrade that, khelpcenter needs a rebuild at the same time against the lower xapian version.
*** Bug 583688 has been marked as a duplicate of this bug. ***