Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 58353 - Americas Army 210 Will not start.
Summary: Americas Army 210 Will not start.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Games
Depends on:
Reported: 2004-07-25 21:04 UTC by KryNx
Modified: 2004-12-27 19:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description KryNx 2004-07-25 21:04:48 UTC
When I try to start americas army, it gives the following message:
"/usr/games/bin/armyops: Line 49 : /opt/americas-army/System/armyops-bin: No such file or directory
/usr/games/bin/armyops: Line 49 : /opt/americas-army/System/armyops-bin: Success
" .. I have tried reinstalling it a couple of times with the same result, and I checked the script.. its trying to execute /opt/americas-army/System/armyops-bin, but there is no such file in said location - it has installed in the correct place, everything else is there, but no armyops-bin.

Reproducible: Always
Steps to Reproduce:
I simply installed it normally, then ran "armyops"
Actual Results:  
It gives the error mentioned above.

ash-2.05b$ emerge info
Portage 2.0.50-r9 (default-amd64-2004.0, gcc-3.3.3, glibc-,
System uname: 2.6.7-gentoo-r11 x86_64 4
Gentoo Base System version 1.4.16
distcc 2.13 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/conf$
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
FEATURES="autoaddcvs ccache"
USE="X alsa amd64 apm arts avi berkdb cdr crypt dvd dvdr encode fluxbox
foomaticdb gdbm gif gpm gtk gtk2 imlib jpeg libg++ libwww mikmod motif mpeg
mplayer ncurses nls nogcj oggvorbis opengl oss pam pdflib perl png python qt
quicktime readline sdl slang spell ssl tcltk tcpd truetype xml2 xmms xv zlib
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2004-07-25 21:40:05 UTC
Got enough room in /opt to install?
Comment 2 KryNx 2004-07-26 00:14:55 UTC
Yup, Ive got about 30gb free on that drive.. It doesnt give any install errors or anything, its just when I try to run it that I have a problem.
Comment 3 KryNx 2004-07-26 19:17:30 UTC
I have also tried installing AA onto my 32bit AthlonXP Box, and copying the armyops-bin file over, then trying to run it again, but it gives the exact same message.
Comment 4 Chris Gianelloni (RETIRED) gentoo-dev 2004-07-27 04:38:38 UTC
What is the output of "mount"?

Also, America's Army is does NOT have a KEYWORD for amd64 for a reason (it doesn't work).


$ locate armyops-bin

That is with the ebuild done *after* you posted this bug.  I'm going to see what I can do to help you, but really I should just mark this as INVALID, since you have made modifications to the ebuild to install it, or worked around the KEYWORDS put in place by the package maintainer (me).
Comment 5 KryNx 2004-07-27 18:16:49 UTC
Er, I havent made any changes to the ebuild, though - I just did an emerge -s americas-army to see if it was masked or not (As I had only just installed gentoo on my athlon64 box, and had seen that almost all games were masked, and as it wasnt, I simply did an emerge americas-army.. no modifications whatsoever.
Comment 6 KryNx 2004-07-27 20:07:31 UTC
Sorry about not posting this before, but I only just got home.

bash-2.05b$ mount
/dev/hda3 on / type reiserfs (rw,noatime)
none on /dev type devfs (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw)
none on /dev/shm type tmpfs (rw)
none on /proc/bus/usb type usbfs (rw)

Also, I just took a look at the ebuild, and.. :

KEYWORDS="x86 amd64"
        opengl? ( virtual/opengl )
        amd64? ( app-emulation/emul-linux-x86-xlibs )"

(And as I said before, I havent modified the ebuild in any way)
Comment 7 Chris Gianelloni (RETIRED) gentoo-dev 2004-07-28 04:51:51 UTC
GRRR.... Somebody marked it stable on amd64, when it definitely is NOT.

This package does not work on amd64.


$ locate armyops-bin

And that *is* installing on amd64... so I don't know why your ebuild is not installing it.

I'm going to reassign this to augustus, since he's the one that deemed this package stable on amd64.
Comment 8 Chris Gianelloni (RETIRED) gentoo-dev 2004-09-27 21:06:35 UTC
Forgot to leave us on the CC... if I don't hear from Augustus soon, I'm just going to remove the KEYWORD from America's Army.
Comment 9 Chris Gianelloni (RETIRED) gentoo-dev 2004-10-15 17:06:29 UTC
Sorry... this is not the same thing...

Anyway, have you tried this again recently?  I just tried it again on my machine and it is working perfectly.  If you're still having this problem, REOPEN this bug.
Comment 10 Mr. Bones. (RETIRED) gentoo-dev 2004-12-27 19:21:28 UTC
no movement for two months. closing.