Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 58145 - new reiser4 partition fails to mount
Summary: new reiser4 partition fails to mount
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: SpanKY
Depends on:
Reported: 2004-07-24 00:34 UTC by genbug
Modified: 2004-07-24 15:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description genbug 2004-07-24 00:34:57 UTC
I created a new partition with parted which is not r4 aware so I let it default to ext2. I did mkfs reiserfs within parted.

Reboot to see partition . mkfs.reiser4 works but the partition fails to mount.

I am running 2.6.6-love which has been reliable with r4 since I installed it 4 months ago. No other issues.

I have done this repeatedly on two partitions , the result is consistant.

fsck shows the fs to be OK but still no mount.

bash-2.05b# mkfs.reiser4 /dev/hdc15
mkfs.reiser4 0.5.6
Copyright (C) 2001, 2002, 2003, 2004 by Hans Reiser, licensing governed by 

Block size 4096 will be used.                                                 
Linux 2.6.6-love4 is detected.                                                
Uuid 36884688-ee35-4873-917d-c732f9a2dc53 will be used.                       
Reiser4 is going to be created on /dev/hdc15.                                 
(Yes/No): Yes
Creating reiser4 on /dev/hdc15 ... done                                       
bash-2.05b# mount -t reiser4 !$ /tmp/x
mount -t reiser4 /dev/hdc15 /tmp/x
mount: wrong fs type, bad option, bad superblock on /dev/hdc15,
       or too many mounted file systems

Reproducible: Always
Steps to Reproduce:

[ebuild   R   ] sys-fs/reiser4progs-0.5.6 

I have all of portage on an r4 partition that was created around the time 2.6.6-
love4 was released end of May 2004. I had no such problems at that time.
Comment 1 Stefan Schweizer (RETIRED) gentoo-dev 2004-07-24 01:16:09 UTC
If you use the latest reiser4progs you cannot mount the partition with the old snapshot in your kernel, take a newer snapshot. Either from one of the later loves or from
Comment 2 Bryan Østergaard (RETIRED) gentoo-dev 2004-07-24 06:59:47 UTC
reiser4 and love-sources is not supported by Gentoo and I don't believe reiser4progs should be in portage either - at the very least it should be hardmasked.

Vapier, any ideas what to do with reiser4progs?
Comment 3 SpanKY gentoo-dev 2004-07-24 09:29:03 UTC
love sources == not Gentoo's problem

reiser4 == supported by Gentoo only so much as we add/update the packages ... after that, it's up to you to make it work; file bugs upstream, not with us
Comment 4 genbug 2004-07-24 13:58:58 UTC
Many thanks Stephan. At least I understand what is happening now.

I tried to revert to reiser4progs 0.5.4 but this will no longer compile. This may be due my having changed to gcc 3.4 in the meantime.

I should have stayed with what worked . This constant updating is often a cause of more problems to sort out.

As for taking R4 out of Gentoo portage, that does not seem very helpful. That would effectivly be taking out reiser4 . One of the best things about Gentoo is that we have portage to install and test new features like R4 , which I have been using heavily for several months without problems.

I came across an issue and thought it would be helpful to file a bug.

Stephan's reply has enabled me to search for a solution and to post the answer on the forums for others to find.

Are there any "supported" kernels sets that run reliably with r4 ?

Comment 5 SpanKY gentoo-dev 2004-07-24 15:27:53 UTC
no, like i mentioned earlier, Gentoo is not going to support reiser4 ... if it shows up in a kernel that's in portage, we might touch it then

as for the packages, we'll add them and version bump them but that's about it ... file bugs upstream with the reiser maintainers