Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 581122 - mail-client/thunderbird-bin-45.0 not honoring locale
Summary: mail-client/thunderbird-bin-45.0 not honoring locale
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-25 08:02 UTC by Uwe Sauter
Modified: 2017-08-26 17:57 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Sauter 2016-04-25 08:02:14 UTC
Updated thunderbird-bin to version 45.0 a few days ago. Since then the GUI is presented in English although my locale is set to de_DE.utf8 and USE flags included linguas_de. The additionally installed Lightning plugin is shown in German.

The previously installed version 38.7.0 showed correct language on the GUI.


$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

$ equery u thunderbird-bin
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for mail-client/thunderbird-bin-45.0:
 U I
 + + crashreporter : Enable crash reporter for bugs
 - - linguas_ar    : Arabic locale
 - - linguas_ast   : Asturian locale
 - - linguas_be    : Belarusian locale
 - - linguas_bg    : Bulgarian locale
 - - linguas_bn_BD : Bengali locale for Bangladesh
 - - linguas_br    : Breton locale
 - - linguas_ca    : Catalan locale
 - - linguas_cs    : Czech locale
 - - linguas_cy    : Welsh locale
 - - linguas_da    : Danish locale
 + + linguas_de    : German locale
 - - linguas_el    : Greek locale
 + + linguas_en_GB : English locale for Britain
 - - linguas_es_AR : Spanish locale for Argentina
 - - linguas_es_ES : Spanish locale for Spain
 - - linguas_et    : Estonian locale
 - - linguas_eu    : Basque locale
 - - linguas_fi    : Finnish locale
 - - linguas_fr    : French locale
 - - linguas_fy_NL : Frisian language locale for the Netherlands
 - - linguas_ga_IE : Irish locale for Ireland
 - - linguas_gd    : Gaelic locale
 - - linguas_gl    : Galician locale
 - - linguas_he    : Hebrew locale
 - - linguas_hr    : Croatian locale
 - - linguas_hsb   : Upper Sorbian locale
 - - linguas_hu    : Hungarian locale
 - - linguas_hy_AM : Armenian locale
 - - linguas_id    : Indonesian locale
 - - linguas_is    : Icelandic locale
 - - linguas_it    : Italian locale
 - - linguas_ja    : Japanese locale
 - - linguas_ko    : Korean locale
 - - linguas_lt    : Lithuanian locale
 - - linguas_nb_NO : Norwegian (Bokmal) locale for Norway
 - - linguas_nl    : Dutch locale
 - - linguas_nn_NO : Nynorsk locale for Norway
 - - linguas_pa_IN : Punjabi locale for India
 - - linguas_pl    : Polish locale
 - - linguas_pt_BR : Portuguese locale for Brasil
 - - linguas_pt_PT : Portuguese locale for Portugal
 - - linguas_rm    : Romansh locale
 - - linguas_ro    : Romanian locale
 - - linguas_ru    : Russian locale
 - - linguas_si    : Sinhala locale
 - - linguas_sk    : Slovak locale
 - - linguas_sl    : Slovenian locale
 - - linguas_sq    : Albanian locale
 - - linguas_sr    : Serbian locale
 - - linguas_sv_SE : Swedish locale for Sweden
 - - linguas_ta_LK : Tamil locale for Sri Lanka
 - - linguas_tr    : Turkish locale
 - - linguas_uk    : Ukrainian locale
 - - linguas_vi    : Vietnamese locale
 - - linguas_zh_CN : Chinese locale for Peoples Republic of China
 - - linguas_zh_TW : Chinese locale for Taiwan

What other information is needed to debug this?
Comment 1 Franz Trischberger 2016-04-26 05:56:34 UTC
Same issue here.
The langpack is installed:

[...]
/opt/thunderbird/distribution/bundles/langpack-de@thunderbird.mozilla.org/chrome/de/locale/de/messenger/mailViewList.dtd
[and so on]

As a workaround I manually installed the langpack through the addon manager.
Comment 2 Alex Xu (Hello71) 2016-04-27 14:50:26 UTC
for already existing profiles, don't you need to manually select the language?
Comment 3 Ian Stakenvicius gentoo-dev 2016-04-27 15:06:00 UTC
Unfortunately we have no control over thunderbird-bin, due to it being built by upstream.  It is very possible that the shimming-in of the extra langpacks into /opt/thunderbird/ is no longer supported by the upstream builds and they now expect you to install and manage all extra langpacks through the addon manager.

I'll check it out and see if there's anything I can do from here -- with any luck there might be a pref() that I can force-on, or a path adjustment I can make, to allow use of the system langpacks.
Comment 4 charles17 2016-05-02 13:21:44 UTC
(In reply to Alex Xu (Hello71) from comment #2)
> for already existing profiles, don't you need to manually select the
> language?

Have you tried the locale-switcher?
https://addons.mozilla.org/en-US/thunderbird/addon/simple-locale-switcher/
Comment 5 Uwe Sauter 2016-07-14 21:20:48 UTC
I installed Simple Locale Switcher but cannot find the menu where I could choose the language.
But it somehow unlocked the "languages" section on the add-ons page and there I was able to download the German language pack. After a restart of Thunderbird, all menus, etc.seem to be displayed correctly in German.
Comment 6 Franz Trischberger 2016-07-17 07:19:28 UTC
(In reply to Uwe Sauter from comment #5)
> I installed Simple Locale Switcher but cannot find the menu where I could
> choose the language.
> But it somehow unlocked the "languages" section on the add-ons page and
> there I was able to download the German language pack. After a restart of
> Thunderbird, all menus, etc.seem to be displayed correctly in German.

Of course that fixes the issue but not this bug as it should really work without having to download the langpack manually (e.g. through the addon manager).
Could someone revert the status to CONFIRMED so we can track this bug until there is a proper fix? Thx!
Comment 7 Uwe Sauter 2016-07-17 08:39:01 UTC
(In reply to Franz Fellner from comment #6)
> (In reply to Uwe Sauter from comment #5)
> > I installed Simple Locale Switcher but cannot find the menu where I could
> > choose the language.
> > But it somehow unlocked the "languages" section on the add-ons page and
> > there I was able to download the German language pack. After a restart of
> > Thunderbird, all menus, etc.seem to be displayed correctly in German.
> 
> Of course that fixes the issue but not this bug as it should really work
> without having to download the langpack manually (e.g. through the addon
> manager).
> Could someone revert the status to CONFIRMED so we can track this bug until
> there is a proper fix? Thx!

As this wasn't CONFIRMED yet I only can go back to UNCONFIRMED.
Comment 8 Jory A. Pratt gentoo-dev 2017-08-26 17:57:02 UTC
If you feel I have closed your bug and it is still a current issue, please reopen and update it completely. We will not work bugs that have no ebuild in tree any longer or can not be reproduced with a current system.

Thank You for your support and understanding
The Mozilla Team