Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 580890 - media-libs/glfw-2.7.7 - add multilib support
Summary: media-libs/glfw-2.7.7 - add multilib support
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-23 02:03 UTC by Hendrik v. Raven
Modified: 2017-04-29 09:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch against glfw-2.7.7 as it is found in the tree (glfw-2.7.7-multilib.patch,1.38 KB, patch)
2016-04-23 02:03 UTC, Hendrik v. Raven
Details | Diff
updated patch against glfw-2.7.7 with correct dependencies (glfw-2.7.7-multilib.patch,1.72 KB, patch)
2016-04-23 02:07 UTC, Hendrik v. Raven
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hendrik v. Raven 2016-04-23 02:03:10 UTC
Created attachment 431598 [details, diff]
patch against glfw-2.7.7 as it is found in the tree

libglfw.so.2 is used by Crypt of the Necrodancer which just exists as 32 bit binary.

I've made a multilib version of the ebuild in the tree and attached it.
Comment 1 Hendrik v. Raven 2016-04-23 02:07:17 UTC
Created attachment 431600 [details, diff]
updated patch against glfw-2.7.7 with correct dependencies

I forgot to add MULTILIB_USEDEP to the dependencies. This updated patch fixes that.